Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Set default screen brightness on Lenovo X220

  1. #11
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Set default screen brightness on Lenovo X220

    Okay. Which of the following commands affect brightness?
    Code:
    echo 15 | sudo tee /sys/class/backlight/acpi_video0/brightness
    Code:
    echo 6 | sudo tee /sys/class/backlight/acpi_video0/brightness
    Code:
    echo 2324 | sudo tee /sys/class/backlight/intel_backlight/brightness
    Code:
    echo 4648 | sudo tee /sys/class/backlight/intel_backlight/brightness

  2. #12
    Join Date
    Feb 2012
    Location
    Los Angeles, CA
    Beans
    138
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Set default screen brightness on Lenovo X220

    The following commands affected me this way...

    Maximized brightness.
    Code:
     echo 15 | sudo tee /sys/class/backlight/acpi_video0/brightness
    O.O - Set to current brightness
    Code:
     echo 6 | sudo tee /sys/class/backlight/acpi_video0/brightness
    I guess the best I can do is have the computer start at optimal brightness, not where I left off.
    John J. Kim (IRC: kotux)
    High School Senior / Ubuntu User # 35405
    www.launchpad.net/~kotux
    "Let your performance do the thinking." --Charlotte Bronte


  3. #13
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Set default screen brightness on Lenovo X220

    Quote Originally Posted by epikvision View Post
    I guess the best I can do is have the computer start at optimal brightness, not where I left off.
    To do so, edit /etc/rc.local and above the exit 0 command, add the line:
    Code:
    echo 6 > /sys/class/backlight/acpi_video0/brightness

  4. #14
    Join Date
    Feb 2012
    Location
    Los Angeles, CA
    Beans
    138
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Set default screen brightness on Lenovo X220

    Quote Originally Posted by Toz View Post
    To do so, edit /etc/rc.local and above the exit 0 command, add the line:
    Code:
    echo 6 > /sys/class/backlight/acpi_video0/brightness
    I did that, but it didn't work. This is what I got from running the script.

    Code:
     john@kotux:/etc$ sudo ./rc.local
    ./rc.local: 14: ./rc.local: cannot create /sys/class/backlight/acpi_vide0/brightness: Directory nonexistent
    John J. Kim (IRC: kotux)
    High School Senior / Ubuntu User # 35405
    www.launchpad.net/~kotux
    "Let your performance do the thinking." --Charlotte Bronte


  5. #15
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    4,315
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: Set default screen brightness on Lenovo X220

    try installing xbacklight and use lightdm to set it
    xbacklight -set 50
    the 50 is a percentage
    Code:
    ~$ cat /etc/lightdm/lightdm.conf 
    [SeatDefaults]
    greeter-session=lightdm-gtk-greeter
    user-session=xubuntu
    greeter-setup-script = sh -c 'xbacklight -set 50'
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  6. #16
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Set default screen brightness on Lenovo X220

    Quote Originally Posted by epikvision View Post
    I did that, but it didn't work. This is what I got from running the script.

    Code:
     john@kotux:/etc$ sudo ./rc.local
    ./rc.local: 14: ./rc.local: cannot create /sys/class/backlight/acpi_vide0/brightness: Directory nonexistent
    You misspelled acpi_video0. The command should be:
    Code:
    echo 6 > /sys/class/backlight/acpi_video0/brightness

  7. #17
    Join Date
    Feb 2012
    Location
    Los Angeles, CA
    Beans
    138
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Set default screen brightness on Lenovo X220

    Quote Originally Posted by Toz View Post
    You misspelled acpi_video0. The command should be:
    Code:
    echo 6 > /sys/class/backlight/acpi_video0/brightness
    Wow, all it took was a typo... Anyway, now it's all good. I'll consider the lightdm solution too for another machine, but finally, this issue has been conquered.

    Before I mark the thread as 'solved,' I would like to know if there is any development happening to allow screen brightness to match that of the current session by startup.
    John J. Kim (IRC: kotux)
    High School Senior / Ubuntu User # 35405
    www.launchpad.net/~kotux
    "Let your performance do the thinking." --Charlotte Bronte


  8. #18
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Set default screen brightness on Lenovo X220

    Quote Originally Posted by epikvision View Post
    Before I mark the thread as 'solved,' I would like to know if there is any development happening to allow screen brightness to match that of the current session by startup.
    I was hoping to solve this particular issue by using a kernel parameter. However, none seemed to work for your system. Hence the workaround. You may want to create a bug report if you want to follow up with a proper solution.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •