Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Set default screen brightness on Lenovo X220

  1. #1
    Join Date
    Feb 2012
    Location
    Los Angeles, CA
    Beans
    138
    Distro
    Ubuntu 12.04 Precise Pangolin

    Question Set default screen brightness on Lenovo X220

    I run Ubuntu 13.04 stable on my Thinkpad X220. One thing that has been bugging me is that the brightness always resets to full with every startup. I've also been searching for similar issues around the forum, but they go back to older versions of Ubuntu. Another trend I noticed was that setting the brightness varies between machines.

    Is there a way to adjust the screen brightness, so that every restart will keep my screen at current, in-session brightness? I'm guessing it involves editing grub.
    Last edited by epikvision; June 8th, 2013 at 01:31 AM.
    John J. Kim (IRC: kotux)
    High School Senior / Ubuntu User # 35405
    www.launchpad.net/~kotux
    "Let your performance do the thinking." --Charlotte Bronte


  2. #2
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Set default screen brightness on Lenovo X220

    Try using the acpi_osi="!Windows 2012" kernel parameter.

    Edit /etc/default/grub as root, and change:
    Code:
    GRUB_CMDLINE_LINUX=""
    ...to read:
    Code:
    GRUB_CMDLINE_LINUX="acpi_osi=\"!Windows 2012\""
    Save the file then run:
    Code:
    sudo update-grub
    ...and reboot.

  3. #3
    Join Date
    Feb 2012
    Location
    Los Angeles, CA
    Beans
    138
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Set default screen brightness on Lenovo X220

    I did that, but after reboot, my screen is still back to 100% brightness at the login screen.

    Can you explain why we need to set 'Windows 7' as a parameter? Is it because the laptop was once a Windows 7 machine?
    John J. Kim (IRC: kotux)
    High School Senior / Ubuntu User # 35405
    www.launchpad.net/~kotux
    "Let your performance do the thinking." --Charlotte Bronte


  4. #4
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Set default screen brightness on Lenovo X220

    There was a change in kernel 3.8 to deal with the way that Windows 8 deals with brightness. As I understand it, the acpi brightness values were reversed??. This particular parameter tells the bios that the O/S is not Windows 8.

    Can you try acpi_backlight=vendor (use vendor backlight controls, not acpi controls) instead? If that doesn't work, you might want to try acpi_osi= (don't report an O/S to the bios).

    References:
    - http://msdn.microsoft.com/en-us/libr.../jj159305.aspx
    - https://bbs.archlinux.org/viewtopic.php?id=147804 (specifically post #18)
    Last edited by Toz; May 12th, 2013 at 03:55 AM.

  5. #5
    Join Date
    Feb 2012
    Location
    Los Angeles, CA
    Beans
    138
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Set default screen brightness on Lenovo X220

    Sorry for the late reply, but neither of those solutions have worked for me. I still have full backlight after reboot.
    John J. Kim (IRC: kotux)
    High School Senior / Ubuntu User # 35405
    www.launchpad.net/~kotux
    "Let your performance do the thinking." --Charlotte Bronte


  6. #6
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Set default screen brightness on Lenovo X220

    Can you post back the results of the following commands:

    1. What video card(s) do you have:
    Code:
    sudo lspci -vnn | grep -A12 VGA
    2. What kernel parameters are you currently using:
    Code:
    cat /proc/cmdline
    3. What backlight interfaces do you have:
    Code:
    for interface in /sys/class/backlight/*; do echo $interface; cat $interface/brightness; cat $interface/max_brightness; done

  7. #7
    Join Date
    Feb 2012
    Location
    Los Angeles, CA
    Beans
    138
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Set default screen brightness on Lenovo X220

    My graphics card.
    Code:
    john@kotux:~$ sudo lspci -vnn | grep -A12 VGA
    [sudo] password for john: 
    00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Lenovo Device [17aa:21da]
        Flags: bus master, fast devsel, latency 0, IRQ 41
        Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 6000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [a4] PCI Advanced Features
        Kernel driver in use: i915
    
    00:16.0 Communication controller [0780]: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 [8086:1c3a] (rev 04)
    Kernel parameters
    Code:
    john@kotux:~$ cat /proc/cmdline
    BOOT_IMAGE=/vmlinuz-3.9.0-2-generic root=/dev/mapper/ubuntu--vg-root ro acpi_osi= quiet splash vt.handoff=7
    Backlight
    Code:
    john@kotux:~$ for interface in /sys/class/backlight/*; do echo $interface; cat $interface/brightness; cat $interface/max_brightness; done
    /sys/class/backlight/acpi_video0
    5
    15
    /sys/class/backlight/intel_backlight
    4648
    4648
    Last edited by epikvision; May 17th, 2013 at 09:28 PM. Reason: Added 'kernel parameters'
    John J. Kim (IRC: kotux)
    High School Senior / Ubuntu User # 35405
    www.launchpad.net/~kotux
    "Let your performance do the thinking." --Charlotte Bronte


  8. #8
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Set default screen brightness on Lenovo X220

    Why are you using the acpi_osi= kernel prameter? Does it fix an issue for you?

    Can you remove the acpi_osi= kernel parameter, add the acpi_backlight=vendor kernel parameter, reboot, then post back the results of those commands again? And also check brightness.

  9. #9
    Join Date
    Feb 2012
    Location
    Los Angeles, CA
    Beans
    138
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Set default screen brightness on Lenovo X220

    Graphics card.
    Code:
    john@kotux:~$ sudo lspci -vnn | grep -A12 VGA
    [sudo] password for john:
    00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Lenovo Device [17aa:21da]
        Flags: bus master, fast devsel, latency 0, IRQ 41
        Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 6000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [a4] PCI Advanced Features
        Kernel driver in use: i915
    
    00:16.0 Communication controller [0780]: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 [8086:1c3a] (rev 04)
    Kernel parameters
    Code:
    john@kotux:~$ cat /proc/cmdline
    BOOT_IMAGE=/vmlinuz-3.9.0-2-generic root=/dev/mapper/ubuntu--vg-root ro acpi_backlight=vendor quiet splash vt.handoff=7
    When I made the change, changing brightness with the brightness keys behave abnormally. The notifications for changing brightness is static, but the function keys work; The brightness is still full.

    Backlight
    Code:
    john@kotux:~$ for interface in /sys/class/backlight/*; do echo $interface; cat $interface/brightness; cat $interface/max_brightness; done
    /sys/class/backlight/acpi_video0
    6
    15
    /sys/class/backlight/intel_backlight
    4648
    4648
    Perhaps, the problem is in here? Do I have to modify something?
    John J. Kim (IRC: kotux)
    High School Senior / Ubuntu User # 35405
    www.launchpad.net/~kotux
    "Let your performance do the thinking." --Charlotte Bronte


  10. #10
    Join Date
    Feb 2012
    Location
    Los Angeles, CA
    Beans
    138
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Set default screen brightness on Lenovo X220

    For my kernel parameters, both "acpi_osi=" and "acpi_osi=\"!Windows 2012\"" function properly but still yield max brightness at reboot. The "acpi_backlight=vendor" doesn't really.
    John J. Kim (IRC: kotux)
    High School Senior / Ubuntu User # 35405
    www.launchpad.net/~kotux
    "Let your performance do the thinking." --Charlotte Bronte


Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •