Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: [SOLVED]Enable Numlock after booting - Lubuntu 13.04 / Xubuntu 12.04 LTS

  1. #11
    Join Date
    May 2013
    Beans
    10

    Re: Enable Numlock after booting

    I looked into the warning and as I understand that should have no influence on the numlock issue and could be ignored. So I'll keep to have looking.

    Well, that's unless you didn't log into your DE* and logged into bash**, that wouldn't start the Xsession which in turn wouldn't start numlockx either.
    Can somebody tell me how to know the difference of * & ** and how to activate the Xsession process.

  2. #12
    Join Date
    May 2010
    Location
    uk
    Beans
    9,305
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Enable Numlock after booting

    Hi

    Try this.

    Copy and paste these lines into the terminal.

    Code:
    echo "/usr/bin/numlockx on" | sudo tee /usr/share/enable_numlock.sh
    Code:
    sudo chmod 755 /usr/share/enable_numlock.sh
    Code:
    echo 'session-setup-script=/usr/share/enable_numlock.sh' | sudo tee -a /etc/lightdm/lightdm.conf
    Reboot and tell us if it works.

    EDIT:

    You may want to run...

    Code:
    echo 'display-setup-script=/usr/share/enable_numlock.sh' | sudo tee -a /etc/lightdm/lightdm.conf
    ..as i think display-setup-script gets called after X is started.

    Kind regards
    Last edited by matt_symes; May 12th, 2013 at 08:33 PM. Reason: Added full path !!
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

  3. #13
    Join Date
    Dec 2007
    Location
    green bay, wi
    Beans
    2,229
    Distro
    Xubuntu 14.04 Trusty Tahr

    Lightbulb Re: Enable Numlock after booting

    try this use this script
    #!/bin/bash
    echo xxxx | sudo -S NumLock on

    replace xxx with your user name. name it whatever put in home folder. then open up the script go to permissions and check execute:allow executing file as program.
    then add it to your session and startup folder. worked for me . to check after you login open up your terminal program and type numlockx status you should get the response Numlock is on.

  4. #14
    Join Date
    May 2013
    Beans
    10

    Re: Enable Numlock after booting

    Matt, I tried what you suggested but after reboot numlock still off.
    Rburkartjo, also tried what you suggested. The strange thing here is that I don't get the time in the terminal to enter my password. I immediately get following error:
    schoonjans@Vic1:~$ echo schoonjans | sudo -S NumLock on
    [sudo] password for schoonjans: Sorry, try again.
    [sudo] password for schoonjans:
    sudo: 1 incorrect password attempt
    Remark: I din't type my pasword yet!

  5. #15
    Join Date
    May 2010
    Location
    uk
    Beans
    9,305
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Enable Numlock after booting

    Hi

    Quote Originally Posted by Koenraads View Post
    Matt, I tried what you suggested but after reboot numlock still off.
    Did you see my edit of my last post and use this one with display-setup-script.

    Code:
    echo 'display-setup-script=/usr/share/enable_numlock.sh' | sudo tee -a /etc/lightdm/lightdm.conf
    Just tried it on a laptop with no numlock key, using gb keymap and non gb keyboard (still in the process of setting it up) and it would not let me log in so numlockx did something.

    If you try it on yours, where you have a numlock key, the correct keyboard and mapping, using display-setup-script and not session-setup-script, it may work.

    Of course, if you tried both display-setup-script and session-setup-script then disregard this post

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

  6. #16
    Join Date
    Dec 2007
    Location
    green bay, wi
    Beans
    2,229
    Distro
    Xubuntu 14.04 Trusty Tahr

    Lightbulb Re: Enable Numlock after booting

    Koe on the script i gave you dont have to enter your password to activate.

  7. #17
    Join Date
    Mar 2005
    Location
    Lancashire, NW England UK
    Beans
    169
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: [SOLVED]Enable Numlock after booting - Lubuntu 13.04 / Xubuntu 12.04 LTS

    Quote Originally Posted by Koenraads View Post
    This solution worked for me on both operating systems. ( Lubuntu 13.04 / Xubuntu 12.04 LTS)

    sudo apt-get install numlockx
    sudo leafpad /etc/lightdm/lightdm.conf
    add the next line at the end
    greeter-setup-script=/usr/bin/numlockx on
    Thanks for this post, this solution also worked for me on Lubuntu 13.04 fresh install.
    Momist. Follower of the minor Greek god Momer.

  8. #18
    Join Date
    Feb 2013
    Beans
    2

    Re: [SOLVED]Enable Numlock after booting - Lubuntu 13.04 / Xubuntu 12.04 LTS

    Quote Originally Posted by Koenraads View Post
    This solution worked for me on both operating systems. ( Lubuntu 13.04 / Xubuntu 12.04 LTS)

    sudo apt-get install numlockx
    sudo leafpad /etc/lightdm/lightdm.conf
    add the next line at the end
    greeter-setup-script=/usr/bin/numlockx on

    Just to confirm that this also works for Kubuntu 13.10 (although I used kate instead of leafpad). I was not able to get numlocks on any other way (including built in settings controls)

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •