Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 42

Thread: Ubuntu 13.04 mini: LXDE not working

  1. #31
    Join Date
    Nov 2009
    Beans
    Hidden!

    Re: Ubuntu 13.04 mini: LXDE not working

    Could you please elaborate on exactly what is the same? The output of ck-list-sessions should now include an X11 entry under LXDE. Otherwise I failed to achieve behaviour I consider optimal for your situation.
    linux-git/fs/super.c: "Self-destruct in 5 seconds. Have a nice day...\n",

  2. #32
    Join Date
    May 2013
    Beans
    22

    Re: Ubuntu 13.04 mini: LXDE not working

    I'm sorry, I'll try to be more precise.

    Whenever I try to login using lxdm, after login and password I obtain a solid blue background and the mouse pointer. The pointer is moving, but clicks do nothing (no Openbox menu).
    Xoomer.ap obtained the same with a virtual machine and posted a picture: http://img856.imageshack.us/img856/6...0514215001.png
    As I said in my first post, I had this problem after update from Ubuntu 12.10 64 bit to 13.04. I started from the mini iso and added lxde. The same occur if I start from the new 13.04 64 bit mini iso, in virtual machine or on another computer. With gdm everything works fine.

    After the addition of the lines you suggested, the differences in the output of set disappeared, but with lxdm ck-list-session continues to show only the tty session (no X11).

  3. #33
    Join Date
    Nov 2009
    Beans
    Hidden!

    Re: Ubuntu 13.04 mini: LXDE not working

    When you start LXDE, do you see a process called 'ck-launch-session' ?
    linux-git/fs/super.c: "Self-destruct in 5 seconds. Have a nice day...\n",

  4. #34
    Join Date
    May 2013
    Beans
    22

    Re: Ubuntu 13.04 mini: LXDE not working

    Quote Originally Posted by Rexilion View Post
    When you start LXDE, do you see a process called 'ck-launch-session' ?
    No, I do not have any ck-launch-session running prior or after my login with lxdm.
    The only new processes that showed up with a ps -e after loggin in (i.e. while I have the solid background and the mouse pointer) are:
    Code:
    gnome-keyring-d
    lxdm-binary
    PreLogin <defunct>
    And after a minute or so I found also 'kworker/0:0'.

  5. #35
    Join Date
    Nov 2009
    Beans
    Hidden!

    Re: Ubuntu 13.04 mini: LXDE not working

    I'm trying this dirty hack just to test something. We create a file called startlxde_custom in /usr/bin. Modify /etc/lxdm/lxdm.conf to make that the default session.

    /usr/bin/startlxde_custom
    Code:
    exec dbus-launch ck-launch-session /usr/bin/startlxde
    Code:
    chown 0:0 /usr/bin/startlxde_custom
    chmod 755 /usr/bin/startlxde_custom
    /etc/lxdm/lxdm.conf
    Replace:
    Code:
    # session=/usr/bin/startlxde
    with:
    Code:
    session=/usr/bin/startlxde_custom
    Now try again please.
    linux-git/fs/super.c: "Self-destruct in 5 seconds. Have a nice day...\n",

  6. #36
    Join Date
    May 2013
    Beans
    22

    Re: Ubuntu 13.04 mini: LXDE not working

    I always get the solid blue background, and also the same processes (no ck-launch-session).

  7. #37
    Join Date
    Nov 2009
    Beans
    Hidden!

    Re: Ubuntu 13.04 mini: LXDE not working

    Then it seems that lxdm did not use /usr/bin/startlxde_custom . Can you look for an 'default' option or something?

    There should be a ck-launch-session and dbus-launch session when startlxde_custom is used as a session initiator.
    linux-git/fs/super.c: "Self-destruct in 5 seconds. Have a nice day...\n",

  8. #38
    Join Date
    May 2013
    Beans
    22

    Re: Ubuntu 13.04 mini: LXDE not working

    Trying to get around this, I moved /usr/bin/startlxde to /usr/bin/startlxde_original and /usr/bin/startlxde_custom to /usr/bin/startlxde (and modified the last one to launch "original"), but nothing changed.

  9. #39
    Join Date
    May 2013
    Beans
    22

    Re: Ubuntu 13.04 mini: LXDE not working

    I'm going to try Ubuntu mini 12.10 in a vm to check the differences in config files.

  10. #40
    Join Date
    Nov 2009
    Beans
    Hidden!

    Re: Ubuntu 13.04 mini: LXDE not working

    Maybe try to look at /usr/share/xsessions and see what is in there.
    linux-git/fs/super.c: "Self-destruct in 5 seconds. Have a nice day...\n",

Page 4 of 5 FirstFirst ... 2345 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •