Results 1 to 6 of 6

Thread: Destination unreachable

  1. #1
    Join Date
    Sep 2007
    Location
    Oklahoma, USA
    Beans
    2,283
    Distro
    Xubuntu 14.04 Trusty Tahr

    Destination unreachable

    I'm continually getting error messages from my local DNS server, such as this small example:
    Code:
    May  8 10:43:54 mehitabel named[1086]: error (network unreachable) resolving 'sa.bbc.com/A/IN': 2001:503:231d::2:30#53
    May  8 10:43:54 mehitabel named[1086]: error (network unreachable) resolving 'sa.bbc.com/A/IN': 2001:503:a83e::2:30#53
    May  8 10:43:54 mehitabel named[1086]: error (network unreachable) resolving 'static.bbc.co.uk/A/IN': 2001:502:ad09::3#53
    May  8 10:43:54 mehitabel named[1086]: error (network unreachable) resolving 'static.bbc.co.uk/A/IN': 2a01:40:1001:35::2#53
    May  8 10:43:55 mehitabel named[1086]: error (network unreachable) resolving 'open.live.bbc.co.uk/A/IN': 2001:502:ad09::3#53
    May  8 10:43:55 mehitabel named[1086]: error (network unreachable) resolving 'secure-us.imrworldwide.com/A/IN': 2001:503:231d::2:30#53
    May  8 10:43:57 mehitabel named[1086]: success resolving 'secure-us.imrworldwide.com/A' (in 'imrworldwide.com'?) after reducing the advertised EDNS UDP packet size to 512 octets
    May  8 10:43:57 mehitabel named[1086]: success resolving 'open.live.bbc.co.uk/A' (in 'bbc.co.uk'?) after reducing the advertised EDNS UDP packet size to 512 octets
    However I've attempted to turn off EDNS in named.conf, and also to limit its packet size to 512 octets.

    The strange thing I notice is that all of these messages deal with v6 addresses; they never show a v4 address. All of the threads I've found on Google indicate a firewall problem, but I have no v6 firewall configured... Any ideas to help me troubleshoot this? Could it be a problem at my ISP's servers, which I've configured as forwarders?

    EDIT: Attempting to do "nslookup" on the addresses returns "Host unknown" from my ISP's server; AT&T apparently doesn't yet support DNS for v6!
    Last edited by JKyleOKC; May 9th, 2013 at 03:46 PM. Reason: add information
    --
    Jim Kyle in Oklahoma, USA
    Linux Counter #259718
    Howto mark thread: https://wiki.ubuntu.com/UnansweredPo.../SolvedThreads

  2. #2
    Join Date
    Jan 2008
    Location
    Ohio
    Beans
    71
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Destination unreachable

    If you want to disable IPV6 I found this post for you...
    http://ubuntuforums.org/showthread.p...ight=turn+ipv6
    Warprunner
    This is one race of people for whom psychoanalysis is of no use whatsoever.
    ...Sigmund Freud (about the Irish)

  3. #3
    Join Date
    Sep 2007
    Location
    Oklahoma, USA
    Beans
    2,283
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Destination unreachable

    Do you think that will work on Lucid? I noted that Karmic moved the support from a module into the kernel itself, so I apparently need a kernel parameter to turn it off. And I'll be moving to 12.04 soon since Lucid is about to go EOL...
    --
    Jim Kyle in Oklahoma, USA
    Linux Counter #259718
    Howto mark thread: https://wiki.ubuntu.com/UnansweredPo.../SolvedThreads

  4. #4
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Destination unreachable

    Quote Originally Posted by Warprunner View Post
    If you want to disable IPV6 I found this post for you...
    http://ubuntuforums.org/showthread.p...ight=turn+ipv6
    Wow! A post from 2005! Didn't read much after reading the date

    As for current versions, this is how IPv6 is disabled permanently (of course can be reverted if required so) -
    Add these lines to the /etc/sysctl.conf file :
    # disable IPv6
    net.ipv6.conf.all.disable_ipv6=1
    net.ipv6.conf.default.disable_ipv6=1
    net.ipv6.conf.lo.disable_ipv6=1
    A single command to do this :
    Code:
    echo -e "\n# disable IPv6\nnet.ipv6.conf.all.disable_ipv6=1\nnet.ipv6.conf.default.disable_ipv6=1\nnet.ipv6.conf.lo.disable_ipv6=1" | sudo tee -a /etc/sysctl.conf
    Additionally, set IPv6 "Method" to "Ignore" in Network Manager.
    Hopefully this gets rid of the error messages.


    PS:
    Apparently, Lucid Desktop, along with Hardy Server, reached its EOL today : https://wiki.ubuntu.com/Releases
    Although the repositories will stay there for a while before they'll be moved from archive.ubuntu.com to old-releases.ubuntu.com
    Last edited by varunendra; May 9th, 2013 at 05:37 PM. Reason: added info about EOL
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  5. #5
    Join Date
    Sep 2007
    Location
    Oklahoma, USA
    Beans
    2,283
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Destination unreachable

    Many thanks! I've totally disabled Network Manager on this system, and use the interfaces file instead. I'll be staying with Lucid for a few more weeks, since I have some 300 GB of VMs on it that I'll need to back up for safety before starting to upgrade, and it'll then take me at least a week to get all my servers that run on the system (DNS, FTP, PostFix, and LAN router) back into action after making the change!
    --
    Jim Kyle in Oklahoma, USA
    Linux Counter #259718
    Howto mark thread: https://wiki.ubuntu.com/UnansweredPo.../SolvedThreads

  6. #6
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Destination unreachable

    Quote Originally Posted by JKyleOKC View Post
    ...since I have some 300 GB of VMs..
    .... only?
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •