Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Mobility Radeon HD 4830 on 13.04 x64, no hardware acceleration

  1. #11
    Join Date
    Apr 2006
    Location
    Seattle, WA
    Beans
    15
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Mobility Radeon HD 4830 on 13.04 x64, no hardware acceleration

    Quote Originally Posted by Temüjin View Post
    Yeah, I've seen a few other radeon users struggle with that issue. If you hit it again, it would be worth trying newer kernels: http://kernel.ubuntu.com/~kernel-ppa...e/v3.9-raring/
    Thank you so much for this idea! I was able to resolve these issues by installing the newest v3.9-raring kernel and then making a couple of changes to to /etc/default/grub.

    Installing the mainline kernel

    You can install a new kernel without overwriting your old one. Often newer kernels will have fixes that aren't in the older one provided by the distribution.

    Point your browser at http://kernel.ubuntu.com/~kernel-ppa...e/v3.9-raring/. You'll need to download 3 files from here. Two are deb package files containing the kernel headers and kernel image for your architecture, respectively (in my case amd64 for a x86_64 cpu). The other one is architecture independent headers. If you follow these instructions be sure to download the files for the right architecture for your machine.

    At this time v3.9-raring is the newest mainline kernel tested with raring so that is what I used, but others can be found at http://kernel.ubuntu.com/~kernel-ppa/mainline/.

    First download the three debs. You can either download with your browser or pull them down with wget at the terminal:
    Code:
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-raring/linux-headers-3.9.0-030900-generic_3.9.0-030900.201304291257_amd64.deb
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-raring/linux-image-3.9.0-030900-generic_3.9.0-030900.201304291257_amd64.deb
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-raring/linux-headers-3.9.0-030900_3.9.0-030900.201304291257_all.deb
    Once they are downloaded, put the three files in a directory by themselves, cd to that directory in your terminal and install them with dpkg. For example:
    Code:
    cd ~/Downloads/v3.9-raring
    sudo dpkg -i *.deb
    # update the bootloader to know that the new kernel is installed
    sudo update-grub
    Testing the kernel

    At this point you could reboot and test the kernel. It might just work. On the other hand, like in my case, it might need additional kernel parameters to work correctly. The basics have been discussed elsewhere.

    I changed the following two lines in /etc/default/grub to read as follows:

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="modeset=0 acpi_osi=linux vesafb.nonsense=1"
    
    [...]
    
    GRUB_GFXPAYLOAD_LINUX=text
    Then be sure to run
    Code:
    sudo update-grub
    to install these settings to the bootloader.

    Reboot

    Reboot into grub and select your new kernel and press enter. Hopefully it works. If not, you may have to tweak some of the settings.

    Note: Other have apparently had luck using just "acpi_osi=" in case the above doesn't work. If you have the same computer as me hopefully the above works fine.

    Recap

    The 3.9.0 kernel works perfectly so far AND there is the added bonus of it fixing another bug that was causing the radeon driver to spam /var/log/syslog with 5 warnings or so per second.

    I intend to file a bug report for my kernel issues. The few times I was able to boot 3.8.0 without the "nomodeset" kernel parameter the system was extremely unstable and would often lock up completely while loading up lightdm, while logging in, or shortly after logging in. Most of the time it locked up before that, or I just got a black screen and had no idea what was going on. The 3.9.0 kernel seems to not have such issues, at least not with the kernel parameters I am using now.

    Cheers!

  2. #12
    Join Date
    Apr 2006
    Location
    Seattle, WA
    Beans
    15
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Mobility Radeon HD 4830 on 13.04 x64, no hardware acceleration

    I may have spoken too soon. The above worked for one boot, then I wasn't able to boot it again even with identical settings. The inconsistency is killing me.

    In the mean time I noticed 3.8.0-21-generic kernel was now available on apt so I installed that. I was able to boot that once with default grub settings --> literally just "quiet splash $vt_handoff" on the kernel line in the grub setup. I thought great, rebooted, tried the same exact thing and got a black screen.

    I tried modeset=0 apci_osi=linux parameters: Worked fine with hardware acceleration
    Rebooted and tried the exact same settings: Hung at loading the ramdisk forever

    Later it worked with only "acpi_osi=linux vesafb.nonsense=1", but after putting that in GRUB_CMDLINE_LINUX_DEFAULT, running update-grub and rebooting it ALSO gave me a black screen.

    Is it possible that grub is changing something the second time it boots a kernel with particular settings? If so, how do I stop it from doing that?


  3. #13
    Join Date
    Dec 2007
    Beans
    1

    Re: Mobility Radeon HD 4830 on 13.04 x64, no hardware acceleration

    Have you found a solution?
    I have the same problem.

    Code:
    01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV740/M97 [Mobility Radeon HD 4830] [1002:94a0]
    LIBGL_DEBUG=verbose glxinfo:

    http://pastebin.com/vXrjT16E

    Code:
    lsb_release -a:
    
    LSB Version:	core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:cxx-3.0-amd64:cxx-3.0-noarch:cxx-3.1-amd64:cxx-3.1-noarch:cxx-3.2-amd64:cxx-3.2-noarch:cxx-4.0-amd64:cxx-4.0-noarch:desktop-3.1-amd64:desktop-3.1-noarch:desktop-3.2-amd64:desktop-3.2-noarch:desktop-4.0-amd64:desktop-4.0-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.0-amd64:graphics-3.0-noarch:graphics-3.1-amd64:graphics-3.1-noarch:graphics-3.2-amd64:graphics-3.2-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-3.2-amd64:printing-3.2-noarch:printing-4.0-amd64:printing-4.0-noarch:qt4-3.1-amd64:qt4-3.1-noarch
    Distributor ID:	Ubuntu
    Description:	Ubuntu 13.04
    Release:	13.04
    Codename:	raring
    Xorg.0.log:

    http://pastebin.com/UYVQk42Y

    It always works fine on a first boot. Can I force it to do what ever it does on the first boot?
    Last edited by Nisk; September 7th, 2013 at 10:42 PM.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •