Results 1 to 6 of 6

Thread: error building Postfix 2.8.5

  1. #1
    Join Date
    May 2013
    Beans
    2

    error building Postfix 2.8.5

    Hello
    new to Ubuntu (now 11.10) and new to Postfix.
    I'm trying to rebuild Postfix 2.8.5 starting from the apt source code.
    I'm aware I can use the distribution package, but I need to modify the source code to meet my needs.
    Before starting with modification, I'm trying to rebuild the code.

    apt-get source postfix (2.8.5)
    make
    ../../lib/libutil.a: undefined reference to `dict_pcre_open'
    ../../lib/libutil.a: undefined reference to `dict_tcp_open'

    I'm unable to find a solution.
    BTW: did a try with Ubuntu 12.04.2, Postfix 2.9.6, got the same error.

  2. #2
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: error building Postfix 2.8.5

    you can download the deb package you need from : https://launchpad.net/ubuntu/+source/postfix , into an empty folder, then cd to that folder, and run : sudo dpkg -i *

    but why does not using the version inside your installation ?

  3. #3
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: error building Postfix 2.8.5

    Make sure you have all of the postfix build dependencies installed...
    Code:
    sudo apt-get build-dep postfix
    Cheesemill

  4. #4
    Join Date
    Nov 2008
    Location
    Storybrooke
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: error building Postfix 2.8.5

    Quote Originally Posted by reinold View Post
    Hello
    new to Ubuntu (now 11.10) and new to Postfix.
    I'm trying to rebuild Postfix 2.8.5 starting from the apt source code.
    I'm aware I can use the distribution package, but I need to modify the source code to meet my needs.
    Before starting with modification, I'm trying to rebuild the code.

    apt-get source postfix (2.8.5)
    make
    ../../lib/libutil.a: undefined reference to `dict_pcre_open'
    ../../lib/libutil.a: undefined reference to `dict_tcp_open'

    I'm unable to find a solution.
    BTW: did a try with Ubuntu 12.04.2, Postfix 2.9.6, got the same error.
    Have you tried with debuild?
    Sometimes, there are patches included in the source package that need to be used in order to compile it properly.
    Ubuntu Forums Moderation Staff
    Don't waste your energy trying to change opinions ... Do your thing, and don't care if they like it.

  5. #5
    Join Date
    May 2013
    Beans
    2

    Re: error building Postfix 2.8.5

    Thank you sandyd, I found the yellow bricks.
    I switched to 12.04.2, where, first of all, I was unable to make changes to sasl sql plugin.
    Debuild is a quite long way.
    Can you please suggest me a tutorial (not the man pages) to debuild?
    I suppose there's a quick way to rebuld next packages for debugging.

  6. #6
    Join Date
    Nov 2008
    Location
    Storybrooke
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: error building Postfix 2.8.5

    /me fishes around my brain for a second (its been a while since ive built from source...)
    Note that the below has a *few* hacks which may not work so well for other releases

    Code:
    apt-get source postfix
    sudo apt-get install devscripts
    sudo apt-get build-dep postfix
    cd postfix*
    cd debian
    Edit the files

    Now, generate a new GPG key with your name and email
    Code:
    nano changelog
    Carefully add the following to the front of the file (exactly as it is, replacing my name and email with yours, debuild is fussy about spaces)
    Code:
    postfix (2.10.0-20) unstable; urgency=low
    
      * Repackaging
    
     -- Celene Barjaval <celene@nowhere.com>  Fri, 10 Mar 2013 06:26:29 -0800
    Save the file by pressing control +x
    Code:
    cd ../
    debuild -D
    and you are done. You should have some deb files outside of the folder, and those are the ones that relate to postfix

    Note that this package *will* upgrade itself when the version in the repositories is newer than the current version (currently set to 2.10.0-20)

    If your bored enough, you can even run
    Code:
    debuild -S
    and upload the resulting source files to a PPA so that they can be compiled on there instead of your computer

    If it results in an error along the lines of missing files, recompress the folder into postfix_2.10.0.orig.tar.gz
    Last edited by sandyd; May 10th, 2013 at 02:35 PM.
    Ubuntu Forums Moderation Staff
    Don't waste your energy trying to change opinions ... Do your thing, and don't care if they like it.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •