Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Ubuntu 13.04 sound gone

  1. #1
    Join Date
    Dec 2012
    Beans
    50

    Ubuntu 13.04 sound gone

    There was no update I know of, but sound suddenly stopped working (It was working right since I installed fresh 13.04 ~ month ago). Now I get only dummy outputs. The card is probably detected though:

    Code:
    petr@sova:~$ cat /proc/asound/cards
     0 [PCH            ]: HDA-Intel - HDA Intel PCH
                          HDA Intel PCH at 0xd9400000 irq 51
    screenshot_2013-05-08-07-51-25.png screenshot_2013-05-08-07-51-16.png

    I tried purging and reinstalling alsa-base and pulseaudio as in Dummy output - No Sound Card Detected / snd-hda-intel - (Karmic), but to no avail. What should I do?

    Code:
    petr@sova:~$ uname -a
    Linux sova 3.8.0-19-generic #30-Ubuntu SMP Wed May 1 16:35:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
    petr@sova:~$ lsb_release -a
    No LSB modules are available.
    Distributor ID:    Ubuntu
    Description:    Ubuntu 13.04
    Release:    13.04
    Codename:    raring
    Could it be related to another problem I started having? Xubuntu splash hangs on boot for 15s on askubuntu.

  2. #2
    Join Date
    Dec 2012
    Beans
    50

    Re: Ubuntu 13.04 sound gone

    I found out that some user 109 is blocking my pulseaudio

    Code:
    petr@sova:~$ ps -ef | grep pulseaudio
    109       1515     1  1 15:23 ?        00:00:00 /usr/bin/pulseaudio --start --log-target=syslog
    petr      2344     1  0 15:24 ?        00:00:00 /usr/bin/pulseaudio --start --log-target=syslog
    petr      2807  2757  0 15:24 pts/1    00:00:00 grep --color=auto pulseaudio
    Once I kill the 1515 process, the sound card is recognized and I can play sound again! Now, what is blocking it and who the hell is user 109?

    I've read somewhere, that GDM can monopolize pulseaudio. However, I don't use GDM as I am on Xubuntu 13.04, so I have (probably) LightDM. How can I stop it from stealing my sound?

  3. #3
    Join Date
    Dec 2012
    Beans
    3

    Re: Ubuntu 13.04 sound gone

    Thanks for posting. I am having the same problem (Ubuntu 13.04) and killing the offending process (for uid 109) re-enabled my audio.

  4. #4
    Join Date
    Jan 2012
    Beans
    17

    Re: Ubuntu 13.04 sound gone

    I am also affected by this problem, I'm currently using Ubuntu 13.04, except there is no process 109 when the dummy output is created, and it seems to happen randomly. I have an Asus U56E-BBL6 with a Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller. Any help would be greatly appreciated.

  5. #5
    Join Date
    May 2013
    Beans
    21

    Re: Ubuntu 13.04 sound gone

    I also met this problem in April, I solved by reinstall xubuntu, as reinstallation of drivers seems no help

  6. #6
    Join Date
    Dec 2012
    Beans
    50

    Re: Ubuntu 13.04 sound gone

    Well I don't want to reinstall as I have a lot of applications installed and set up. Luckily, you don't have to reboot Ubuntu that often, so I'll just stick with hibernating Once I have to reboot, I'll sudo pkill pulseaudio.

    I still hope that it get's fixed by some updates. Upgrading kernel to 3.9 doesn't help.

  7. #7
    Join Date
    Dec 2012
    Beans
    3

    Re: Ubuntu 13.04 sound gone

    @mreq: I solved my problem with the uid 109 process and pulseaudio...

    I previously had a problem with Ubuntu 13.04 shutting down. The console message at shutdown said something like "speech-dispatcher is disabled: edit /etc/default/speech-dispatcher to enable it". So I enabled speech-dispatcher. Seems like uid 109 is the speech-dispatcher. So I disabled speech-dispatcher and rebooted, and now I have sound again.

  8. #8
    Join Date
    Dec 2012
    Beans
    50

    Re: Ubuntu 13.04 sound gone

    Strange. How did you disable it? I tried to uninstall it, but the lightdm didn't show up. Had to drop to tty1 and reinstall it.

  9. #9
    Join Date
    Dec 2012
    Beans
    3

    Re: Ubuntu 13.04 sound gone

    I edited the /etc/default/speech-dispatcher file:

    $ sudo cat /etc/default/speech-dispatcher
    [sudo] password for dsana123:
    # Defaults for the speech-dispatcher initscript, from speech-dispatcher


    # Set to yes to start system wide Speech Dispatcher
    RUN=no

  10. #10
    Join Date
    Dec 2012
    Beans
    50

    Re: Ubuntu 13.04 sound gone

    Aha, thanks! Will see the results once I can reboot the pc and write it here.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •