Results 1 to 6 of 6

Thread: Desktop icon issue Gnome Ubuntu 13.04

  1. #1
    Join Date
    Jan 2011
    Beans
    117

    Desktop icon issue Gnome Ubuntu 13.04

    I have been using Gnome Ubuntu 13.04. I updated to Gnome 3.8 and all is well. Not happy with Nautilus 3.6 in Unity or Gnome Ubuntu I try PCmanFM. My system begins to reboot at will, although PCmanFM is fast. I noticed that although Desktop icons are enabled in Gnome-tweak-tool, there are no desktop icons.

    I try Thunar File Manager. Very fast like PcmanFM but still no Desktop icons. How do I fix this?

  2. #2
    Join Date
    May 2013
    Beans
    25

    Re: Desktop icon issue Gnome Ubuntu 13.04

    I think there is problem with your icon cache.
    try to run this bash script using
    Code:
    sudo
    Code:
    for i in /usr/share/icons/*;do  gtk-update-icon-cache -f $i; done

  3. #3
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Desktop icon issue Gnome Ubuntu 13.04

    Also remember that desktop, including all the icons, is handled by the file manager. So by default the icons are handled by Nautilus, and if you stop Nautilus from starting on login and use some other file manager instead, you need to set that file amnager to handle the desktop. Both Thunar and PCMAnFM should have the option.

  4. #4
    Join Date
    Jan 2011
    Beans
    117

    Re: Desktop icon issue Gnome Ubuntu 13.04

    I get the following error when running sudo for i in /usr/share/icons/*;do gtk-update-icon-cache -f $i; done

    bash: syntax error near unexpected token `do'

    Thanks in advance for any help!

    Edit: I did it wrong. I logged in as gnome root terminal and put in for "i in /usr/share/icons/*;do gtk-update-icon-cache -f $i; done"


    gtk-update-icon-cache: No theme index file.
    gtk-update-icon-cache: No theme index file.
    gtk-update-icon-cache: No theme index file.
    gtk-update-icon-cache: Cache file created successfully.
    gtk-update-icon-cache: Cache file created successfully.
    gtk-update-icon-cache: Cache file created successfully.
    gtk-update-icon-cache: Cache file created successfully.
    gtk-update-icon-cache: Cache file created successfully.
    gtk-update-icon-cache: No theme index file.
    gtk-update-icon-cache: No theme index file.
    gtk-update-icon-cache: No theme index file.
    gtk-update-icon-cache: Cache file created successfully.
    gtk-update-icon-cache: No theme index file.

    Unfortunately, it didn't work, still no Desktop icons.
    Last edited by chazdg24; May 8th, 2013 at 03:11 PM.

  5. #5
    Join Date
    Jan 2011
    Beans
    117

    Re: Desktop icon issue Gnome Ubuntu 13.04

    I decided to go with Nemo and made it default file manager. The fix requires going into dconf under org-nemo-desktop, There you can enable Home, Trash and Computer.

  6. #6
    Join Date
    Aug 2013
    Beans
    1

    Thumbs up Re: Desktop icon issue Gnome Ubuntu 13.04

    Your answer is right here:

    http://www.youtube.com/watch?v=CoUqX9ZUijg

    Good luck!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •