Results 1 to 8 of 8

Thread: Fullscreen programs (wine) do not hide unity items

  1. #1
    Join Date
    Feb 2012
    Beans
    84

    Fullscreen programs (wine) do not hide unity items

    Hello, I have seen this problem posted around here about two years ago but none of the solutions have worked for me so far. I am using a thinkpad t60 with three different fullscreen wine programs. for each of them, If I disallow the window manager to control the windows in the wine settings, it will display correctly but the keyboard will not function correctly. If I enable the window manager to control the windows then the keyboard will work correctly, but then the unite launcher and top panel will display over the programs. Was their ever a workaround for these problems? I have tried the "legacy fullscreen support" in compiz with no luck.

    thanks.
    Last edited by sona1111; May 19th, 2013 at 09:50 PM. Reason: solved

  2. #2
    Join Date
    Jan 2008
    Location
    Gdansk, Poland
    Beans
    8
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Fullscreen programs (wine) do not hide unity items

    I have the same problem and I am clueless. sona1111 have you managet to solve it? If so please write what was the solution.

  3. #3
    Join Date
    Feb 2012
    Beans
    84

    Re: Fullscreen programs (wine) do not hide unity items

    I have only posted this less then a day ago, but I have been trying everything. I am through the entire first google page so far. Including a bunch of weird compiz settings. I Think I will try playonlinux next.

  4. #4
    Join Date
    Feb 2012
    Beans
    84

    Re: Fullscreen programs (wine) do not hide unity items

    Still no luck getting the unity bars to go away. Does anyone know how to fix it? or possibly how to capture the keyboard without using the window manager?

  5. #5
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Fullscreen programs (wine) do not hide unity items

    Moved to Wine


    Let's see if you get better action here.

    Cheers!

  6. #6
    Join Date
    Feb 2012
    Beans
    84

    Re: Fullscreen programs (wine) do not hide unity items

    thank you, though some people have also reported problems with non-wine applications. (the problems I have are only with wine at this time)

  7. #7
    Join Date
    Feb 2012
    Beans
    84

    Re: Fullscreen programs (wine) do not hide unity items

    bump

  8. #8
    Join Date
    Feb 2012
    Beans
    84

    Re: Fullscreen programs (wine) do not hide unity items

    Ok guys, It took a little help from the people at wine forums, but I seem to have solved it, for myself at least.

    All that you need to do is check all the boxes in wine config graphics tab (auto capture, alllow, allow, and emulate desktop) and set the resolution of the desktop in the boxes to exactly what you have set in ubuntu display settings. One pixel off and it becomes a window, but exactly the same it goes full screen! Then all that you have to do is open your program and set the resolution there to be the same as the other two resolution settings, and you should be good to go! (if you cant find the exact resolution you need, check the programs app directory for some .ini file they like to hide the resolutions in.)

    Thanks for everyone's help!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •