Page 5 of 19 FirstFirst ... 3456715 ... LastLast
Results 41 to 50 of 186

Thread: Howto: Compile the development version of vlc under the latest Ubuntu release

  1. #41
    Join Date
    Sep 2006
    Beans
    3,513

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    Looking forward to FLAC 1.4.0 in 2018.

  2. #42
    Join Date
    Dec 2006
    Beans
    7,030

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    Don't be too hasty
    You think that's air you're breathing now?

  3. #43
    Join Date
    Dec 2006
    Beans
    7,030

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    I have added in libdc1394-22-dev which is used by firewire digital cameras with vlc. Now if I only had a Firewire camera....

    Latest successful build:


    Code:
    andrew@corinth:~$ cvlc --version | head -n 3
    VLC media player 2.1.0-pre1 Rincewind (revision 01b0eaf)
    VLC version 2.1.0-pre1 Rincewind (01b0eaf)
    Compiled by andrew on corinth (Jun  7 2013 16:31:00)
    Compiler: gcc version 4.7.3 (Ubuntu/Linaro 4.7.3-1ubuntu1)
    You think that's air you're breathing now?

  4. #44
    Join Date
    Dec 2006
    Beans
    7,030

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    Latest successful build:

    Code:
    andrew@corinth:~/Desktop$ cvlc --version | head -n 3
    VLC media player 2.1.0-pre1 Rincewind (revision cda1e9b)
    VLC version 2.1.0-pre1 Rincewind (cda1e9b)
    Compiled by andrew on corinth (Jun 15 2013 14:30:32)
    Compiler: gcc version 4.7.3 (Ubuntu/Linaro 4.7.3-1ubuntu1)
    You think that's air you're breathing now?

  5. #45
    Join Date
    Dec 2006
    Beans
    7,030

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    I have altered the version numbers for vlc to reflect recent changes. A big welcome to Weatherwax:

    Code:
    andrew@corinth:~$ cvlc --version | head -n 3
    VLC media player 2.2.0-git Weatherwax (revision 7ee04e3)
    VLC version 2.2.0-git Weatherwax (7ee04e3)
    Compiled by andrew on corinth (Jul  4 2013 11:08:41)
    Compiler: gcc version 4.7.3 (Ubuntu/Linaro 4.7.3-1ubuntu1)
    You think that's air you're breathing now?

  6. #46
    Join Date
    Jul 2012
    Beans
    3

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    Hi there,

    Thank you for this useful tutorial.
    I have question. How can i enable vaapi support for my intel NUC. It is having intel HD4000 graphics. XBMC is running good with hardware acceleration. But i need vlc with H/W acceleration.

  7. #47
    Join Date
    Sep 2013
    Beans
    1

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    Hello,

    Thank you for great tutorial. But i got same error, like in official links... https://help.ubuntu.com/community/CompileVLC and https://wiki.videolan.org/UnixCompile/
    Tryed and here http://motorscript.com/compiling-vlc-for-root-users/ And of course i tryed by this tutorial.
    Somebody can help me fix it?

    I got this error on 2th server.
    I used 12.04.03 LTS and now new version 13.04 but still getting same error.

    Full log when do installation from dpkg package - http://pastebin.com/V2P6HNuu
    Error -
    make[2]: Leaving directory `/root/vlc_build/vlc/modules/altivec'
    Making distclean in sse2
    make[2]: Entering directory `/root/vlc_build/vlc/modules/sse2'
    Makefile:1156: ../video_chroma/.deps/libi420_rgb_sse2_plugin_la-i420_rgb.Plo: No such file or directory
    Makefile:1157: ../video_chroma/.deps/libi420_rgb_sse2_plugin_la-i420_rgb16.Plo: No such file or directory
    Makefile:1158: ../video_chroma/.deps/libi420_yuy2_sse2_plugin_la-i420_yuy2.Plo: No such file or directory
    Makefile:1159: ../video_chroma/.deps/libi422_yuy2_sse2_plugin_la-i422_yuy2.Plo: No such file or directory
    make[2]: *** No rule to make target `../video_chroma/.deps/libi422_yuy2_sse2_plugin_la-i422_yuy2.Plo'. Stop.
    make[2]: Leaving directory `/root/vlc_build/vlc/modules/sse2'
    make[1]: *** [distclean-recursive] Error 1
    make[1]: Leaving directory `/root/vlc_build/vlc/modules'
    make: *** [distclean-recursive] Error 1

    It's looks problem with "--disable-altivec". When i do this in configure, everyting was okey. Just problem now with sound. When using aac, sound have some interference, sharp sound...

    Thank you for your time.
    Last edited by poul2; September 13th, 2013 at 09:59 PM.

  8. #48
    Join Date
    Aug 2013
    Beans
    2,069

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    Hi.

    I am following the guide to compile vlc but I got a bit confused by Mc4man's comments #6 and #10. How do I check whether vlc is using the local build of ffmpeg or the system one? I am asking because I tried to compile vlc with vdpau support using this guide and got the ./configure error that vdpau required libavcodecs >= 54.36.0. I followed the guide but use git for ffmpeg instead, so libavcodecs should be the latest.
    http://ubuntuforums.org/showthread.php?t=2188965
    Last edited by monkeybrain20122; November 20th, 2013 at 11:55 PM.

  9. #49
    Join Date
    Aug 2013
    Beans
    2,069

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    Hii anyone?

  10. #50
    Join Date
    Dec 2006
    Beans
    7,030

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    Restarted work on this guide, hopefully a Saucy version out over the next few days...
    You think that's air you're breathing now?

Page 5 of 19 FirstFirst ... 3456715 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •