Page 15 of 18 FirstFirst ... 51314151617 ... LastLast
Results 141 to 150 of 174

Thread: Howto: Compile the development version of vlc under the latest Ubuntu release

  1. #141
    Join Date
    Aug 2013
    Beans
    1,991

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    Quote Originally Posted by mc4man View Post
    The first one is a Dash audio & it seems vlc > 2.1.x can no longer handle. The other, flac in ogg, same deal. You could file vlc bugs on Videolan's bug thing or post query's in it's support forum.

    (using ffmpeg with -c:a copy to .m4a or .flac respectively will 'fix' vlc playback
    Hi, Thanks for looking at it. Will file a bug report there soon.. Have been struggling with the compiz corners again since I posted this so haven't got the time yet.

  2. #142
    Join Date
    Jun 2007
    Beans
    13,185

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    Quote Originally Posted by monkeybrain20122 View Post
    Hi, Thanks for looking at it. Will file a bug report there soon.. Have been struggling with the compiz corners again since I posted this so haven't got the time yet.
    I did post a question re Dash audio on the videolan forum, no response as of yet

    As far as your continuing issues with bindings there could be 3 possible solutions
    1. try rotate instead of wall
    2. try the latest compiz in a 14.04 install (I have in my personal ppa with a few add. changes or I'll pm you a link to the 'train' ppa - use with discretion..
    3. Alter the default(s) to what you want, then if compiz/unity set back it's to what you want.

  3. #143
    Join Date
    Dec 2006
    Beans
    6,979

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    In a very small update I have bumped the FFmpeg version to 2.2.4, changelog does not show a lot but FFmpeg is the core of vlc so..... Latest successful compile:

    Code:
    andrew@hellas:~$ cvlc --version | head -n 2
    VLC media player 3.0.0-git Vetinari (revision 2.2.0-git-101-g8a9ac87)
    VLC version 3.0.0-git Vetinari (2.2.0-git-101-g8a9ac87)
    Compiled by andrew on hellas (Jun 27 2014 18:15:37)
    A very interesting addition to the vlc-git code base is a patch to add a GStreamer decoder module:

    [PATCH]v4 codec: Add GStreamer based decoder module
    https://mailman.videolan.org/piperma...ay/097921.html

    This is something I am definitely going to have a look at, at the very least to see which GStreamer plugins need to be installed. So far the decoding is a little limited:

    Codecs currently supported are h264, mpeg4, vp8, mpeg2,
    flashvideo, wmv1/2/3, vc1.
    but looks like more may be added in the future. Interesting?
    You think that's air you're breathing now?

  4. #144
    Join Date
    Dec 2006
    Beans
    6,979

    Smile Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    In an even smaller update I have renamed fdk-aac to libfdk-aac where appropriate to avoid confusion with the command line encoder fdkaac. I mean how could these 3 names ever be confused!?
    You think that's air you're breathing now?

  5. #145
    Join Date
    Aug 2014
    Beans
    3

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    Hi,

    I tried to use this guide as the current version of vlc won't transcode to AAC audio on my system. Got it all compiled but still doesn't seem to work very well on my system not producing the ts files I'm expecting. As such I'm now trying to do it against one of the vlc stable branches rather than the master.

    However when I do that I get the follwoing error:

    checking for AVCODEC... no
    configure: error: No package 'libavcodec' found
    No package 'libavutil' found. Pass --disable-avcodec to ignore this error.

    I'm pretty sure that package was part of my problem with the vlc from the 14.04 repository. Do I really need this? Also not sure why I didn't get the same error when compiling from master...

    Any help much appreciated.

  6. #146
    Join Date
    Aug 2014
    Beans
    3

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    Interestingly - running the ./configure in the vlc master on it's own fails as above but running as a block of commands with the && in seems to work so will try the same for vlc-2.2.

  7. #147
    Join Date
    Aug 2014
    Beans
    3

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    Running the command as a batch works. Tried both master and 2.2 and neither work for my streaming DVB to HLS via a transcode. However 2.1 branch works. Thanks for the guide!

  8. #148
    Join Date
    Dec 2006
    Beans
    6,979

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    Quote Originally Posted by neil.renaud View Post
    Thanks for the guide!
    Good to hear that it is still useful, I confess that my Ubuntu work has suffered lately due to other commitments. Looks like a version bump for FFmpeg is due (2.3.3) and I will work on this over the next day or so. Nothing much else leaps out at me from the vlc changelog at the moment anyway...
    Last edited by andrew.46; August 23rd, 2014 at 09:23 AM.
    You think that's air you're breathing now?

  9. #149
    Join Date
    Dec 2006
    Beans
    6,979

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    It has been a while between updates but all builds well in a brand new vm with an updated FFmpeg (2.3.3). Latest successful build is:

    Code:
    andrew@corinth:~$ cvlc --version | head -n 2
    VLC media player 3.0.0-git Vetinari (revision ee78942)
    VLC version 3.0.0-git Vetinari (ee78942)
    Compiled by andrew on corinth (Aug 30 2014 18:22:15)
    Work, family and study are keeping me busy but I hope to keep this guide (perhaps my most favoured guide in my long history on these Forums) puttering along.....
    You think that's air you're breathing now?

  10. #150
    Join Date
    Dec 2006
    Beans
    6,979

    Re: Howto: Compile the development version of vlc under the latest Ubuntu release

    And speaking of puttering along: I have updated the Live555 libraries to 2014.07.25. All compiles well here:

    Code:
    andrew@corinth:~$ cvlc --version | head -n 2
    VLC media player 3.0.0-git Vetinari (revision 407756f)
    VLC version 3.0.0-git Vetinari (407756f)
    Compiled by andrew on corinth (Sep  2 2014 17:58:02)
    You think that's air you're breathing now?

Page 15 of 18 FirstFirst ... 51314151617 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •