Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: How to disable screensaver

  1. #11
    Join Date
    Oct 2006
    Beans
    49

    Re: How to disable screensaver

    I considered caffeine, but it is not in the repository for Lubuntu 12.04. In any case, I prefer to avoid adding another dependency -- especially in a case where the problem was caused by too many dependencies with overlapping functionality.

    I wanted to add one comment to my posting with the solution to the problem. I am having trouble understanding why X11 provides both DPMS and xscreensaver, considering that the functionality of the first appears to be subsumed by the second. Moreover, xfce4-power-manager triplicates some of the functionality. Having three modules performing the same functions seems like a bad design. Also, if my belief is correct that a recent upgrade to X11 activated the DPMS functionality, then a lot of users are going to be surprised as I was when their configuration of xfce4-power-manager and xsreensaver mysteriously stops working. This seems like a particularly poor upgrade policy for an LTS release.

  2. #12
    Join Date
    Feb 2009
    Location
    Sierra Vista, AZ
    Beans
    1,688
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: How to disable screensaver

    Got the old Dell out of the closet and after updating the kernel to 3.2.0.41, it works like a charm. I just thought of something that perhaps you were not doing. Under Memu->Preferences->Power Manager there is a box for disabling DPMS under the General Tab. Did you have that checked before you found your solution?

    By the way Lubuntu 12.04 is not a LTS release. As of this moment there is no LTS release for Lubuntu. They do not have the manpower to support the versions.
    Last edited by Rex Bouwense; May 5th, 2013 at 05:28 PM.
    Rex
    ASUS EeePC 1000h with Lubuntu 14.04 and Lubuntu 15.04

    Ubuntu Arizona LoCo Team - The Hottest LoCo on Earth
    Arizona LoCo |Arizona Team Wiki|Arizona Launchpad

  3. #13
    Join Date
    Nov 2013
    Beans
    1

    Re: How to disable screensaver

    Quote Originally Posted by jeffbarish View Post
    I found the problem. It's X11. It has something called DPMS. By default, it blanks the screen at 10 minutes (just as I was seeing). To fix the problem, I created a file called 10-disable-dpms.conf in /etc/X11/xorg.conf.d (which I had to create) containing:

    Section "ServerFlags"
    Option "BlankTime" "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"
    EndSection


    I'm pretty sure I saw an X upgrade go by some time ago, so I bet that's when this problem started.

    Thanks anyway for the suggestions.

    This works in lubuntu 13.10 also.

    Example

    Code:
    cd /etc/X11
    sudo mkdir xorg.conf.d
    cd xorg.conf.d
    sudo touch 10-disable-dpms.conf
    sudo nano 10-disable-dpms.conf 
    #Add code from comment (copy/paste)

  4. #14
    Join Date
    Nov 2011
    Beans
    1,914
    Distro
    Ubuntu

    Re: How to disable screensaver

    In 13.10, the "Brightness and Lock" settings panel -- distinct from the screensaver -- inlcudes settings to lock and turn off the screen after a specified period. Or, not.

  5. #15
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    6,734
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: How to disable screensaver

    Quote Originally Posted by buzzingrobot View Post
    In 13.10, the "Brightness and Lock" settings panel -- distinct from the screensaver -- inlcudes settings to lock and turn off the screen after a specified period. Or, not.
    The posters have Lubuntu in mind. Is your answer relating to Ubuntu? I'm not seeing a "Brightness and Lock" settings panel in Lubuntu 13.10.
    de gustibus et coloribus non est disputandum -- Wiktionary

  6. #16
    Join Date
    Nov 2011
    Beans
    1,914
    Distro
    Ubuntu

    Re: How to disable screensaver

    Quote Originally Posted by vasa1 View Post
    The posters have Lubuntu in mind. Is your answer relating to Ubuntu? I'm not seeing a "Brightness and Lock" settings panel in Lubuntu 13.10.
    Ah, yep, Ubuntu. Sorry. Odd if it's been removed, tho.

  7. #17
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    6,734
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: How to disable screensaver

    Quote Originally Posted by buzzingrobot View Post
    Ah, yep, Ubuntu. Sorry. Odd if it's been removed, tho.


    No idea but a Xubuntu user has been reporting something similar (I think): https://lists.ubuntu.com/archives/xu...er/006163.html

    I took another tack and I'm using a small script to run every 8 min; it uses xdotool to send a keypress of the shift key every 8 min when the CPU usage exceeds a set value (like when I'm watching a video).

    BTW, I don't see the screen getting locked at any time. If I leave my laptop unattended (with minimal CPU usage) the screen just goes blank and never locks. I'm a single user and don't have to worry about others touching my lappie. I don't have any screensaver installed and xscreensaver isn't part of Lubuntu 13.10, AFAIK.
    de gustibus et coloribus non est disputandum -- Wiktionary

  8. #18
    Join Date
    Jun 2009
    Beans
    5

    Re: How to disable screensaver

    this is for pple who find this googling for answers.
    [ solution ] from cmdline 》xset s off && xset -dpms
    that should disable screensaver & powersaver.
    u can also change timed to 1hr like so
    》xset s 3600 && xset dpms 3600

    finally to re-enable
    》xset s on && xset +dpms

  9. #19
    Join Date
    Jul 2014
    Beans
    6

    Re: How to disable screensaver

    Quote Originally Posted by jeffbarish View Post
    To fix the problem, I created a file called 10-disable-dpms.conf in /etc/X11/xorg.conf.d (which I had to create) containing:

    Section "ServerFlags"
    Option "BlankTime" "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"
    EndSection
    This worked for me (Lubuntu 14.04). Thanks!

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •