Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: seemingly unsolvable problem with Wi-Fi

  1. #11
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,459
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: seemingly unsolvable problem with Wi-Fi

    @Varun--

    I am troubled by this:
    ieee80211 phy0: wlan0: No probe response from AP <MAC address removed> after 500ms, disconnecting.
    There is a parameter here:
    Code:
    $ modinfo mac80211
    filename:       /lib/modules/3.8.0-19-generic/kernel/net/mac80211/mac80211.ko
    license:        GPL
    description:    IEEE 802.11 subsystem
    srcversion:     2B2B66D5E403FA4D5C2715F
    depends:        cfg80211
    intree:         Y
    vermagic:       3.8.0-19-generic SMP mod_unload modversions 
    parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
    parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
    parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
    parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)
    You might try 1000 or 2000 to see if it helps. Post back or PM if you need help.

    I strongly suggest channel 1 or 11 and WPA2-PSK only.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  2. #12
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: seemingly unsolvable problem with Wi-Fi

    Quote Originally Posted by chili555 View Post
    @Varun--

    I am troubled by this...
    Never really looked at it. But there are many things in outputs (in fact most of things in syslog, and dmesg) that I still keep ignoring because I don't understand them and/or don't know values they can take.

    Thanks for the input doc, I'll wait for the feedback more eagerly now.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  3. #13
    Join Date
    Apr 2013
    Beans
    49

    Re: seemingly unsolvable problem with Wi-Fi

    Quote Originally Posted by varunendra View Post
    Nothing looks suspicious in there except that you are currently using the most used channel in the neighborhood. But you already tried changing the channel, as you posted earlier, with no improvements. So at the moment, I'm left with only a few more suggestions :

    1. Try changing the channel again with a least used one (maybe channel 6, if that is allowed based on your regional settings.)
    2. Permanently disable IPv6 as mentioned in this post : http://ubuntuforums.org/showthread.p...3#post12631003
    3. If the encryption is set to WPA/WPA2 mixed mode, try changing it to WPA2 only in the router. You may try the swcrypto=1 parameter again if the encryption is changed.
    4. The bit rate seems to be on auto. Try fixing it to a decent speed, say, 48 Mbps :
      Code:
      sudo iwconfig wlan0 rate 48M


    Try one at a time (leave the IPv6 disabled, you are not using it anyway). If none of this helps, then I'm out of ideas I'm afraid, but still I'd like to see-
    Code:
    ifconfig
    grep -iR [0-9a-z] /sys/module/iwl_legacy/parameters/
    grep -iR [0-9a-z] /sys/module/iwl3945/parameters/
    ..without much hope.
    Tried a lot of different channels before starting the thread.. So I guess we can rule wrong wireless channel out. Disabled IPv6 and set speed to 48 Mb/s. I am still about to change the encryption. Will give feedback immediately after I give it a try. Here's the output of the commands you requested:
    Code:
    icefire@Toshiba:~$ ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:1e:33:5d:46:ab  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:936 errors:0 dropped:0 overruns:0 frame:0
              TX packets:936 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:117090 (117.0 KB)  TX bytes:117090 (117.0 KB)
    
    
    ppp0      Link encap:Point-to-Point Protocol  
              inet addr:192.168.1.200  P-t-P:192.168.1.2  Mask:255.255.255.255
              UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1400  Metric:1
              RX packets:317287 errors:0 dropped:0 overruns:0 frame:0
              TX packets:252408 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:3 
              RX bytes:437969928 (437.9 MB)  TX bytes:15159602 (15.1 MB)
    
    
    wlan0     Link encap:Ethernet  HWaddr 00:1f:3c:ae:d0:ea  
              inet addr:192.168.1.20  Bcast:192.168.1.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:385049 errors:0 dropped:0 overruns:0 frame:0
              TX packets:329009 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:528594052 (528.5 MB)  TX bytes:45125380 (45.1 MB)
    Code:
    icefire@Toshiba:~$ grep -iR [0-9a-z] /sys/module/iwl_legacy/parameters/grep: /sys/module/iwl_legacy/parameters/: No such file or directory
    Code:
    icefire@Toshiba:~$ grep -iR [0-9a-z] /sys/module/iwl3945/parameters/
    /sys/module/iwl3945/parameters/swcrypto:1
    /sys/module/iwl3945/parameters/fw_restart:1
    /sys/module/iwl3945/parameters/disable_hw_scan:1
    /sys/module/iwl3945/parameters/antenna:0
    Quote Originally Posted by chili555 View Post
    @Varun--

    I am troubled by this:There is a parameter here:
    Code:
    $ modinfo mac80211
    filename:       /lib/modules/3.8.0-19-generic/kernel/net/mac80211/mac80211.ko
    license:        GPL
    description:    IEEE 802.11 subsystem
    srcversion:     2B2B66D5E403FA4D5C2715F
    depends:        cfg80211
    intree:         Y
    vermagic:       3.8.0-19-generic SMP mod_unload modversions 
    parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
    parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
    parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
    parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)
    You might try 1000 or 2000 to see if it helps. Post back or PM if you need help.

    I strongly suggest channel 1 or 11 and WPA2-PSK only.
    Thanks for helping I am very new to linux and need some more explanation.. sorry for that. So, just to make sure I've got it right, I did the following:
    1. sudo gedit /etc/modprobe.d/mac80211.conf
    2. Added this line:
    options mac80211 probe_wait_ms=1000

    Did I get i right?

    Otherwise, the overall internet performance is sometimes ok, however, it is not constant. What is always causing trouble is my vpn connection. It's just a simple pptp vpn.. why is it so slow on this computer? This is what's troubling me..
    Last edited by icu12345; May 9th, 2013 at 05:56 PM.

  4. #14
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: seemingly unsolvable problem with Wi-Fi

    Quote Originally Posted by icu12345 View Post
    Code:
    icefire@Toshiba:~$ grep -iR [0-9a-z] /sys/module/iwl_legacy/parameters/grep: /sys/module/iwl_legacy/parameters/: No such file or directory
    My mistake! It was a hyphen, not an underscore :
    Code:
    grep -iR [0-9a-z] /sys/module/iwl-legacy/parameters/
    The other parameters look okay to me.


    ....just to make sure I've got it right, I did the following:
    1. sudo gedit /etc/modprobe.d/mac80211.conf
    2. Added this line: options mac80211 probe_wait_ms=1000

    Did I get i right?
    Looks right to me. Just make sure there are no spaces before or after the line : options mac80211 probe_wait_ms=1000
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  5. #15
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,459
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: seemingly unsolvable problem with Wi-Fi

    Looks right to me.
    And to me. Now are there any more "...No probe response from AP <MAC address removed> after 1000ms, disconnecting...." in dmesg?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  6. #16
    Join Date
    Apr 2013
    Beans
    49

    Re: seemingly unsolvable problem with Wi-Fi

    I kinda tried all possible options..:
    Code:
    grep: /sys/module/iwl-legacy/parameters/: No such file or directoryicefire@Toshiba:~$ grep -iR [0-9a-z] /sys/module/iwllegacy/parameters/
    grep: /sys/module/iwllegacy/parameters/: No such file or directory
    icefire@Toshiba:~$ grep -iR [0-9a-z] /sys/module/iwl-legacy/parameters/
    grep: /sys/module/iwl-legacy/parameters/: No such file or directory
    icefire@Toshiba:~$ grep -iR [0-9a-z] /sys/module/iwl_legacy/parameters/
    grep: /sys/module/iwl_legacy/parameters/: No such file or directory
    "No probe response from AP <MAC address removed> after xxxx ms" doesn't seem to appear any more...


    Code:
    **** dmesg ****
    [    0.791360] MODSIGN: Loaded cert 'Magrathea: Glacier signing key: 91de7a0b580f416d81726d1f7134a3ecef081207'
    [   12.932471] wmi: Mapper loaded
    [   13.179849] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s
    [   13.179854] iwl3945: Copyright(c) 2003-2011 Intel Corporation
    [   13.234176] iwl3945 0000:03:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
    [   13.234182] iwl3945 0000:03:00.0: Detected Intel Wireless WiFi Link 3945ABG
    [   13.234331] iwl3945 0000:03:00.0: irq 48 for MSI/MSI-X
    [   13.241510] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
    [   17.844903] iwl3945 0000:03:00.0: loaded firmware version 15.32.2.9
    [   17.912841] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [   18.306207] type=1400 audit(1368114146.001:19): apparmor="STATUS" operation="profile_load" name="/usr/lib/telepathy/mission-control-5" pid=986 comm="apparmor_parser"
    [   24.889838] wlan0: authenticate with <MAC address removed>
    [   24.892498] wlan0: send auth to <MAC address removed> (try 1/3)
    [   24.896052] wlan0: authenticated
    [   24.900031] wlan0: associate with <MAC address removed> (try 1/3)
    [   24.902795] wlan0: RX AssocResp from <MAC address removed> (capab=0x431 status=0 aid=1)
    [   24.904164] wlan0: associated
    [   24.904192] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    However, vpn performance is still tragic. Internet and LAN performance is OK at the moment but it changes over time and isn't constantly good. I thought that speedtest.net is maybe not a reliable speed testing tool, so I tried downloading the ubuntu 13.04 iso file from ubuntu.com on the laptop in question and then on another laptop (the other laptop is very similar to the one in question). The other one had a constant speed of 2,3 MB/s and this one had variable speed between 1 and 2,3 MB/s....

  7. #17
    Join Date
    Jul 2005
    Beans
    2,050

    Re: seemingly unsolvable problem with Wi-Fi

    Let me suggest that to solve this problem, you need to simplify it as much as possible and isolate the most simple test cases. You said in your first post that copying files over the local network is slow. FIX THAT FIRST, and worry about your VPN performance (if still an issue) later.

    If you've determined that your local network really is as fast as it should be - then it's probably a VPN configuration problem, not a "network" problem. But, if you can plug in the laptop to a wired ethernet connection and try it without wireless connected, that also might tell you something about "VPN performance" without wireless as a variable.

    And I repeat what I said earlier: by choosing to go with the very new 13.04, you are choosing to make it harder for yourself than sticking with the much more stable 12.04 LTS release that is supported until April 2017. I've been using Ubuntu for years and haven't even booted 13.04 (and perhaps never will). 12.04 works very well for me. Experienced Linux users who want the latest and greatest versions of everything can go ahead and trailblaze with the newer versions.

    You might consider upgrading your wireless card anyway, even though I doubt it will have any impact on your current problems. But you'll get N connections to an N router; for the cheap upgrade price, well worth it.

  8. #18
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: seemingly unsolvable problem with Wi-Fi

    Quote Originally Posted by icu12345 View Post
    I kinda tried all possible options..
    Figured out! In 13.04, they've changed the name of the module (why do they keep doing this??) : iwlegacy.
    However, be informed that the command was meant to only show us what parameters the module is loaded with. It is only the 'bt_coex_active' parameter that I was initially interested in, but with another review of the description of the problem, it hardly seems relevant.

    Quote Originally Posted by ahallubuntu View Post
    Let me suggest that to solve this problem, you need to simplify it as much as possible and isolate the most simple test cases.
    ..
    ..by choosing to go with the very new 13.04, you are choosing to make it harder for yourself than sticking with the much more stable 12.04 LTS release that is supported until April 2017.
    ..
    ..You might consider upgrading your wireless card anyway, even though I doubt it will have any impact on your current problems. But you'll get N connections to an N router; for the cheap upgrade price, well worth it.
    I agree with what he said, although there is no guarantee of an improved performance with an LTS.
    You may try a live cd of 12.04 to see if it makes any difference. I'd suggest to go with 64 bit if your laptop supports it.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  9. #19
    Join Date
    Apr 2013
    Beans
    49

    Re: seemingly unsolvable problem with Wi-Fi

    I have already tried live cds with Xubuntu 12.10 and Ubuntu 12.04 LTS before starting the thread but didn't mention this as it seemed hardly relevant....

    At the moment I am getting LAN transfer speeds of 1,0 MB/s which is a significant improvement over the initial state. How did this happen? I guess the modification of the parse time had a positive effect because nothing else has changed..

    However the VPN problem remains. I'm going to hook it up to a wired connection and see what happens.

  10. #20
    Join Date
    Apr 2013
    Beans
    49

    Re: seemingly unsolvable problem with Wi-Fi

    Update: Tried a wired connection and the VPN transfer speed was as miserable as when using wireless. So this is a VPN issue..

    For the time being I would focus on the vpn issue as it is a bigger problem...

    The settings at the moment are like this:



    Use Point-to-Point encryption must be checked, because the server is set up to reject not encrypted connections. Tried playing with the other options (stateful encryption, BSD data compression, Deflate data compression and TCP header compression) but there was no difference... Also tried send PPP echo packets but it didn't bring anything..
    Last edited by icu12345; May 10th, 2013 at 11:51 AM.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •