Page 3 of 13 FirstFirst 12345 ... LastLast
Results 21 to 30 of 123

Thread: Wifi won't connect on 13.04 with BCM 4313

  1. #21
    Join Date
    Apr 2008
    Beans
    53

    Re: Wifi won't connect on 13.04 with BCM 4313

    I've retraced my steps some, and I have come to the conclusion that I have actually been having two wifi problems, but I have been treating them as one.

    Problem #1 - first demonstrated when I upgraded from 12.10 - 13.04. My home wifi network would show in the available network lists, but I could not connect to it (i.e., continual attempt at connection showing in the indicator, but never able to make the connection). This problem was solved when I correctly applied Varunendra's fix.

    Problem #2 - The first time I rebooted after successfully applying Varunendra's fix, my wifi indicator showed that I was weakly connected to my network, but I could not access the internet - web pages would never load and would eventually time out. I tried reapplying Varunendra's fix at these times with no improvement. At that time I tried some other fixes, which included reinstalling and updating the Broadcom driver. This recreated problem #1. I then applied Varunendra's fix and wifi was up and running again. I essentially went back through this same process again yesterday after my computer was left unplugged and I had to reboot.

    I have since applied the recommended fix at post #13 above and I did reboot with no loss of Wifi. Not sure if any of this will help you guys. Thanks again, so much, for all of your help. If I can provide any further information let me know.

  2. #22
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,685
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wifi won't connect on 13.04 with BCM 4313

    Quote Originally Posted by bagelong View Post
    If I can provide any further information let me know.
    Yes you can help us more.

    First - a personal favour to me - please stop calling that "Varunendra's fix", both of you. Its embrrassing as it is mostly a 'stolen fix', I've only put it together in one place.

    Second - this was unexpected, although it may be because we copied the wl driver manually -
    Code:
    long@long-Lenovo:~$ dpkg -s bcmwl-kernel-source | grep -i version
    dpkg-query: package 'bcmwl-kernel-source' is not installed and no information is available
    So please post instead -
    Code:
    modinfo wl
    Third, regarding the 'weak connection' issue, please post -
    Code:
    iwconfig
    ifconfig
    Maybe we can see and suggest something that makes it possibly better. Additionally, you may wish to post a complete diagnostics report (iwconfig is included in it) following the "Wireless Script" link in my signature. But that's not required if things are satisfactory.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  3. #23
    Join Date
    Apr 2008
    Beans
    53

    Re: Wifi won't connect on 13.04 with BCM 4313

    #1 How about I refer to it as VSF (Varunendra's Stolen Fix)?

    #2
    Code:
    long@long-Lenovo:~$ modinfo wl
    filename:       /lib/modules/3.8.0-19-generic/kernel/drivers/net/wireless/wl.ko
    srcversion:     49E2D90EE4D6877632DEDB0
    alias:          pci:v000014E4d00000576sv*sd*bc*sc*i*
    alias:          pci:v000014E4d0000435Asv*sd*bc*sc*i*
    alias:          pci:v000014E4d00004359sv*sd*bc*sc*i*
    alias:          pci:v000014E4d00004358sv*sd*bc*sc*i*
    alias:          pci:v000014E4d00004727sv*sd*bc*sc*i*
    alias:          pci:v000014E4d00004357sv*sd*bc*sc*i*
    alias:          pci:v000014E4d0000A99Dsv*sd*bc*sc*i*
    alias:          pci:v000014E4d00004353sv*sd*bc*sc*i*
    alias:          pci:v000014E4d0000432Dsv*sd*bc*sc*i*
    alias:          pci:v000014E4d0000432Csv*sd*bc*sc*i*
    alias:          pci:v000014E4d0000432Bsv*sd*bc*sc*i*
    alias:          pci:v000014E4d0000432Asv*sd*bc*sc*i*
    alias:          pci:v000014E4d00004329sv*sd*bc*sc*i*
    alias:          pci:v000014E4d00004328sv*sd*bc*sc*i*
    alias:          pci:v000014E4d00004315sv*sd*bc*sc*i*
    alias:          pci:v000014E4d00004313sv*sd*bc*sc*i*
    alias:          pci:v000014E4d00004312sv*sd*bc*sc*i*
    alias:          pci:v000014E4d00004311sv*sd*bc*sc*i*
    depends:        lib80211
    vermagic:       3.8.0-19-generic SMP mod_unload modversions 686 
    parm:           oneonly:int
    parm:           piomode:int
    parm:           instance_base:int
    parm:           nompc:int
    parm:           name:string
    #3 My connection speed is fine now because of the most recent use of VSF after reinstall of the Broadcom drivers, but here is the requested output.
    Code:
    long@long-Lenovo:~$ iwconfig
    eth7      IEEE 802.11  Access Point: Not-Associated   
              Link Quality:5  Signal level:218  Noise level:164
              Rx invalid nwid:0  invalid crypt:0  invalid misc:0
    
    lo        no wireless extensions.
    
    eth6      no wireless extensions.
    
    long@long-Lenovo:~$ ifconfig
    eth6      Link encap:Ethernet  HWaddr b8:88:e3:35:57:7b  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    eth7      Link encap:Ethernet  HWaddr 74:e5:43:17:93:09  
              inet addr:192.168.1.120  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::76e5:43ff:fe17:9309/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:229152 errors:0 dropped:0 overruns:0 frame:5755239
              TX packets:172625 errors:18 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:228120835 (228.1 MB)  TX bytes:30941641 (30.9 MB)
              Interrupt:17 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:10448 errors:0 dropped:0 overruns:0 frame:0
              TX packets:10448 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:1624730 (1.6 MB)  TX bytes:1624730 (1.6 MB)

  4. #24
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,685
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wifi won't connect on 13.04 with BCM 4313

    Quote Originally Posted by bagelong View Post
    #1 How about I refer to it as VSF
    You guys are determined

    The output of modinfo is as expected, but this looks cryptic, none like I have ever seen so far -
    Quote Originally Posted by bagelong View Post
    Code:
    long@long-Lenovo:~$ iwconfig
    eth7      IEEE 802.11  Access Point: Not-Associated   
              Link Quality:5  Signal level:218  Noise level:164
              Rx invalid nwid:0  invalid crypt:0  invalid misc:0
    The highlighted part above doesn't seem good to me. Are you too far from the access point? Although since it is cryptic, I may be misinterpreting it. But if it is what it looks like, then the noise level is too high than 'tolerable'. Usually it should be under 65. But I don't know if it is in normal units. Similarly, the link quality is normally displayed in the form of "something1/something2" which is interpreted as "something1 out of something2". Now I can't say that "5" is on what scale

    EDIT : Noticed later, it shows both "not associated" as well as link quality and other stuff - which only appears when it IS associated with an access point. So this is really a messed up output. I'd have to find more examples, or seek advice from my seniors to get an idea of what is going on here

    So for now, since I'm not even sure I'm interpreting it correctly, let's leave it as long as the connection is fine.

    Finally -
    Quote Originally Posted by bagelong View Post
    Code:
    long@long-Lenovo:~$ ifconfig
    ..
    ..
    eth7      Link encap:Ethernet  HWaddr 74:e5:43:17:93:09  
              inet addr:192.168.1.120  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::76e5:43ff:fe17:9309/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:229152 errors:0 dropped:0 overruns:0 frame:5755239
              TX packets:172625 errors:18 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:228120835 (228.1 MB)  TX bytes:30941641 (30.9 MB)
              Interrupt:17
    Usually I recommend to disable IPv6 altogether (using this method), but that doesn't explain the 'error packets'. Besides, as long as it is working, just

    We'd be right here if needed
    Last edited by varunendra; May 15th, 2013 at 05:45 AM.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  5. #25
    Join Date
    Apr 2008
    Beans
    53

    Re: Wifi won't connect on 13.04 with BCM 4313

    Okay, I now think I am back to problem two. I still have a connection, but it is not very good. I am probably about 7 feet from my router, but the indicator shows a weak connection and web page loading is hit or miss. This is a big change from a few days ago when I first reapplied the fix.

  6. #26
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,685
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wifi won't connect on 13.04 with BCM 4313

    Quote Originally Posted by bagelong View Post
    Okay, I now think I am back to problem two. I still have a connection, but it is not very good. I am probably about 7 feet from my router, but the indicator shows a weak connection and web page loading is hit or miss. This is a big change from a few days ago when I first reapplied the fix.
    Hmm..
    While you are connected via wireless, please post outputs of -
    Code:
    iwconfig
    ifconfig
    sudo iwlist scan
    dmesg | grep wl
    Let's see if something obvious jumps out.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  7. #27
    Join Date
    Apr 2008
    Beans
    53

    Re: Wifi won't connect on 13.04 with BCM 4313

    Code:
    long@long-Lenovo:~$ iwconfig
    wlan3     IEEE 802.11bgn  ESSID:"Cisco47799"  
              Mode:Managed  Frequency:2.437 GHz  Access Point: 58:6D:8F:90:E0:23   
              Bit Rate=43.3 Mb/s   Tx-Power=19 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=29/70  Signal level=-81 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:10428  Invalid misc:2214   Missed beacon:0
    
    lo        no wireless extensions.
    
    eth6      no wireless extensions.
    
    long@long-Lenovo:~$ ifconfig
    eth6      Link encap:Ethernet  HWaddr b8:88:e3:35:57:7b  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:10525 errors:0 dropped:0 overruns:0 frame:0
              TX packets:10525 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:1429279 (1.4 MB)  TX bytes:1429279 (1.4 MB)
    
    wlan3     Link encap:Ethernet  HWaddr 74:e5:43:17:93:09  
              inet addr:192.168.1.120  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::76e5:43ff:fe17:9309/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:139374 errors:0 dropped:0 overruns:0 frame:0
              TX packets:96592 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:96998536 (96.9 MB)  TX bytes:16467888 (16.4 MB)
    
    long@long-Lenovo:~$ sudo iwlist scan
    [sudo] password for long: 
    wlan3     Scan completed :
              Cell 01 - Address: 58:6D:8F:90:E0:23
                        Channel:6
                        Frequency:2.437 GHz (Channel 6)
                        Quality=29/70  Signal level=-81 dBm  
                        Encryption key:on
                        ESSID:"Cisco47799"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                        Mode:Master
                        Extra:tsf=000000118e9445b4
                        Extra: Last beacon: 52ms ago
                        IE: Unknown: 000A436973636F3437373939
                        IE: Unknown: 010882848B962430486C
                        IE: Unknown: 030106
                        IE: Unknown: 2A0100
                        IE: Unknown: 2F0100
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (2) : CCMP TKIP
                            Authentication Suites (1) : PSK
                        IE: Unknown: 32040C121860
                        IE: Unknown: 2D1AFC181BFFFF000000000000000000000000000000000000000000
                        IE: Unknown: 3D1606001700000000000000000000000000000000000000
                        IE: Unknown: 4A0E14000A002C01C800140005001900
                        IE: Unknown: 7F0101
                        IE: Unknown: DD7F0050F204104A00011010440001021041000100103B00010310470010B4BDE38EDD78AAD1B25D93F1902999EE10210005436973636F1023000D4C696E6B7379732045323530301024000776312E302E30321042000234321054000800060050F20400011011000D4C696E6B737973204532353030100800020084103C000103
                        IE: Unknown: DD090010180204F0040000
                        IE: WPA Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (2) : CCMP TKIP
                            Authentication Suites (1) : PSK
                        IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
              Cell 02 - Address: 58:6D:8F:90:E0:25
                        Channel:6
                        Frequency:2.437 GHz (Channel 6)
                        Quality=29/70  Signal level=-81 dBm  
                        Encryption key:off
                        ESSID:"Cisco47799-guest"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                        Mode:Master
                        Extra:tsf=000000118e945b68
                        Extra: Last beacon: 52ms ago
                        IE: Unknown: 0010436973636F34373739392D6775657374
                        IE: Unknown: 010882848B962430486C
                        IE: Unknown: 030106
                        IE: Unknown: 2A0100
                        IE: Unknown: 2F0100
                        IE: Unknown: 32040C121860
                        IE: Unknown: 2D1AFC181BFFFF000000000000000000000000000000000000000000
                        IE: Unknown: 3D1606001700000000000000000000000000000000000000
                        IE: Unknown: 4A0E14000A002C01C800140005001900
                        IE: Unknown: 7F0101
                        IE: Unknown: DD090010180204F0040000
                        IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
    
    lo        Interface doesn't support scanning.
    
    eth6      Interface doesn't support scanning.
    
    long@long-Lenovo:~$ dmesg | grep wl
    [   26.826118] IPv6: ADDRCONF(NETDEV_UP): wlan3: link is not ready
    [   26.826376] IPv6: ADDRCONF(NETDEV_UP): wlan3: link is not ready
    [   28.887873] wlan3: authenticate with 58:6d:8f:90:e0:23
    [   28.897635] wlan3: send auth to 58:6d:8f:90:e0:23 (try 1/3)
    [   28.899124] wlan3: authenticated
    [   28.899406] wlan3: associate with 58:6d:8f:90:e0:23 (try 1/3)
    [   28.902604] wlan3: RX AssocResp from 58:6d:8f:90:e0:23 (capab=0x411 status=0 aid=3)
    [   28.903342] wlan3: associated
    [   28.903347] IPv6: ADDRCONF(NETDEV_CHANGE): wlan3: link becomes ready
    [16835.223378] wlan3: authenticate with 58:6d:8f:90:e0:23
    [16835.224396] wlan3: send auth to 58:6d:8f:90:e0:23 (try 1/3)
    [16835.425688] wlan3: send auth to 58:6d:8f:90:e0:23 (try 2/3)
    [16835.629462] wlan3: send auth to 58:6d:8f:90:e0:23 (try 3/3)
    [16835.833160] wlan3: authentication with 58:6d:8f:90:e0:23 timed out
    [16849.485270] IPv6: ADDRCONF(NETDEV_UP): wlan3: link is not ready
    [16877.959809] wlan3: authenticate with 58:6d:8f:90:e0:23
    [16877.963366] wlan3: send auth to 58:6d:8f:90:e0:23 (try 1/3)
    [16877.964886] wlan3: authenticated
    [16877.966721] wlan3: associate with 58:6d:8f:90:e0:23 (try 1/3)
    [16877.970123] wlan3: RX AssocResp from 58:6d:8f:90:e0:23 (capab=0x411 status=0 aid=3)
    [16877.970850] wlan3: associated
    [16877.970867] IPv6: ADDRCONF(NETDEV_CHANGE): wlan3: link becomes ready
    [17739.073173] wlan3: deauthenticating from 58:6d:8f:90:e0:23 by local choice (reason=3)
    [17740.045763] wlan3: authenticate with 58:6d:8f:90:e0:23
    [17740.046971] wlan3: send auth to 58:6d:8f:90:e0:23 (try 1/3)
    [17740.048557] wlan3: authenticated
    [17740.052498] wlan3: associate with 58:6d:8f:90:e0:23 (try 1/3)
    [17740.055762] wlan3: RX AssocResp from 58:6d:8f:90:e0:23 (capab=0x411 status=0 aid=3)
    [17740.056905] wlan3: associated
    long@long-Lenovo:~$

  8. #28
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,685
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wifi won't connect on 13.04 with BCM 4313

    Quote Originally Posted by bagelong View Post
    Code:
    long@long-Lenovo:~$ iwconfig
    wlan3     IEEE 802.11bgn  ESSID:"Cisco47799"  
              Mode:Managed  Frequency:2.437 GHz  Access Point: 58:6D:8F:90:E0:23   
              Bit Rate=43.3 Mb/s   Tx-Power=19 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=29/70  Signal level=-81 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:10428  Invalid misc:2214   Missed beacon:0
    Hmm.. that output is more familiar.. but, "wlan3"???? The "wl" driver assigns the interface name of "ethx" pattern, not "wlanx".
    Looks like you are back on the native brcmsmac driver, probably due to a kernel upgrade? Let us take a look at -
    Code:
    uname -mr
    lspci -nnk | grep -iA2 net
    lsmod
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  9. #29
    Join Date
    Apr 2008
    Beans
    53

    Re: Wifi won't connect on 13.04 with BCM 4313

    Code:
    long@long-Lenovo:~$ uname -mr
    3.8.0-21-generic i686
    long@long-Lenovo:~$ lspci -nnk | grep -iA2 net
    03:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
    	Subsystem: Broadcom Corporation Device [14e4:0608]
    	Kernel driver in use: bcma-pci-bridge
    0c:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller [10ec:8168] (rev 07)
    	Subsystem: Lenovo Device [17aa:5000]
    	Kernel driver in use: r8169
    long@long-Lenovo:~$ lsmod
    Module                  Size  Used by
    parport_pc             27504  0 
    bnep                   17669  2 
    rfcomm                 37420  0 
    ppdev                  12817  0 
    snd_hda_codec_hdmi     36185  1 
    coretemp               13131  0 
    joydev                 17097  0 
    snd_hda_codec_conexant    52256  1 
    arc4                   12543  2 
    kvm                   376505  0 
    aesni_intel            18156  1 
    aes_i586               16995  1 aesni_intel
    xts                    12749  1 aesni_intel
    lrw                    13057  1 aesni_intel
    gf128mul               14503  2 lrw,xts
    brcmsmac              521468  0 
    thinkpad_acpi          69384  0 
    nvram                  13986  1 thinkpad_acpi
    ablk_helper            13357  1 aesni_intel
    snd_hda_intel          38307  3 
    cordic                 12518  1 brcmsmac
    brcmutil               14355  1 brcmsmac
    snd_hda_codec         117580  3 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_intel
    mac80211              526519  1 brcmsmac
    snd_hwdep              13272  1 snd_hda_codec
    snd_pcm                80890  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
    uvcvideo               71279  0 
    videobuf2_vmalloc      12920  1 uvcvideo
    videobuf2_memops       13042  1 videobuf2_vmalloc
    cryptd                 15613  1 ablk_helper
    snd_page_alloc         14230  2 snd_pcm,snd_hda_intel
    btusb                  17986  0 
    snd_seq_midi           13132  0 
    videobuf2_core         39161  1 uvcvideo
    snd_seq_midi_event     14475  1 snd_seq_midi
    cfg80211              436177  2 brcmsmac,mac80211
    i915                  535507  3 
    bluetooth             202069  11 bnep,btusb,rfcomm
    snd_rawmidi            25114  1 snd_seq_midi
    videodev               95806  2 uvcvideo,videobuf2_core
    snd_seq                51280  2 snd_seq_midi_event,snd_seq_midi
    snd_seq_device         14137  3 snd_seq,snd_rawmidi,snd_seq_midi
    rtsx_pci_ms            12875  0 
    snd_timer              24411  2 snd_pcm,snd_seq
    drm_kms_helper         47545  1 i915
    drm                   228750  4 i915,drm_kms_helper
    snd                    56485  17 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,thinkpad_acpi,snd_seq_device
    psmouse                81038  0 
    bcma                   39645  1 brcmsmac
    i2c_algo_bit           13197  1 i915
    memstick               15842  1 rtsx_pci_ms
    lp                     13299  0 
    serio_raw              13031  0 
    microcode              18286  0 
    video                  18894  1 i915
    parport                40753  3 lp,ppdev,parport_pc
    soundcore              12600  1 snd
    wmi                    18590  0 
    lpc_ich                16925  0 
    mei                    36197  0 
    mac_hid                13037  0 
    rtsx_pci_sdmmc         17238  0 
    ahci                   25507  2 
    libahci                26108  1 ahci
    r8169                  61531  0 
    rtsx_pci               32018  2 rtsx_pci_ms,rtsx_pci_sdmmc

  10. #30
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,685
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wifi won't connect on 13.04 with BCM 4313

    Quote Originally Posted by bagelong View Post
    Code:
    long@long-Lenovo:~$ uname -mr
    3.8.0-21-generic i686
    long@long-Lenovo:~$ lspci -nnk | grep -iA2 net
    03:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
    	Subsystem: Broadcom Corporation Device [14e4:0608]
    	Kernel driver in use: bcma-pci-bridge
    Indeed what I suspected. Please compile and install the wl driver again like you did previously. Plus this additional step to prevent the brcmsmac driver from loading :
    Code:
    echo "blacklist brcmsmac" | sudo tee -a /etc/modprobe.d/blacklist.conf
    Reboot if necessary, and post back if our old driver gives you better speeds.

    PS:
    I know this is annoying to manually compile and install the driver again after each kernel upgrade. This can be automated as far as I know, using 'dkms', but unfortunately, I don't yet know how to use it. Thanks to my laziness
    Last edited by varunendra; May 21st, 2013 at 05:00 AM. Reason: corrected 'blacklist' command
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

Page 3 of 13 FirstFirst 12345 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •