Page 12 of 13 FirstFirst ... 210111213 LastLast
Results 111 to 120 of 123

Thread: Wifi won't connect on 13.04 with BCM 4313

  1. #111
    Join Date
    Jun 2013
    Beans
    12

    Re: Wifi won't connect on 13.04 with BCM 4313

    Well, all appears well! At least so far, the connection is stable and speeds acceptable. I do have a couple of related questions out of interest and for possible practical purposes later on..

    You mentioned that building the driver from the source download will be necessary every time the kernel upgrades. The following post mentions locking the version of the driver, would this method be applicable with this solution? [ http://askubuntu.com/questions/28673...-kernel-source ]

    Also, how do I know/tell when the kernel will be upgraded. Is there an obvious designation in the updates that highlights a kernel upgrade?

    Also, if for whatever reason I wanted to undo this process in the future, how would I go about doing so? I noticed previously that using
    Code:
    apt-get remove --purge bcmwl-kernel-source
    did not work after the first time I followed these steps and I tried to reverse them.

    Thanks again, learning lots!

  2. #112
    Join Date
    Jun 2013
    Beans
    12

    Re: Wifi won't connect on 13.04 with BCM 4313

    Quote Originally Posted by varunendra View Post
    Then restart both your router and laptop, and try to connect. If it is still slow, post back the results of -
    ifconfig
    iwconfig
    sudo iwlist eth1 scan
    nm-tool
    Afraid I spoke too soon.. after a day of usage, the WiFi is back to extremely slow (only on this system) despite router/laptop restarts etc. Sometimes it just completely disonnects. I ran the wireless script when everything was great for reference and ran it again when it reverted back to the suck. Here are the results for comparison:

    Wireless Script Ouput - BAD Connection:
    Code:
    *************** info trace ***************
    
    ***** uname -a *****
    
    Linux karlFolioMint 3.9.6-030906-generic #201306131535 SMP Thu Jun 13 19:35:54 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
    
    ***** lsb_release *****
    
    Distributor ID:    LinuxMint
    Description:    Linux Mint 15 Olivia
    Release:    15
    Codename:    olivia
    
    ***** lspci *****
    
    01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller [10ec:8168] (rev 06)
        Subsystem: Hewlett-Packard Company Device [103c:17f8]
        Kernel driver in use: r8169
    02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
        Subsystem: Hewlett-Packard Company Device [103c:1795]
        Kernel driver in use: wl
    
    ***** lsusb *****
    
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 004 Device 002: ID 125f:312b A-DATA Technology Co., Ltd. Superior S102 Pro
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 003: ID 1bcf:2c07 Sunplus Innovation Technology Inc. 
    Bus 002 Device 004: ID 046d:c521 Logitech, Inc. Cordless Mouse Receiver
    
    ***** iwconfig *****
    
    eth1      IEEE 802.11  Access Point: Not-Associated   
              Link Quality:5  Signal level:252  Noise level:164
              Rx invalid nwid:0  invalid crypt:0  invalid misc:0
    
    
    ***** rfkill *****
    
    0: brcmwl-0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: hp-wifi: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    2: hp-bluetooth: Bluetooth
        Soft blocked: yes
        Hard blocked: no
    
    ***** lsmod *****
    
    wl                   2573614  0 
    lib80211               14352  2 wl,lib80211_crypt_tkip
    
    ***** nm-tool *****
    
    NetworkManager Tool
    
    State: connected (global)
    
    - Device: eth1  [Auto Asus] ----------------------------------------------------
      Type:              802.11 WiFi
      Driver:            wl
      State:             connected
      Default:           yes
      HW Address:        <MAC address removed>
    
      Capabilities:
        Speed:           72 Mb/s
    
      Wireless Properties
        WEP Encryption:  yes
        WPA Encryption:  yes
        WPA2 Encryption: yes
    
      Wireless Access Points (* = current AP)
        *Asus:           Infra, <MAC address removed>, Freq 2447 MHz, Rate 54 Mb/s, Strength 100 WPA2
    
      IPv4 Settings:
        Address:         192.168.1.200
        Prefix:          24 (255.255.255.0)
        Gateway:         192.168.1.1
    
        DNS:             192.168.1.1
    
    
    - Device: eth0 -----------------------------------------------------------------
      Type:              Wired
      Driver:            r8169
      State:             unavailable
      Default:           no
      HW Address:        <MAC address removed>
    
      Capabilities:
        Carrier Detect:  yes
    
      Wired Properties
        Carrier:         off
    
    
    
    ***** NetworkManager.state *****
    [main]
    NetworkingEnabled=true
    WirelessEnabled=true
    WWANEnabled=true
    WimaxEnabled=true
    
    ***** NetworkManager.conf *****
    
    [main]
    plugins=ifupdown,keyfile
    dns=dnsmasq
    
    [ifupdown]
    managed=false
    
    ***** interfaces *****
    
    # interfaces(5) file used by ifup(8) and ifdown(8)
    auto lo
    iface lo inet loopback
    
    ***** iwlist *****
    
    eth1      Scan completed :
              Cell 01 - Address: <MAC address removed>
                        ESSID:"Asus"
                        Mode:Managed
                        Frequency:2.447 GHz (Channel 8)
                        Quality:5/5  Signal level:-2 dBm  Noise level:-92 dBm
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
                        IE: Unknown: DDAC0050F204104A0001101044000102103B000103104700107CD8D1061EC1541683CDA9B7B723CDCC102100154153555354654B20436F6D707574657220496E632E1023001C57692D46692050726F74656374656420536574757020526F757465721024000752542D4E3636551042001136303A61343A34633A64333A38313A34381054000800060050F20400011011000752542D4E363655100800022008103C0001031049000600372A000120
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                                  12 Mb/s; 48 Mb/s
    
    
    ***** resolv.conf *****
    
    nameserver 127.0.1.1
    
    nameserver 208.67.222.222
    nameserver 208.67.220.220
    
    ***** blacklist *****
    
    [/etc/modprobe.d/blacklist-ath_pci.conf]
    blacklist ath_pci
    
    [/etc/modprobe.d/blacklist.conf]
    blacklist evbug
    blacklist usbmouse
    blacklist usbkbd
    blacklist eepro100
    blacklist de4x5
    blacklist eth1394
    blacklist snd_intel8x0m
    blacklist snd_aw2
    blacklist i2c_i801
    blacklist prism54
    blacklist bcm43xx
    blacklist brmcsmac
    blacklist bcma
    blacklist ssb
    blacklist b43
    blacklist b43legacy
    blacklist ndiswrapper
    blacklist garmin_gps
    blacklist asus_acpi
    blacklist snd_pcsp
    blacklist pcspkr
    blacklist amd76x_edac
    
    ***** dmesg *****
    
    [    4.841863] wl: module license 'unspecified' taints kernel.
    [    4.843976] wl: module verification failed: signature and/or required key missing - tainting kernel
    [    5.054524] eth1: Broadcom BCM4727 802.11 Hybrid Wireless Controller 5.100.82.112
    [ 6808.929447] wlc_print_ampdu_txstatus: txstatus 0x1163
    [ 8937.412614] wlc_print_ampdu_txstatus: txstatus 0x3063
    [ 8937.412645] wlc_print_ampdu_txstatus: txstatus 0x3063
    [ 8937.413115] wlc_print_ampdu_txstatus: txstatus 0xf063
    [ 8937.413128] wlc_print_ampdu_txstatus: txstatus 0xf063
    [ 8937.413134] wlc_print_ampdu_txstatus: txstatus 0xf063
    [ 8937.413139] wlc_print_ampdu_txstatus: txstatus 0xf063
    
    ****************** done ******************
    Wireless Script Ouput - GREAT Connection:
    Code:
    *************** info trace ***************
    
    ***** uname -a *****
    
    Linux karlFolioMint 3.9.6-030906-generic #201306131535 SMP Thu Jun 13 19:35:54 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
    
    ***** lsb_release *****
    
    Distributor ID:    LinuxMint
    Description:    Linux Mint 15 Olivia
    Release:    15
    Codename:    olivia
    
    ***** lspci *****
    
    01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller [10ec:8168] (rev 06)
        Subsystem: Hewlett-Packard Company Device [103c:17f8]
        Kernel driver in use: r8169
    02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
        Subsystem: Hewlett-Packard Company Device [103c:1795]
        Kernel driver in use: wl
    
    ***** lsusb *****
    
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 003: ID 1bcf:2c07 Sunplus Innovation Technology Inc. 
    Bus 002 Device 003: ID 046d:c521 Logitech, Inc. Cordless Mouse Receiver
    
    ***** iwconfig *****
    
    eth1      IEEE 802.11  Access Point: Not-Associated   
              Link Quality:5  Signal level:250  Noise level:164
              Rx invalid nwid:0  invalid crypt:0  invalid misc:0
    
    
    ***** rfkill *****
    
    0: brcmwl-0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: hp-wifi: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    2: hp-bluetooth: Bluetooth
        Soft blocked: yes
        Hard blocked: no
    
    ***** lsmod *****
    
    wl                   2573614  0 
    lib80211               14352  2 wl,lib80211_crypt_tkip
    
    ***** nm-tool *****
    
    NetworkManager Tool
    
    State: connected (global)
    
    - Device: eth1  [Auto Asus] ----------------------------------------------------
      Type:              802.11 WiFi
      Driver:            wl
      State:             connected
      Default:           yes
      HW Address:        <MAC address removed>
    
      Capabilities:
        Speed:           72 Mb/s
    
      Wireless Properties
        WEP Encryption:  yes
        WPA Encryption:  yes
        WPA2 Encryption: yes
    
      Wireless Access Points (* = current AP)
        *Asus:           Infra, <MAC address removed>, Freq 2447 MHz, Rate 54 Mb/s, Strength 100 WPA2
        Lighthouse:      Infra, <MAC address removed>, Freq 2412 MHz, Rate 0 Mb/s, Strength 35 WPA WPA2
        NIKAT:           Infra, <MAC address removed>, Freq 2452 MHz, Rate 54 Mb/s, Strength 39 WPA
        GCD-HOME2:       Infra, <MAC address removed>, Freq 2437 MHz, Rate 0 Mb/s, Strength 29 WPA WPA2
    
      IPv4 Settings:
        Address:         192.168.1.200
        Prefix:          24 (255.255.255.0)
        Gateway:         192.168.1.1
    
        DNS:             192.168.1.1
    
    
    - Device: eth0 -----------------------------------------------------------------
      Type:              Wired
      Driver:            r8169
      State:             unavailable
      Default:           no
      HW Address:        <MAC address removed>
    
      Capabilities:
        Carrier Detect:  yes
    
      Wired Properties
        Carrier:         off
    
    
    
    ***** NetworkManager.state *****
    [main]
    NetworkingEnabled=true
    WirelessEnabled=true
    WWANEnabled=true
    WimaxEnabled=true
    
    ***** NetworkManager.conf *****
    
    [main]
    plugins=ifupdown,keyfile
    dns=dnsmasq
    
    [ifupdown]
    managed=false
    
    ***** interfaces *****
    
    # interfaces(5) file used by ifup(8) and ifdown(8)
    auto lo
    iface lo inet loopback
    
    ***** iwlist *****
    
    eth1      Scan completed :
              Cell 01 - Address: <MAC address removed>
                        ESSID:"Asus"
                        Mode:Managed
                        Frequency:2.447 GHz (Channel 8)
                        Quality:5/5  Signal level:-4 dBm  Noise level:-92 dBm
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
                        IE: Unknown: DDAC0050F204104A0001101044000102103B000103104700107CD8D1061EC1541683CDA9B7B723CDCC102100154153555354654B20436F6D707574657220496E632E1023001C57692D46692050726F74656374656420536574757020526F757465721024000752542D4E3636551042001136303A61343A34633A64333A38313A34381054000800060050F20400011011000752542D4E363655100800022008103C0001031049000600372A000120
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                                  12 Mb/s; 48 Mb/s
              Cell 02 - Address: <MAC address removed>
                        ESSID:"hpsetup"
                        Mode:Ad-Hoc
                        Frequency=2.437 GHz (Channel 6)
                        Quality:1/5  Signal level:-85 dBm  Noise level:-92 dBm
                        Encryption key:off
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
              Cell 03 - Address: <MAC address removed>
                        ESSID:"Lighthouse"
                        Mode:Managed
                        Frequency:2.412 GHz (Channel 1)
                        Quality:1/5  Signal level:-82 dBm  Noise level:-92 dBm
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (2) : CCMP TKIP
                            Authentication Suites (1) : PSK
                        IE: WPA Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (2) : CCMP TKIP
                            Authentication Suites (1) : PSK
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                                  12 Mb/s; 48 Mb/s
    
    
    ***** resolv.conf *****
    
    nameserver 127.0.1.1
    
    nameserver 208.67.222.222
    nameserver 208.67.220.220
    
    ***** blacklist *****
    
    [/etc/modprobe.d/blacklist-ath_pci.conf]
    blacklist ath_pci
    
    [/etc/modprobe.d/blacklist.conf]
    blacklist evbug
    blacklist usbmouse
    blacklist usbkbd
    blacklist eepro100
    blacklist de4x5
    blacklist eth1394
    blacklist snd_intel8x0m
    blacklist snd_aw2
    blacklist i2c_i801
    blacklist prism54
    blacklist bcm43xx
    blacklist brmcsmac
    blacklist bcma
    blacklist ssb
    blacklist b43
    blacklist b43legacy
    blacklist ndiswrapper
    blacklist garmin_gps
    blacklist asus_acpi
    blacklist snd_pcsp
    blacklist pcspkr
    blacklist amd76x_edac
    
    ***** dmesg *****
    
    [    4.613038] wl: module license 'unspecified' taints kernel.
    [    4.614745] wl: module verification failed: signature and/or required key missing - tainting kernel
    [    4.822608] eth1: Broadcom BCM4727 802.11 Hybrid Wireless Controller 5.100.82.112
    
    ****************** done ******************
    ifconfig
    Code:
    $ ifconfig
    eth0      Link encap:Ethernet  HWaddr b4:99:ba:f7:5e:ec  
              inet6 addr: fe80::b699:baff:fef7:5eec/64 Scope:Link
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:984 errors:0 dropped:0 overruns:0 frame:0
              TX packets:722 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:1082872 (1.0 MB)  TX bytes:94706 (94.7 KB)
    
    eth1      Link encap:Ethernet  HWaddr c0:18:85:07:b7:fd  
              inet addr:192.168.1.200  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::c218:85ff:fe07:b7fd/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:2337 errors:0 dropped:0 overruns:0 frame:25373
              TX packets:2080 errors:38 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:2102893 (2.1 MB)  TX bytes:237400 (237.4 KB)
              Interrupt:18 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:218 errors:0 dropped:0 overruns:0 frame:0
              TX packets:218 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:20231 (20.2 KB)  TX bytes:20231 (20.2 KB)
    iwconfig
    Code:
    $ iwconfig
    eth0      no wireless extensions.
    
    eth1      IEEE 802.11  Access Point: Not-Associated   
              Link Quality:5  Signal level:248  Noise level:164
              Rx invalid nwid:0  invalid crypt:12  invalid misc:0
    
    lo        no wireless extensions.
    
    karl@karlFolioMint ~ $ sudo iwlist eth1 scan
    eth1      Scan completed :
              Cell 01 - Address: 60:A4:4C:D3:81:48
                        ESSID:"Asus"
                        Mode:Managed
                        Frequency:2.447 GHz (Channel 8)
                        Quality:5/5  Signal level:-12 dBm  Noise level:-92 dBm
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
                        IE: Unknown: DD310050F204104A0001101044000102104700107CD8D1061EC1541683CDA9B7B723CDCC103C0001031049000600372A000120
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                                  12 Mb/s; 48 Mb/s
    nm-tool
    Code:
    $ nm-tool
    
    NetworkManager Tool
    
    State: connected (global)
    
    - Device: eth1  [Auto Asus] ----------------------------------------------------
      Type:              802.11 WiFi
      Driver:            wl
      State:             connected
      Default:           yes
      HW Address:        C0:18:85:07:B7:FD
    
      Capabilities:
        Speed:           72 Mb/s
    
      Wireless Properties
        WEP Encryption:  yes
        WPA Encryption:  yes
        WPA2 Encryption: yes
    
      Wireless Access Points 
        Asus:            Infra, 60:A4:4C:D3:81:48, Freq 2447 MHz, Rate 0 Mb/s, Strength 100 WPA2
    
      IPv4 Settings:
        Address:         192.168.1.200
        Prefix:          24 (255.255.255.0)
        Gateway:         192.168.1.1
    
        DNS:             192.168.1.1
    
    
    - Device: eth0 -----------------------------------------------------------------
      Type:              Wired
      Driver:            r8169
      State:             unavailable
      Default:           no
      HW Address:        B4:99:BA:F7:5E:EC
    
      Capabilities:
        Carrier Detect:  yes
        Speed:           1000 Mb/s
    
      Wired Properties
        Carrier:         off
    iwlist eth1 scan
    Code:
    $ sudo iwlist eth1 scan
    eth1      Scan completed :
              Cell 01 - Address: 60:A4:4C:D3:81:48
                        ESSID:"Asus"
                        Mode:Managed
                        Frequency:2.447 GHz (Channel 8)
                        Quality:5/5  Signal level:-12 dBm  Noise level:-92 dBm
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
                        IE: Unknown: DD310050F204104A0001101044000102104700107CD8D1061EC1541683CDA9B7B723CDCC103C0001031049000600372A000120
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                                  12 Mb/s; 48 Mb/s
    Any thoughts?

    EDIT: I should mention that when I restart, the network is immediately seen with Excellent strenght and the network manager shows "connecting," but after a couple of attempts to connect it fails and then the network shows completely out of range.
    Last edited by kajkob; June 18th, 2013 at 06:01 AM.

  3. #113
    Join Date
    Mar 2010
    Location
    India
    Beans
    6,577
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wifi won't connect on 13.04 with BCM 4313

    Quote Originally Posted by kajkob View Post
    You mentioned that building the driver from the source download will be necessary every time the kernel upgrades. The following post mentions locking the version of the driver, would this method be applicable with this solution? [ http://askubuntu.com/questions/28673...-kernel-source ]
    I'm afraid not.
    The reason is - unless we can find a patched package in the repositories, the older version is not compatible with 13.04. We can sure pin it, but then it won't compile on it in the first place. Although I have seen at least one post here a few weeks ago someone mentioning that they got a package that worked on 13.04, but I thought it was perhaps a patched package from a third party (something like we are doing here).

    Also, how do I know/tell when the kernel will be upgraded. Is there an obvious designation in the updates that highlights a kernel upgrade?
    If you get the Grub menu at startup, its entry for booting into Ubuntu/Mint will change (for example, "Linux with kernel 3.9.6..." instead of 3.9.5). In upgrades, it is listed as "linux-image-<version number>". There is no other obvious notification or indication of kernel upgrade. You can always manually check it with -
    Code:
    uname -r
    You can check all the currently installed kernels with -
    Code:
    dpkg --get-selections | grep linux-image
    (as an aside, you can uninstall older kernels to recover some disk space (around 100MB per kernel), although it is recommended to keep at least the last working one, so that you can boot with it in case the current one causes problems)

    Also, if for whatever reason I wanted to undo this process in the future, how would I go about doing so? I noticed previously that using
    Code:
    apt-get remove --purge bcmwl-kernel-source
    did not work after the first time I followed these steps and I tried to reverse them.
    Yes, apt-get purge bcmwl-kernel-source won't work because it is not part of installation of that package, we are manually copying the driver. As such, the 'uninstallation' process will also have to be manual, that is -

    unload the "wl" driver > delete the copied "wl.ko" module > run "depmod -a" and "update-initramfs -u" again > Un-Blacklist the modules "b43, ssb, brcmsmac and bcma". Everything will be back to defaults again after this (unless you manually did something more that you will need to revert).

    Quote Originally Posted by kajkob View Post
    [CODE]
    iwlist eth1 scan
    Code:
    $ sudo iwlist eth1 scan
    eth1      Scan completed :
              Cell 01 - Address: 60:A4:4C:D3:81:48
                        ESSID:"Asus"
                        Mode:Managed
                        Frequency:2.447 GHz (Channel 8)
                        Quality:5/5  Signal level:-12 dBm  Noise level:-92 dBm
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
                        IE: Unknown: DD310050F204104A0001101044000102104700107CD8D1061EC1541683CDA9B7B723CDCC103C0001031049000600372A000120
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                                  12 Mb/s; 48 Mb/s
    Any thoughts?.
    Try changing the channel from 8 to 1 or 11.

    If that does not help, try the native brcmsmac driver instead of the current wl one -
    Code:
    sudo modprobe -rfv wl
    sudo modprobe -v brcmsmac
    ..and see if it works any better. If it does, we can un-blacklist it and blacklist the wl instead.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  4. #114
    Join Date
    Jun 2013
    Beans
    12

    Re: Wifi won't connect on 13.04 with BCM 4313

    Quote Originally Posted by varunendra View Post
    Try changing the channel from 8 to 1 or 11.

    If that does not help, try the native brcmsmac driver instead of the current wl one -
    Neither of these worked unfortunately..but new developments have allowed for some progress. There is a new version of the driver being implemented for Ubuntu 13.10 and already available as mentioned in comment #45 on this board [ https://bugs.launchpad.net/ubuntu/+s...x/+bug/1110139 ]. I added that PPA and updated the driver, which allows for the connection to be more stable and the speeds are ok, however, the signal strength is still not great.

    The other problem is that regardless of the driver being used, including the newer 6.30.223.30 linked above, there is a problem with authentication with WPA2 Enterprise networks. There was a post about this somewhere that I lost track of.. This is also a problem for me as I also need to use my laptop at work, so still a work in progress...

  5. #115
    Join Date
    Mar 2010
    Location
    India
    Beans
    6,577
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wifi won't connect on 13.04 with BCM 4313

    Quote Originally Posted by kajkob View Post
    There is a new version of the driver being implemented for Ubuntu 13.10 and already available as mentioned in comment #45 on this board [ https://bugs.launchpad.net/ubuntu/+s...x/+bug/1110139 ]. I added that PPA and updated the driver, which allows for the connection to be more stable and the speeds are ok, however, the signal strength is still not great.
    That's an interesting development. I'd wait to see how well it works for others. Obviously, it's going to be the third option in my recommendation list for now, probably first if proves better for others too.

    The other problem is that regardless of the driver being used, including the newer 6.30.223.30 linked above, there is a problem with authentication with WPA2 Enterprise networks.
    Is it something about "ca-certificate authentication"? If so, try setting "system-ca-certs=" to "false" for your connection key-file in /etc/NetworkManager/system-connections. A one-liner to do this -
    Code:
    sudo sed -i 's:system-ca-certs=true:system-ca-certs=false:' /etc/NetworkManager/system-connections/<your connection key-file>
    ..where <your connection key-file> has to be replaced by your connection's key-file name (simply the connection name).
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  6. #116
    Join Date
    Jun 2013
    Beans
    12

    Re: Wifi won't connect on 13.04 with BCM 4313

    Quote Originally Posted by varunendra View Post
    ..where <your connection key-file> has to be replaced by your connection's key-file name (simply the connection name).
    As in the SSID?

  7. #117
    Join Date
    Mar 2010
    Location
    India
    Beans
    6,577
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wifi won't connect on 13.04 with BCM 4313

    Quote Originally Posted by kajkob View Post
    As in the SSID?
    Usually, but not necessarily the same. Just use -
    Code:
    ls -1 /etc/NetworkManager/system-connections
    to make sure.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  8. #118
    Join Date
    Jun 2013
    Beans
    12

    Re: Wifi won't connect on 13.04 with BCM 4313

    Quote Originally Posted by varunendra View Post
    Is it something about "ca-certificate authentication"? If so, try setting "system-ca-certs=" to "false" for your connection key-file in /etc/NetworkManager/system-connections. A one-liner to do this -
    Code:
    sudo sed -i 's:system-ca-certs=true:system-ca-certs=false:' /etc/NetworkManager/system-connections/<your connection key-file>
    ..where <your connection key-file> has to be replaced by your connection's key-file name (simply the connection name).
    Amazing, it works! I spent 40 minutes at the IT help desk in the building and they could not figure out how to connect to the WPA2 Enterprise network on Linux (granted they don't officialy support it). I was given a "this is a known bug with Linux that cannot be overcome at the moment." I just wrote it off as an issue with the driver. Anyway, thanks this is huge progress.. I may be able to boot into Linux exclusively from now on. That is my goal

    EDIT: Is there a way to set "system-ca-certs=" to false permanently? Had to do it again after a reboot..
    Last edited by kajkob; June 22nd, 2013 at 02:19 AM. Reason: Spelling

  9. #119
    Join Date
    Mar 2010
    Location
    India
    Beans
    6,577
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wifi won't connect on 13.04 with BCM 4313

    Quote Originally Posted by kajkob View Post
    EDIT: Is there a way to set "system-ca-certs=" to false permanently? Had to do it again after a reboot..
    I thought it WAS permanent

    The keyfile is what tells NetworkManager how to deal with a particular connection and it gets created IF it does not already exist, or only those values get changed that are changed for the connection.

    Could you confirm that the value was set to "true" again with -
    Code:
    sudo cat /etc/NetworkManager/system-connections/<your key-file> | grep "system-ca"
    ??

    If it is getting reset, you may add the command to your /etc/rc.local file to do it automatically at every boot. Just make sure to insert any custom line above "exit 0" in that file. This is how to do it, but ONLY do it IF the file is indeed getting reset on every boot (which is against what I know about it) -

    Open the /etc/rc.local file as root -
    Code:
    gksu gedit /etc/rc.local
    Add the following ling just above the last line "exit 0" -
    Code:
    sed -i 's:system-ca-certs=true:system-ca-certs=false:' /etc/NetworkManager/system-connections/<your connection key-file>
    Of course, replace the <your connection key-file> with the one you have. Since this file is executed (at every boot) as root, we don't need "sudo" in the command.

    It is VERY IMPORTANT that the last line in the /etc/rc.local file should be "exit 0". So insert any custom command always before it.

    By the way, good to know it worked
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  10. #120
    Join Date
    Jun 2013
    Beans
    12

    Re: Wifi won't connect on 13.04 with BCM 4313

    Quote Originally Posted by varunendra View Post
    I thought it WAS permanent

    The keyfile is what tells NetworkManager how to deal with a particular connection and it gets created IF it does not already exist, or only those values get changed that are changed for the connection.

    Could you confirm that the value was set to "true" again with -
    Code:
    sudo cat /etc/NetworkManager/system-connections/<your key-file> | grep "system-ca"
    This command doesn't produce any output, just returns to the default terminal line.. and when I just do
    Code:
    sudo cat /etc/NetworkManager/system-connections/<your key-file>
    to look at the content the line I previously set to 'false' is no longer there..

Page 12 of 13 FirstFirst ... 210111213 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •