Results 1 to 4 of 4

Thread: 13.04 raring: grub2 iso & sata loopback failed, 32 and 64 bit

  1. #1
    Join Date
    Jun 2008
    Location
    SF Bay Area, CA
    Beans
    80
    Distro
    Ubuntu Development Release

    13.04 raring: grub2 iso & sata loopback failed, 32 and 64 bit

    I've looked but haven't found anything in the forums or on launchpad.net yet. All previous Ubuntu versions work fine using grub2 to loopback mount the .iso image to try out the newer versions without requiring either a USB stick image or burning a dvd/cd.

    When I boot the iso images using grub2 on a usb stick they work ok.

    When I try to boot the iso images using grub2 on a sata disk I get the following errors and then it drops to busybox:

    ata1.00: qc timeout (cmd 0xec)
    ata1.00: failed to identify (I/O error err_mask=0x4)

    There may be some kernel parameters I can pass but I'm not sure what to try. Any ideas?

    Grant
    http://ubuntu-california.org

  2. #2
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: 13.04 raring: grub2 iso & sata loopback failed, 32 and 64 bit

    All my drives are SATA, and the drives are from 2006. I do have AHCI on in BIOS.

    I installed 13.04, by booting grub on sdd an SSD, to loopmount an ISO on sdb to install on sdc without any issue.

    I have nVidia so I have built into all my loopmount linux lines the nomodeset. Not sure what other parameters you may need. Did other versions work?
    Last edited by oldfred; May 3rd, 2013 at 01:39 AM. Reason: Clarity
    Oldfred on vacation. Back Sept 9. Will not have much if any Internet access.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  3. #3
    Join Date
    Jun 2008
    Location
    SF Bay Area, CA
    Beans
    80
    Distro
    Ubuntu Development Release

    Re: 13.04 raring: grub2 iso & sata loopback failed, 32 and 64 bit

    So just to clarify, I'm just trying to boot an iso from a file on my sata disk and the kernel is panicing during boot. It works fine on USB but fails when the iso file is on a sata drive. All the other parameters are the same. All previous versions of ubuntu kernels have not paniced like this and they boot OK with sata just the same when booting OK with usb. Booting from an .iso file on the sata disk helps a lot to be able to test out .iso images quickly.

  4. #4
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: 13.04 raring: grub2 iso & sata loopback failed, 32 and 64 bit

    Whenever I had issues like that it was usually some command on set root, or boot parameters in linux line.

    This was what I used, but I had to add a gpt module as sdb is gpt partitioned.

    Code:
    menuentry "Ubuntu 13.04 Raring ISO 64bit" {
        set isofile="/iso/raring-desktop-amd64.iso"
        insmod part_gpt
        loopback loop (hd2,4)$isofile 
        linux (loop)/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper iso-scan/filename=$isofile nomodeset
        initrd (loop)/casper/initrd.lz
    }
    This will boot an ISO from a hard drive.
    ISO Booting with Grub 2 from Hard drive - drs305
    https://help.ubuntu.com/community/Grub2/ISOBoot
    Examples - you may copy & edit for your path & ISO version
    https://help.ubuntu.com/community/Gr...OBoot/Examples
    http://ubuntuforums.org/showthread.php?t=1549847
    Oldfred on vacation. Back Sept 9. Will not have much if any Internet access.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •