Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Dell Inspiron 6400 - No network after Ubuntu 13.04 installation

  1. #11
    Join Date
    May 2013
    Beans
    6

    Re: Dell Inspiron 6400 - No network after Ubuntu 13.04 installation

    What wifi card do you have? I've got the Dell wireless 1390 WLAN mini-card and the only one way to make it work is to disable driver in additional drivers at Software & Updates dialog (don't know exactly how it is named in EN localization, I'm using CS) and to install the b43 drivers (see above)...
    I've got no experience with the bcmwl-kernel-source...

  2. #12
    Join Date
    Aug 2009
    Beans
    3

    Re: Dell Inspiron 6400 - No network after Ubuntu 13.04 installation

    With the help of this thread this is what I found (and I now have wire and wireless network connections working)

    The auto update from 12.10 to 13.04 and when I did a fresh install from a USB ISO download from the main ubuntu site and included "download updates while installing" both left me with no network connect or wireless options.

    (when I installed from the USB drive ISO copy and did not select "download updates while installing" it was OK - but then if I selected the "additional driver" broadcom 802.11 STA driver from bcmwl-kernel-source in "software and updates" (or installed from command line) - then on restarting the laptop I lost all network connections and "additional drivers" tab was now blank so I could not disable it).

    The loss of network connection for me was resolved by removing the bcmwl-kernel-source:

    sudo apt-get remove bcmwl-kernel-source

    Then to get the wifi working tomie's line of code above worked:

    sudo apt-get install b43-fwcutter firmware-b43-installer

    I hope this helps others and thanks for your help tomie

  3. #13
    Join Date
    May 2013
    Beans
    1

    Re: Dell Inspiron 6400 - No network after Ubuntu 13.04 installation

    I have the Dell Insperion 1501. Same issue after upgrade. I did like these folks advised and uninstalled the proprietary drivers for the belkin wireless. When I did that my wired ethernet started working. I then installed the drivers the person above recommended. They must be generic. When completed my laptop function key to turn the wireless on and off started to work. It wasn't previously. The network icon then became populated with my wireless networking options.

    However, before the upgrade and using the proprietary drivers, my signal strength icon stayed steady. (my chair is right next to the router) After the upgade and the fix mentioned, I find that my meter fluctuates randomly through the entire range meter (weakest to strongest). I have not noticed any problems with things working.

    Question: could this be a result of the 1. Generic Drivers, 2. The skin not working properly and my signal strength is just fine, 3. Some other settings that may need to be changed or tweaked. ??? Or none of the above.

    Until it becomes a problem I do not really have an issue with it. However I thought I should mention it.

    On a side note, I found that my ATI proprietary video drivers no longer exist after the upgrade. Are they not proprietary anymore? Where did they go? This is an isssue for me, because 3 out of 5 boots I get buzzing vertical lines filling the screen and I have to reboot to get a working screen. I found to that if I close the laptop lid and then open it I get the logon for xubuntu.

    Any information would be welcome.

  4. #14
    Join Date
    Jan 2009
    Location
    Scotland
    Beans
    910
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Dell Inspiron 6400 - No network after Ubuntu 13.04 installation

    Thanks folks,

    Also sorts the same issues (No networks/no shutdown) on a Dell Inspiron 1501 with the Broadcom BCM4311 network controller and a BCM4401 Ethernet controller.
    I almost re installed 12.04!!!!

    Mike
    Dell Inspiron 1501 AMD Sempron, 4GB RAM, 120GB HDD, running 14.04 64Bit
    Dell Latitude D830 Centrino duo 4GB RAM 320GB HDD, running 13.10 64Bit
    Raspberry Pi running Rasbian
    Ubuntu User #32384

  5. #15
    Join Date
    Jul 2005
    Beans
    2,050

    Re: Dell Inspiron 6400 - No network after Ubuntu 13.04 installation

    Anyone with one of these same vintage Dell laptops should consider replacing the Broadcom wireless card with an Intel card - the Intel WiFi Link 5100 card has worked great for me in several Dell laptops, including two 6400's. (In fact, Ubuntu 12.04 LTS works beautifully on them; I use Gnome Classic (no effects) to get the best performance and don't use Unity.) I can't speak of the costs in Scotland or elsewhere, but here in the US, one can obtain one of these Intel wireless cards for about $5 USD shipped (used card). For the 6400 (and probably the 1501) you need a full-height wireless card (not half-height - the 5100 comes in both sizes), and you want a card that is *NOT* designed for HP/Lenovo/IBM. That card probably won't work in a Dell laptop. But any other variation of the 5100 (for Toshiba, Acer, etc.) should work fine.

    Dell has service manuals on its website showing you how to replace the wireless card on any laptop. On the 6400 (aka E1505), you have to remove the keyboard, but that's quite easy. There are YouTube videos demonstrating how to replace a wireless card and probably one or more showing how to replace it on a 6400.

    Don't try to upgrade the wireless card on an HP or Lenovo laptop - those companies "whitelist" their wireless cards, limiting which cards will operate in the laptop. Dell does not do this, so upgrading a Dell laptop should be easy in most cases.

  6. #16
    Join Date
    Mar 2013
    Beans
    2

    Thumbs up Re: Dell Inspiron 6400 - No network after Ubuntu 13.04 installation

    Quote Originally Posted by iantaylor01 View Post
    The loss of network connection for me was resolved by removing the bcmwl-kernel-source:

    sudo apt-get remove bcmwl-kernel-source

    Then to get the wifi working tomie's line of code above worked:

    sudo apt-get install b43-fwcutter firmware-b43-installer

    I hope this helps others and thanks for your help tomie
    Thanks Taylor and Tomie!
    Those two tiny commands worked the best out of my 1505!

    Thanks again!

  7. #17
    Join Date
    Mar 2008
    Beans
    16

    Re: Dell Inspiron 6400 - No network after Ubuntu 13.04 installation

    on a fresh install of Ubuntu 13.04 on a Dell Inspiron 1521 this code worked for me in the terminal after and update "sudo apt-get install b43-fwcutter firmware-b43-installer". before after i would install wireless i would lose my network completely on the laptop. Thanks very much this really helped me out.

  8. #18
    Join Date
    Dec 2011
    Beans
    24

    Re: Dell Inspiron 6400 - No network after Ubuntu 13.04 installation

    I am having the same issue on my sons Insp 6400

    After trying to enter any of the above code i get

    E: dpkg was interrupted, you must manually run sudo dpkg --configure -a' to correct the problem

    I am a noob to ubuntu still so not sure what I have to do now?
    Last edited by cray5656; October 14th, 2013 at 10:30 AM.

  9. #19
    Join Date
    Sep 2013
    Beans
    17

    Re: Dell Inspiron 6400 - No network after Ubuntu 13.04 installation

    bcmwl-kernel-source blacklists kernel modul b44 in /etc/modprobe/blacklist-bcm43.conf which is needed for ethernet controller bcm4401

    Please check yourself and vote here: https://bugs.launchpad.net/ubuntu/+s...l/+bug/1244587

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •