Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: USB stick automount not working

  1. #1
    Join Date
    Nov 2007
    Location
    London, England
    Beans
    6,007
    Distro
    Xubuntu 15.10 Wily Werewolf

    USB stick automount not working

    I have just installed Xubuntu 13.04 for my Mum. Everything is sweet except that automount of her backup USB stick (VFAT) doesn't work.

    I would really like to be able to get automount working her backup stick, because re-training her to manually mount the stick will be difficult.

    This is on xubuntu if that makes a difference. Under the Removable Storage settings, I have checked the three options:
    * Mount removable drives when hot-plugged
    * Mount removable media when inserted
    * Browse removable media when inserted

  2. #2
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: USB stick automount not working

    can you check that issue with an other thumb ? (to know if its a hardware issue with that one only)

  3. #3
    Join Date
    Nov 2007
    Location
    London, England
    Beans
    6,007
    Distro
    Xubuntu 15.10 Wily Werewolf

    Re: USB stick automount not working

    Confirmed. I just tried two other sticks - an iso9900 (xubuntu live-cd/installer) and another stick with both a vfat and a btrfs partition. Neither automounted at all.
    And there's nothing wrong with the backup stick - it mounts manually without any problem.

  4. #4
    Join Date
    Jul 2005
    Location
    England
    Beans
    Hidden!

    Re: USB stick automount not working

    Perhaps I'm grasping at straws, but have you tried all the other USB ports on the machine, or perhaps a powered USB hub, if you have one?
    DISTRO: Xubuntu 14.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo

  5. #5
    Join Date
    Nov 2007
    Location
    London, England
    Beans
    6,007
    Distro
    Xubuntu 15.10 Wily Werewolf

    Re: USB stick automount not working

    Right - I've confirmed the behaviour on my laptop as well. Both behave the same. Strangely, the iso9900 installer stick does now automount on both machines, so maybe that was finger trouble earlier. But neither the vfat backup stick or my vfat+btrfs stick automount.

    I'm also sure this is an Xubuntu issue - I found the settings for automount are stored in ~/.config/xfce4/xfconf/xfce-perchannel-xml/thunar-volman.xml.
    It's 64-bit, if that's significant.
    Last edited by The Cog; May 1st, 2013 at 11:06 PM.

  6. #6
    Join Date
    May 2010
    Location
    uk
    Beans
    9,374
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: USB stick automount not working

    Hi

    @TheCog.

    Is it creating the device file in /dev when you insert the stick ?

    If so that will discount udev and everything lower.

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

    Thinking about becoming an Ubuntu Member?

  7. #7
    Join Date
    Nov 2007
    Location
    London, England
    Beans
    6,007
    Distro
    Xubuntu 15.10 Wily Werewolf

    Re: USB stick automount not working

    Hi matt.

    I believe so. fdisk -l shows it as /dev/sdb and /dev/sdb1 and I can mount the device manually with a mount command (mount /dev/sdb1 /mnt).

    The partitions appear in gigolo, and in the devices side-panel of thunar. By clicking the device in either gigolo or thunar it mounts to /media/username/volumename. It just doesn't do it automatically when I plug the stick in.

  8. #8
    Join Date
    May 2010
    Location
    uk
    Beans
    9,374
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: USB stick automount not working

    Hi

    That's rather odd. gvfs is used by Thunar for auto-mounting.

    Plug in the device in but don't mount it using Thunar. What does this return ?

    Code:
    gvfs-mount --list
    EDIT:

    Does the pen drive have a label ?

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

    Thinking about becoming an Ubuntu Member?

  9. #9
    Join Date
    Nov 2007
    Location
    London, England
    Beans
    6,007
    Distro
    Xubuntu 15.10 Wily Werewolf

    Re: USB stick automount not working

    Code:
    steve@dingly:~$ gvfs-mount --list
    Drive(0): WDC WD1600BJKT-75F4T0
      Type: GProxyDrive (GProxyVolumeMonitorUDisks2)
    Drive(1): TEAC DVD-ROM DV28SV
      Type: GProxyDrive (GProxyVolumeMonitorUDisks2)
    Drive(2): Freecom DataBar USB2.0
      Type: GProxyDrive (GProxyVolumeMonitorUDisks2)
      Volume(0): BackupStick
        Type: GProxyVolume (GProxyVolumeMonitorUDisks2)
    Drive 0 and 1 are there before I plug the stick in. Drive 2 appears after I plug the stick in. The vfat filesystem label is indeed BackupStick.

    Looking at man gvfs-mount, I see that you can monitor events, so I did. This is the result:
    Code:
    steve@dingly:~$ gvfs-mount --monitor --detail
    Monitoring events. Press Ctrl+C to quit.
    Drive connected:    'Freecom DataBar USB2.0'
      Drive(0): Freecom DataBar USB2.0
        Type: GProxyDrive (GProxyVolumeMonitorUDisks2)
        ids:
         unix-device: '/dev/sdb'
        themed icons:  [drive-removable-media-usb]  [drive-removable-media]  [drive-removable]  [drive]
        symbolic themed icons:  [drive-removable-media-usb-symbolic]  [drive-removable-media-usb]  [drive-removable-media]  [drive-removable]  [drive]
        is_media_removable=1
        has_media=1
        is_media_check_automatic=1
        can_poll_for_media=0
        can_eject=1
        can_start=0
        can_stop=0
        start_stop_type=shutdown
        sort_key=01hotplug/1367492865053959
        Volume(0): BackupStick
          Type: GProxyVolume (GProxyVolumeMonitorUDisks2)
          ids:
           class: 'device'
           unix-device: '/dev/sdb1'
           uuid: 'C2F8-4274'
           label: 'BackupStick'
          themed icons:  [drive-removable-media-usb]  [drive-removable-media]  [drive-removable]  [drive]
          symbolic themed icons:  [drive-removable-media-usb-symbolic]  [drive-removable-media-usb]  [drive-removable-media]  [drive-removable]  [drive]
          can_mount=1
          can_eject=1
          should_automount=1
          sort_key=gvfs.time_detected_usec.1367492865156872
    
    Volume added:       'BackupStick'
      Volume(0): BackupStick
        Type: GProxyVolume (GProxyVolumeMonitorUDisks2)
        ids:
         class: 'device'
         unix-device: '/dev/sdb1'
         uuid: 'C2F8-4274'
         label: 'BackupStick'
        themed icons:  [drive-removable-media-usb]  [drive-removable-media]  [drive-removable]  [drive]
        symbolic themed icons:  [drive-removable-media-usb-symbolic]  [drive-removable-media-usb]  [drive-removable-media]  [drive-removable]  [drive]
        can_mount=1
        can_eject=1
        should_automount=1
        sort_key=gvfs.time_detected_usec.1367492865156872
    and then when I use gigolo to mount the drive it adds these lines:
    Code:
    Volume changed:     'BackupStick'
      Volume(0): BackupStick
        Type: GProxyVolume (GProxyVolumeMonitorUDisks2)
        ids:
         class: 'device'
         unix-device: '/dev/sdb1'
         uuid: 'C2F8-4274'
         label: 'BackupStick'
        themed icons:  [drive-removable-media-usb]  [drive-removable-media]  [drive-removable]  [drive]
        symbolic themed icons:  [drive-removable-media-usb-symbolic]  [drive-removable-media-usb]  [drive-removable-media]  [drive-removable]  [drive]
        can_mount=1
        can_eject=1
        should_automount=1
        sort_key=gvfs.time_detected_usec.1367492865156872
    
    Mount added: 'BackupStick'
      Mount(0): BackupStick -> file:///media/steve/BackupStick
        Type: GProxyMount (GProxyVolumeMonitorUDisks2)
        default_location=file:///media/steve/BackupStickRemovable Dr
        themed icons:  [drive-removable-media-usb]  [drive-removable-media]  [drive-removable]  [drive]
        symbolic themed icons:  [drive-removable-media-usb-symbolic]  [drive-removable-media-usb]  [drive-removable-media]  [drive-removable]  [drive]
        can_unmount=1
        can_eject=1
        is_shadowed=0
        sort_key=gvfs.time_detected_usec.1367492932314002
    I notice that it says should_automount=1.
    Edit: It says that even if I change the configuration (in Settings Manager | Removable Drives and Media) to not automount.
    Last edited by The Cog; May 2nd, 2013 at 12:18 PM.

  10. #10
    Join Date
    May 2010
    Location
    uk
    Beans
    9,374
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: USB stick automount not working

    Hi

    This is an odd one TheCog. So far that all looks fine and is what i would expect.

    This is what i find really odd.

    Right - I've confirmed the behaviour on my laptop as well. Both behave the same. Strangely, the iso9900 installer stick does now automount on both machines, so maybe that was finger trouble earlier. But neither the vfat backup stick or my vfat+btrfs stick automount.
    It'll mount some sticks and not others. I wonder if it's a known bug or something.

    As it auto-mounts some devices, i would expect you to already be a member of the plugdev group.

    It looks like the issue is either with udisks2, gvfs or thunar volume manger, although thunar volume manager does not explain gigolo.

    It does not look like a policykit issue either.

    I'm doing some research as well on this.

    Kind regards
    Last edited by matt_symes; May 2nd, 2013 at 01:41 PM. Reason: Typo
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

    Thinking about becoming an Ubuntu Member?

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •