Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: ffmpeg - Unknown encoder libfaac

  1. #1
    Join Date
    Sep 2010
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    ffmpeg - Unknown encoder libfaac

    Recently, I have freshly installed Ubuntu 12.04.2 i386 on my computer. I follow the instructions from FFmpeg, Community Ubuntu Documentation, https://help.ubuntu.com/community/FF...Configurations, to enable Universe/Medibuntu repos and to install ffmpeg. And this instruction reads as, "the following additional libraries will be downloaded: apport-hooks-medibuntu, libfaac0, libopencore-amrnb0, libopencore-amrwb0"

    I tried to convert avi video using libfaac codec, then I got the following error message:
    Unknown encoder 'libfaac'

    Where is the codec location for ffmpeg in Precise/Natty? Can I just copy the libfaac codec from Natty to Precise. I had Natty installed on my computer in another partition, and the same ffmpeg command, that converted avi video using libfaac codec, worked alright with me.

    I try not to compile-install ffmpeg. Is there any idea to add libfaac to my ffmpeg? Can you please let me know what I'm missing?

    Thank you very much in advance!!!

    Best Regards,
    cibalo
    Last edited by cibalo; May 23rd, 2013 at 01:23 PM.

  2. #2
    Join Date
    Dec 2006
    Beans
    6,930

    Re: ffmpeg - Unknown encoder libfaac

    Seems a little odd, I suspect that you need libavcodec-extra-53 but this is given on the wiki page...
    You think that's air you're breathing now?

  3. #3
    Join Date
    Sep 2010
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: ffmpeg - Unknown encoder libfaac

    Hello andrew.46,

    Thank you very much for replying to my post.

    Quote Originally Posted by andrew.46 View Post
    I suspect that you need libavcodec-extra-53
    Yes, I do have libavcodec-extra-53 installed. I do have all packages installed/dist-upgraded as suggested by the Help Wiki Page.

    Best Regards,
    cibalo

  4. #4
    Join Date
    Jun 2007
    Beans
    12,906

    Re: ffmpeg - Unknown encoder libfaac

    Could you run this to check what version is installed (currently the Ubuntu repo version is higher than mediabuntu's
    Code:
    apt-cache policy libavcodec-extra-53

  5. #5
    Join Date
    Sep 2010
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: ffmpeg - Unknown encoder libfaac

    Hello mc4man,

    Thank you very much for replying to my post.
    Quote Originally Posted by mc4man View Post
    Could you run this to check what version is installed
    libavcodec-extra-53 version outputs as follows:
    $ apt-cache policy libavcodec-extra-53
    libavcodec-extra-53:
    Installed: 4:0.8.6ubuntu0.12.04.1
    Candidate: 4:0.8.6ubuntu0.12.04.1
    Version table:
    *** 4:0.8.6ubuntu0.12.04.1 0
    500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/universe i386 Packages
    500 http://us.archive.ubuntu.com/ubuntu/ precise-security/universe i386 Packages
    100 /var/lib/dpkg/status
    4:0.8.5ubuntu0.12.04.1+medibuntu1 0
    500 http://packages.medibuntu.org/ precise/non-free i386 Packages
    4:0.8.1ubuntu1 0
    500 http://us.archive.ubuntu.com/ubuntu/ precise/universe i386 Packages
    $ ffmpeg -codecs|grep -in "libxvid\|libx264\|libfaac\|libmp3lame"
    ffmpeg version 0.8.6-4:0.8.6-0ubuntu0.12.04.1, Copyright (c) 2000-2013 the Libav developers
    built on Apr 2 2013 17:00:59 with gcc 4.6.3
    *** THIS PROGRAM IS DEPRECATED ***
    This program is only provided for compatibility and will be removed in a future release. Please use avconv instead.
    139: EA libmp3lame libmp3lame MP3 (MPEG audio layer 3)
    148: EV libx264 libx264 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
    149: EV libxvid libxvidcore MPEG-4 part 2
    $ uname -a
    Linux host12042 3.5.0-28-generic #48~precise1-Ubuntu SMP Wed Apr 24 21:43:05 UTC 2013 i686 i686 i386 GNU/Linux
    $ lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 12.04.2 LTS
    Release: 12.04
    Codename: precise

  6. #6
    Join Date
    Dec 2006
    Beans
    6,930

    Re: ffmpeg - Unknown encoder libfaac

    So the Ubuntu package:

    http://packages.ubuntu.com/precise/libavcodec-extra-53

    vs the Medibuntu package:

    http://packages.medibuntu.org/precis...-extra-53.html

    Always easier to compile your own
    You think that's air you're breathing now?

  7. #7
    Join Date
    Sep 2010
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: ffmpeg - Unknown encoder libfaac

    Hello andrew.46,

    Thank you very much for replying to my post.

    Quote Originally Posted by andrew.46 View Post
    Always easier to compile your own
    I have no other choice but to compile my own.

    Thank you any way.

  8. #8
    Join Date
    Dec 2006
    Beans
    6,930

    Re: ffmpeg - Unknown encoder libfaac

    This is nearly always the best course of action for FFmpeg, the rewards for using the most recent version are great. Doubtless you have seen this page:

    http://ffmpeg.org/trac/ffmpeg/wiki/U...mpilationGuide

    Best place to go to for such a guide...
    You think that's air you're breathing now?

  9. #9
    Join Date
    Jul 2006
    Location
    Lancashire
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: ffmpeg - Unknown encoder libfaac

    Quote Originally Posted by cibalo View Post
    I have no other choice but to compile my own.
    Hi
    You can add the medibuntu repository to enable libfaac with Ubuntu Precise.
    Adding the Repository
    Look here ---> https://help.ubuntu.com/community/Me...20Repositories
    Then
    Code:
    sudo apt-get install libavcodec-extra-53
    (medibuntu was updated to 4:0.8.6ubuntu0.12.04.1+medibuntu1 on/after Thu, 02 May 2013)



    Code:
    xubuntu@xubuntu:~$ apt-cache policy libavcodec-extra-53
    libavcodec-extra-53:
      Installed: 4:0.8.6ubuntu0.12.04.1+medibuntu1
      Candidate: 4:0.8.6ubuntu0.12.04.1+medibuntu1
      Version table:
     *** 4:0.8.6ubuntu0.12.04.1+medibuntu1 0
            500 http://packages.medibuntu.org/ precise/non-free i386 Packages
            100 /var/lib/dpkg/status
         4:0.8.6ubuntu0.12.04.1 0
            500 http://gb.archive.ubuntu.com/ubuntu/ precise-updates/universe i386 Packages
            500 http://security.ubuntu.com/ubuntu/ precise-security/universe i386 Packages
         4:0.8.1ubuntu1 0
            500 http://gb.archive.ubuntu.com/ubuntu/ precise/universe i386 Packages
    Last edited by ron999; May 9th, 2013 at 01:22 AM.

  10. #10
    Join Date
    Sep 2010
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: ffmpeg - Unknown encoder libfaac

    Hi,

    Quote Originally Posted by ron999 View Post
    You can add the medibuntu repository to enable libfaac with Ubuntu Precise
    Yes, I do have libavcodec-extra-53 installed. I do have all packages installed/dist-upgraded as suggested in the Help Wiki Page,
    https://help.ubuntu.com/community/FFmpeg#Precise_Configurations.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •