Results 1 to 3 of 3

Thread: 13.04 + UEFI + Windows 8 + Raid0 Howto?

  1. #1
    Join Date
    May 2005
    St. John's, NL
    Ubuntu 13.04 Raring Ringtail

    Question 13.04 + UEFI + Windows 8 + Raid0 Howto?

    I've been trying to get this going for the past couple of days, and haven't had it working yet. I've tried many combination of google searches to try and get help, but none of the solutions has gotten this working for me, and I'm starting to wonder if I'm wanting something impossible.

    Here is the current situation, first my layout:

    Drive 1 (128GB SSD)
    Drive 2 (1GB HDD)
    Drive 3 (1GB HDD)
    Drive 4 (1GB HDD)

    My system is using UEFI, which I don't know if its causing the issue or not because I still don't quite "get" UEFI.

    - Drive 1 contains only Windows 8 64bit
    - Drive 2 contains links in windows for my Downloads, Documents, etc, and also to be shared with Ubuntu install
    - Drives 3 & 4 are setup in a Raid 0 using my motherboard's raid utility/ (I don't care about redundancy, raid0 is fine for my purpose)

    So, I download the Ubuntu 13.04 Desktop 64bit install, and write it to a USB stick using unetbootin. Then on reboot, I select from my UEFI boot menu the "UEFI: Titanium Sandisk USB" (therefore the installer boots in UEFI mode). After running through the install, and rebooting, my system can no longer boot. I re-run the installer, and try to install grub to the /dev/mapper/* drives, none of them work. I'm not really sure what to do next. I downloaded the boot-repair thing, and that just hangs while loading.

    Laptop: XPS 15 L502X (Ubuntu 13.04 64bit)
    Nettop: Zotac Mag HD ND-01 (OpenELEC 3.0)
    Desktop: Windows 8 64bit / Ubuntu 13.04 64bit

  2. #2
    Join Date
    Jun 2009
    Chicago Suburbs
    Ubuntu 14.04 Trusty Tahr

    Re: 13.04 + UEFI + Windows 8 + Raid0 Howto?

    Lets see if it installed or what may be the issue. Download into the installer you are using and post link to BootInfo report.

    Post the link to the BootInfo report that this creates. Is part of Boot-Repair:
    Boot Repair -Also handles LVM, GPT, separate /boot and UEFI dual boot.:
    You can repair many boot issues with this or 'Create BootInfo' report (Other Options) & post the link it creates, so we can see your exact configuration and diagnose advanced problems.
    Install in Ubuntu liveCD or USB or Full RepairCD with Boot-Repair (for newer computers)
    For more info on UEFI boot install & repair - Updated Oct 2015:
    Please use Thread Tools above first post to close thread when/if answered completely.

  3. #3
    Join Date
    Nov 2009
    Segur De Calafell, Spain
    Ubuntu 12.04 Precise Pangolin

    Re: 13.04 + UEFI + Windows 8 + Raid0 Howto?

    Post the boot info as oldfred says, it might show something. You might be looking for much with this setup and the new uefi, don't know.

    Did you disable any Secure Boot and Fast Boot options in bios?
    Grub2 doesn't install correctly on fakeraid from the live cd, that's known. But with uefi I have no idea where you need to install it. With legacy boot you put it onto the MBR of the fakeraid (not on any partition on it), but I don't know in uefi. Also, you actually have the win8 and I suppose the uefi system partition on a non-raid disk, so the above about installing grub2 on fakeraid probably doesn't even apply. You should try installing it on the disk where the uefi partition is.

    In fact by booting the stick into uefi mode it should have known to install grub-efi on the uefi partition. Maybe you only need to add an entry manually using the bios uefi manager. The boot info can show us whether uefi grub exists or not.

    Also, you didn't specify where are you trying to install ubuntu? On the fakeraid? On one of the other disks?
    Ubuntu 14.04 LTS 64bit & Windows 7 Ultimate 64bit

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts