Results 1 to 8 of 8

Thread: Bad character encoding in Ubuntu 13.04

  1. #1
    Join Date
    Nov 2009
    Beans
    6

    Bad character encoding in Ubuntu 13.04

    I have Ubuntu 13.04 from release, fresh installation. System language is Slovak and character encoding is everywhere correct except numbers in Skype and VLC (only in settings, subtitles are encoded correctly)

    In Skype are like this:

    [١٩:١٣:١٣]
    [١٩:١٣:٢٧]
    [١٩:١٣:٤٣]
    [١٩:١٤:٣٣]

    And in VLC

    ٦ or ٧

    So it is the same encoding like in Skype...

    Here is a terminal output

    play3man@play3man-Extensa-5630:~$ locale
    LANG=sk_SK.UTF-8
    LANGUAGE=sk:en
    LC_CTYPE="sk_SK.UTF-8"
    LC_NUMERIC=sk_SK.UTF-8
    LC_TIME=sk_SK.UTF-8
    LC_COLLATE="sk_SK.UTF-8"
    LC_MONETARY=sk_SK.UTF-8
    LC_MESSAGES="sk_SK.UTF-8"
    LC_PAPER=sk_SK.UTF-8
    LC_NAME=sk_SK.UTF-8
    LC_ADDRESS=sk_SK.UTF-8
    LC_TELEPHONE=sk_SK.UTF-8
    LC_MEASUREMENT=sk_SK.UTF-8
    LC_IDENTIFICATION=sk_SK.UTF-8
    LC_ALL=
    play3man@play3man-Extensa-5630:~$

  2. #2
    Join Date
    Nov 2009
    Beans
    6

    Re: Bad character encoding in Ubuntu 13.04

    Nobody knows how to fix it?

  3. #3
    Join Date
    May 2013
    Location
    Slovakia
    Beans
    39
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Bad character encoding in Ubuntu 13.04

    I had same issue with qbittorrent, clementine and others... system language is english as well as keyboard, but some apps shows up in slovak...

    Output:
    LANG=en_US.UTF-8
    LANGUAGE=
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC=sk_SK.UTF-8
    LC_TIME=sk_SK.UTF-8
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY=sk_SK.UTF-8
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER=sk_SK.UTF-8
    LC_NAME=sk_SK.UTF-8
    LC_ADDRESS=sk_SK.UTF-8
    LC_TELEPHONE=sk_SK.UTF-8
    LC_MEASUREMENT=sk_SK.UTF-8
    LC_IDENTIFICATION=sk_SK.UTF-8
    LC_ALL=

    I had different language settings (english) and regional settings (slovak). I changed slovak to english, logged out and in and now it works fine... Maybe something wrong with slovak translation...
    Last edited by dankojoffrey; May 17th, 2013 at 06:03 PM.

  4. #4
    Join Date
    Jan 2008
    Beans
    4

    Re: Bad character encoding in Ubuntu 13.04

    yes, had the same issue, changing regional settings to english fixs it

  5. #5
    Join Date
    Jun 2010
    Location
    Denmark
    Beans
    143
    Distro
    Ubuntu

    Re: Bad character encoding in Ubuntu 13.04

    A bug report has been filed to fix this: https://bugs.launchpad.net/ubuntu-tr...s/+bug/1191241

  6. #6
    Join Date
    Aug 2010
    Beans
    7

    Re: Bad character encoding in Ubuntu 13.04


  7. #7
    Join Date
    Jun 2010
    Location
    Denmark
    Beans
    143
    Distro
    Ubuntu

    Re: Bad character encoding in Ubuntu 13.04

    Quote Originally Posted by tomasz_svk View Post
    That won't help it, as I don't have any locale.gen file on my computer. Adding this line into terminal: "sudo gedit /etc/default/locale.gen" only brings up a blank file. Searching for it manually also.

  8. #8
    Join Date
    Jun 2010
    Location
    Denmark
    Beans
    143
    Distro
    Ubuntu

    Re: Bad character encoding in Ubuntu 13.04

    This workaround fixed it for me.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •