Results 1 to 4 of 4

Thread: Dependency problems - apt-get and Octave 3.2

  1. #1
    Join Date
    Jan 2010
    Beans
    2

    Dependency problems - apt-get and Octave 3.2

    Hello,

    I am trying to install Octave 3.2, a program for mathematics, similar to matlab.

    My apt-cache searches reveal there are a number of Octave 3.2 packages, but upon trying to install them with the following command:

    Code:
    sudo apt-get install octave
    I get the following error message:

    Code:
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help resolve the situation:
    
    
    The following packages have unmet dependencies:
     octave : Depends: libarpack2 (>= 2.1) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    Is there any way to deal with these dependency problems?

  2. #2
    Join Date
    Jan 2010
    Beans
    2

    Re: Dependency problems - apt-get and Octave 3.2

    Bump. Sorry for the bump, but it's been a few days.

  3. #3
    Join Date
    Sep 2012
    Location
    Gnome12o4/LXDE14o4
    Beans
    Hidden!

    Re: Dependency problems - apt-get and Octave 3.2

    You do have your universe sources checked.

    https://help.ubuntu.com/community/Re...u_Software_Tab

    Get the same results when just installing libarpack2?
    Click on NewDocs PopularPages -- Ubuntu Documentation Search Tool
    Earn extra beans, report SPAM. Use the "Report Post" button.

  4. #4
    Join Date
    Apr 2012
    Beans
    4,564

    Re: Dependency problems - apt-get and Octave 3.2

    what version of ubuntu are you trying to install this in? do you have a previous version of octave or any of the arpack packages installed?

    Code:
    apt-cache policy arpack*

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •