Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: TP-Link WN821 wifi problems on Precise Pangolin 12.04

  1. #1
    Join Date
    Apr 2013
    Location
    Canada
    Beans
    36
    Distro
    Ubuntu

    TP-Link WN821 wifi problems on Precise Pangolin 12.04

    I've encountered a similar problem to nns2006, but I'm using a TP-Link TL-WN821N wireless adapter on Ubuntu v12.04.

    The system is unning on machine with 64-bit AMD Phenom 8450 Triple-Core processor x3 and a nvidia graphics card.

    The device is detected when inserted into my machine, but when I go to connect to the wifi network, I get stuck at the network authentification stage. I type in the network's password, but the same prompt shows up after a minute of attempting.

    I know there were some problems with Ubuntu 10.04, but those involved outright non-detection of the hardware.

    In this machine's location, wireless is the only internet I have. The same computer running Windows Vista was able to connect to the internet. Currently the notebook I'm using has a full connection.

    Can someone please advise?

    Here is the netinfo.txt file.
    Attachment 241919
    Last edited by UncleAsriel; May 1st, 2013 at 03:13 PM. Reason: [SOLVED]

  2. #2
    Join Date
    Apr 2013
    Location
    Canada
    Beans
    36
    Distro
    Ubuntu

    Re: TP-Link WN821 wifi problems on Precise Pangolin 12.04

    Update: after restarting the router, I appear to have a connection. This shall be treated as solved.

  3. #3
    Join Date
    Apr 2013
    Location
    Canada
    Beans
    36
    Distro
    Ubuntu

    Re: TP-Link WN821 wifi problems on Precise Pangolin 12.04

    After my system froze (I believe this is borne of the problems discussed here, here and here, but that's another topic), the wireless adapter stopped working. The same problem described in my first post arose.

    I'm searching for alternative problems like this, but I'm so far still stuck on finding a consistent cause.

    Does anyone have an idea of what's happening?

  4. #4
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,316
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: TP-Link WN821 wifi problems on Precise Pangolin 12.04

    Welcome to the forums UncleAsriel
    Quote Originally Posted by UncleAsriel View Post
    Does anyone have an idea of what's happening?
    The netinfo.txt file could give us some idea. Unfortunately, the attachment seems to be missing. Please re-attach the file..
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  5. #5
    Join Date
    Sep 2011
    Location
    Pennsylvania, U.S.A.
    Beans
    1,844
    Distro
    Ubuntu Development Release

    Re: TP-Link WN821 wifi problems on Precise Pangolin 12.04

    There are different versions of that adapter. V1. V2 & v3 use some form of Atheros chipset which generally work. An Atheros fix which is sometimes required is to disable hardware encryption. It looks like V4 switched to Realtek.

    Chip1 brand Chip2 brand
    TP-LINK TL-WN821N v1 Atheros Atheros
    TP-LINK TL-WN821N v2 Atheros Atheros
    TP-LINK TL-WN821N v3 Atheros Atheros
    TP-LINK TL-WN821N v4 Realtek

    http://wikidevi.com/wiki/TP-LINK_TL-WN821N_v1
    http://wikidevi.com/wiki/TP-LINK_TL-WN821N_v3

  6. #6
    Join Date
    Apr 2013
    Location
    Canada
    Beans
    36
    Distro
    Ubuntu

    Re: TP-Link WN821 wifi problems on Precise Pangolin 12.04

    Added the netinfo.txt as requested.
    Attachment 241953


    Last night I did some diagnostics a friend walked me through.
    Into the terminal we typed the following

    Code:
    sudo rmmod ar9170usb
    The attempt saw us recieve this error:

    Code:
    ERROR: module ar9170usb does not exist in /proc/modules
    We then used the lsmod command. It gave us these results.

    Having determined that the name of the device we were looking for was rtl8192cu, we then tried the rmmod command on it.

    Code:
    sudo rmmod rtl8192cu
    We then tried
    Code:
    sudo modprobe rtl8192cu
    The wireless tried re-checking itself but the same problem kept re-occurring.

    We then tried to change the wireless so that the network no longer required a password, but that turned out sour when it took out the internet for the entire house.

    After struggling for an hour to get the internet set up again, we decided to call it quits for the night.



    What does that mean for my system, kurt18947? Realtek vs Altehros refers to the type of physical unit they chose to store this on, correct?

    How does the this affect the problem at hand? Do I have to install a different patch/module/thingy to fix this?
    Last edited by UncleAsriel; April 29th, 2013 at 04:22 PM.

  7. #7
    Join Date
    Sep 2011
    Location
    Pennsylvania, U.S.A.
    Beans
    1,844
    Distro
    Ubuntu Development Release

    Re: TP-Link WN821 wifi problems on Precise Pangolin 12.04

    Quote Originally Posted by UncleAsriel View Post
    ....................

    What does that mean for my system, kurt18947? Realtek vs Altehros refers to the type of physical unit they chose to store this on, correct?

    How does the this affect the problem at hand? Do I have to install a different patch/module/thingy to fix this?
    It appears you have v.4 of this adapter using the RealTek chipset. If you have v.1-v3 the module in use would most likely be ath9k, not rtl8192cu. A module is sort of like a driver in Windows. This forum has wizards when it comes to wireless problems, I am not one. Here is a thread about the same RealTek chipset in a different device:

    http://ubuntuforums.org/showthread.p...ight=rtl8192cu

    I have used driver-from-RealTek solution on another realtek chipset and it worked a treat on 12.04 and 12.10. You appear to be running 12.04 so it should work for you as well. I prefer to avoid NDISwrapper unless there is no other choice. Be aware that the Realtek driver may fail after an update to the linux image/kernel. My solution is to leave the extracted download from RealTek on the desktop of my SUDO account user. If the adapter fails after an update, simply re-run the script. The adapter will function again.

  8. #8
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,316
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: TP-Link WN821 wifi problems on Precise Pangolin 12.04

    First, a few notes :-
    1. I don't know about ar9170usb, but ar9170 has been replaced by carl9170 driver long ago (since 10.04 I guess). Not that it is relevant to your problem, just a note
    2. NEVER use 'rmmod' unless you are absolutely sure what you are doing and what all it will affect. Instead, use modprobe -r command. Short description of 'why' is that rmmod doesn't care for dependencies or load/unload sequence and may even crash system due to this. On the other hand, modprobe -r is just a smart way of handling rmmod. It also unloads the dependencies in correct sequence, and returns error message if there is any problem in removing a module or any of its dependencies.



    Quote Originally Posted by UncleAsriel View Post
    What does that mean for my system, kurt18947? Realtek vs Altehros refers to the type of physical unit they chose to store this on, correct?

    How does the this affect the problem at hand? Do I have to install a different patch/module/thingy to fix this?
    While kurt may be able to elaborate on this, the short answer to your questions is that Realtek/Atheros are chip manufacturers and the name indicates which manufacturer's chip has been used on the wireless (or any card for that matter) module. It changes the whole thing about a problem and its solution, including applicable driver, available options that can be applied and methods to solve pertinent problems, if any.

    That said, please try a small parameter to your driver first, and let us know if it makes any difference -
    Code:
    sudo modprobe -rfv rtl8192cu
    sudo modprobe -v rtl8192cu swenc=Y
    Try to connect after running the above commands and post back the result. This is a temporary change that will be lost at reboot. If it seems to help, we can make it permanent.

    EDIT: Beaten by kurt
    Last edited by varunendra; April 30th, 2013 at 07:59 AM.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  9. #9
    Join Date
    Apr 2013
    Location
    Canada
    Beans
    36
    Distro
    Ubuntu

    Re: TP-Link WN821 wifi problems on Precise Pangolin 12.04

    I tried the modprobe commands like you suggested.

    The wireless icon flickered but no long-term effect was noticed.

    How do I go about making these additions to the blacklist. I believe it involves loading things via the commands discussed here.

    I'm unsure of the exact syntax, though. (still very green with Linux, all-in-all). What should I type?

    I'm assuming the following should not suffice

    Code:
    blacklist
    Code:
    rtl8192cu in /etc/modprobe.d/blacklist.conf
    Installing the driver should be easier (just extract the executable from the webtsite (found here) and follow the instructions on the auto-extraction. (I'm assuming that - like w Windows executable file - one of these conpressed drivers know which directory to install themselves into. I have a feeling this is incorrect, though).

    Could you please advise before I take this last step (which I believe will fix this issue)?

  10. #10
    Join Date
    Sep 2011
    Location
    Pennsylvania, U.S.A.
    Beans
    1,844
    Distro
    Ubuntu Development Release

    Re: TP-Link WN821 wifi problems on Precise Pangolin 12.04

    You're most likely correct, you need to blacklist the default realtek drivers in order for the module to created from Realtek to not conflict. Arch looks substantially different though the idea is the same. First, you're modifying system files so you need SuperUserDO privileges. You'll need to be using the account you first set up when you installed. That account has SUDO privileges by default, other accounts do not. Once logged into that account, open a terminal and type the following:
    Code:
    gksu gedit /etc/modprobe.d/blacklist.conf.
    You'll need to enter your SUDO password again. A file should open in gedit, the default text editor. You can scroll to the bottom of the file and add the entries necessary to prevent the default realtek drivers loading. Save, exit and reboot. I do not have your particular adapter but I have one similar, rtl-8188CUs. I have blacklisted
    • rtl8192cu
    • rtl8192c_common
    • rtlwifi

    Yours may not be the same. You can run the command "lsmod" and note any rtl*entries. Those will likely have to be blacklisted. The module from RealTek on my machine doesn't begin with rtl, it's only 8192cu. Hopefully this will be your last step.

    You could run into one other problem though I'm not certain which adapters are affected. If I put a machine with an rtl8192SU adapter in suspend then resume, the wifi adapter will not come online. Unplug, reinsert and it works. There is a fairly simple fix if you have an issue with your adapter waking up after suspend. We can cross than bridge if and when we get there.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •