Results 1 to 8 of 8

Thread: Wifi won't turn on after a suspend mode :(

  1. #1
    Join Date
    Jan 2013
    Beans
    5

    Wifi won't turn on after a suspend mode :(

    I have problem with my wifi after resuming from suspend mode. It says "wireless is disabled by hardware switch". In my normal boot I just press F3, the Wifi led light turns on and my laptop starts searching for signals. But resuming from suspension, I press F3, Wifi led light turns on but no Wifi signals detected. the message "wireless is disabled by hardware switch" won't change at all. I'm new in Ubuntu. and excuse my grammar.. but my bluetooth seems fine even resuming from suspend mode.

    02:00.0 Network controller [0280]: Broadcom Corporation BCM43227 802.11b/g/n [14e4:4358]
    03:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM57785 Gigabit Ethernet PCIe [14e4:16b5] (rev 10)
    03:00.1 SD Host controller [0805]: Broadcom Corporation NetXtreme BCM57765 Memory Card Reader [14e4:16bc] (rev 10)
    03:00.2 System peripheral [0880]: Broadcom Corporation Device [14e4:16be] (rev 10)
    03:00.3 System peripheral [0880]: Broadcom Corporation Device [14e4:16bf] (rev 10)

    HELP...
    Last edited by Macoy Villalobos; April 27th, 2013 at 08:39 PM.

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,580
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Wifi won't turn on after a suspend mode :(

    Please suspend, wait a few moments and resume. Then please open a terminal and run and post:
    Code:
    lsmod | grep wl
    rfkill list all
    The pipe symbol | is on the right side of my US keyboard on the same key with \. Thanks.

    Your grammer and English are just fine; no worries.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Jan 2013
    Beans
    5

    Re: Wifi won't turn on after a suspend mode :(

    macoychristian@macoychristian-ENNS11HR:~$ lsmod | grep wl
    wl 3074942 0
    cfg80211 208382 1 wl
    lib80211 14382 2 lib80211_crypt_tkip,wl
    macoychristian@macoychristian-ENNS11HR:~$ rfkill list all
    0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    1: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
    2: acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    3: acer-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
    macoychristian@macoychristian-ENNS11HR:~$


    Here it is sir.. it's weird but when I read your reply, suspend my laptop for a few minutes, resume. for some reason my wifi works fine without doing what you suggested. hmmm. . so maybe I thought It's just luck. Well it is luck. I reproduce the bug by shutting down my laptop and pull out my battery, count 1 - 10 (hehe) return the battery, turn on, login, close the lid, wait for a few seconds, resume and voila. the bug is back!! then I do what you told me. Restart (to reconnect). Reply thread.

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,580
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Wifi won't turn on after a suspend mode :(

    The commands I suggested you run aren't designed to fix anything. They are designed to gather diagnostics, to see the state of the machine when things aren't working. I assume the diagnostics you posted are the result of:
    close the lid, wait for a few seconds, resume and voila. the bug is back!! then I do what you told me.
    We see the result here:
    1: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
    Here is a technique that often helps.
    Code:
    gksudo gedit /etc/pm/config.d/config
    It will probably be a new file. Add a single line:
    Code:
    SUSPEND_MODULES="wl"
    Proofread carefully, save and close gedit. After a reboot, try to suspend and resume. If the wireless is not working, please run and post:
    Code:
    lsmod | grep wl
    rfkill list all
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #5
    Join Date
    Jan 2013
    Beans
    5

    Re: Wifi won't turn on after a suspend mode :(

    It will probably be a new file. Add a single line:
    Code:
    SUSPEND_MODULES="wl"
    Proofread carefully, save and close gedit. After a reboot, try to suspend and resume. If the wireless is not working, please run and post:
    Code:
    lsmod | grep wl
    rfkill list all
    [/QUOTE]

    It works!! I knew you can help.. thanks doc Chili55 .. after I followed the first set of instruction. after resume for just 1 minute it works.. Thank you very much! Your awesome!=D>

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,580
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Wifi won't turn on after a suspend mode :(

    Glad it's working! Please mark the thread as solved: https://wiki.ubuntu.com/UnansweredPo.../SolvedThreads
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #7
    Join Date
    Sep 2013
    Beans
    1

    Re: Wifi won't turn on after a suspend mode :(

    Thanks chili555. Found this thread through google because Ubuntu 13.04 version had the same issue on my laptop and your solution works like a charm, so far.

    Edit: Well crap, spoke too soon. It's still taking a minute or two for the wifi to come back on after waking. How annoying!
    Last edited by Stephen_Sykes; September 13th, 2013 at 08:26 PM.

  8. #8
    Join Date
    May 2014
    Beans
    1

    Re: Wifi won't turn on after a suspend mode :(

    This bug appears to be on the 14.04 LTS as well. The solution was very helpful. Thanks

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •