Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Can't install nvidia-319

  1. #11
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Can't install nvidia-319

    If you use:

    Code:
    sudo apt-get purge nvidia-304
    that should remove the driver without installing another driver, unless you removed nouveau too.

  2. #12
    Join Date
    May 2006
    Beans
    17

    Re: Can't install nvidia-319

    I purged nvidia-304. Can't purge 304-updates. Still can't install nvidia-319 no matter what, says it has a conflict with the xorg driver binary

    aptitude search '~i?provides(xorg-driver-binary)'
    i A nvidia-304-updates - NVIDIA binary Xorg driver, kernel module a

    apt-get purge nvidia-304-updates

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following package was automatically installed and is no longer required:
    linux-image-extra-3.9.0-4-generic
    Use 'apt-get autoremove' to remove it.
    The following extra packages will be installed:
    nvidia-304 nvidia-current nvidia-settings-304
    The following packages will be REMOVED:
    nvidia-304-updates* nvidia-current-updates* nvidia-settings-319*
    The following NEW packages will be installed:
    nvidia-304 nvidia-current nvidia-settings-304
    0 upgraded, 3 newly installed, 3 to remove and 3 not upgraded.
    Need to get 1,823 kB/69.9 MB of archives.
    After this operation, 325 kB disk space will be freed.
    Do you want to continue [Y/n]? n
    Abort.

  3. #13
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    4,133
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: Can't install nvidia-319

    Installed it on a clean install made with the June 15th daily disk image of xubuntu

    has anyone tried deleting /etc/X11/xorg.conf?
    Last edited by pqwoerituytrueiwoq; June 15th, 2013 at 03:53 PM.
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  4. #14
    Join Date
    May 2010
    Beans
    142

    Re: Can't install nvidia-319

    There is an updated version of 319.23 in the repos now, which installs against kernel 3.10. No need for xorg-edgers anymore if running the latest kernel. Sadly, moving from Gallium to Nvidia under Kernel 3.10 killed Unity and Gnome Classic, but strange enough so does Gnome-Shell work fine. One wouldn't think of Gnome-Shell as a fallback desktop, but in this case it is ... important to keep Nautilus 3.6.3 though as the desktop itself is destroyed when using a newer Nautilus. Gallium works fine with all of the above, but it can't run games properly, using the Linux-port of Portal as a test. Changing to Nvidia, while breaking a lot of the desktop stuff except Gnome-Shell, indeed makes it possible to run Portal properly! Ubuntu 13.10 is in a VERY buggy state right now, I don't think 13.04 ever was this buggy during it's release-cycle, but it's still Alpha so things will/must improve a lot Btw, running yesterdays build of Ubuntu fully updated and extended with ubuntu-gnome-desktop, yesterdays build of Ubuntu Gnome was too buggy to use but the normal Ubuntu was usable enough to have as a base install.
    Last edited by xeizo; June 15th, 2013 at 04:21 PM.
    Ubuntu Gnome 13.10 Asus P5Q-DeLuxe C2Q Q9450@3.2GHz 8GB Nvidia GTX650Ti 1GB Asus Xonar Essence ST Crucial M4 64GB(system) 3TB storage Corsair VX450 Xigmatek Asgard

  5. #15
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Can't install nvidia-319

    nothing buggy here on i386, even with nautilus 3.9.0

  6. #16
    Join Date
    May 2010
    Beans
    142

    Re: Can't install nvidia-319

    Quote Originally Posted by dino99 View Post
    nothing buggy here on i386, even with nautilus 3.9.0
    Well, I run 64-bit and it seems rather common for things to be fixed later in 64-bit which is strange since all desktop/laptop-processors have been 64-bit for nearly ten years ... Otherwise, the Nautilus-problem seems like a known bug, you can't have normal desktop-functionality in Gnome-Shell with anything later than 3.6.3. Usually it manifests itself in a pure white desktop. Of course one can turn the functionality off and have all the screen estate being filled with just a pretty wallpaper, much like in KDE, in that case later Nautilus-versions will do. Anyway, Linux is in much need of a SOLID desktop, which seems just like a wish at the moment. Even Microsoft is struggling GUI-wise with its Windows 8-debacle ....
    Ubuntu Gnome 13.10 Asus P5Q-DeLuxe C2Q Q9450@3.2GHz 8GB Nvidia GTX650Ti 1GB Asus Xonar Essence ST Crucial M4 64GB(system) 3TB storage Corsair VX450 Xigmatek Asgard

  7. #17
    Join Date
    Jun 2005
    Location
    Where?
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Can't install nvidia-319

    Anyway, Linux is in much need of a SOLID desktop, which seems just like a wish at the moment. Even Microsoft is struggling GUI-wise with its Windows 8-debacle ....[/QUOTE]
    +1
    But keep in mind saucy is in Development..

  8. #18
    Join Date
    May 2006
    Beans
    17

    Re: Can't install nvidia-319

    Quote Originally Posted by xeizo View Post
    There is an updated version of 319.23 in the repos now, which installs against kernel 3.10. No need for xorg-edgers anymore if running the latest kernel. Sadly, moving from Gallium to Nvidia under Kernel 3.10 killed Unity and Gnome Classic, but strange enough so does Gnome-Shell work fine. One wouldn't think of Gnome-Shell as a fallback desktop, but in this case it is ... important to keep Nautilus 3.6.3 though as the desktop itself is destroyed when using a newer Nautilus. Gallium works fine with all of the above, but it can't run games properly, using the Linux-port of Portal as a test. Changing to Nvidia, while breaking a lot of the desktop stuff except Gnome-Shell, indeed makes it possible to run Portal properly! Ubuntu 13.10 is in a VERY buggy state right now, I don't think 13.04 ever was this buggy during it's release-cycle, but it's still Alpha so things will/must improve a lot Btw, running yesterdays build of Ubuntu fully updated and extended with ubuntu-gnome-desktop, yesterdays build of Ubuntu Gnome was too buggy to use but the normal Ubuntu was usable enough to have as a base install.
    What repo do I need for 3.10?

    I am completely current as of this post with saucy sisters.

    uname -a
    Linux db1 3.9.0-6-generic #13-Ubuntu SMP Fri Jun 14 15:47:09 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

  9. #19
    Join Date
    May 2010
    Beans
    142

    Re: Can't install nvidia-319

    Quote Originally Posted by ajmcello View Post
    What repo do I need for 3.10? I am completely current as of this post with saucy sisters. uname -a Linux db1 3.9.0-6-generic #13-Ubuntu SMP Fri Jun 14 15:47:09 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
    There's no PPA for 3.10, but it can be downloaded manually here: http://kernel.ubuntu.com/~kernel-ppa...daily/current/ It will install against the latest Nvidia-blob which IS in the normal repos, install it so: Download headers, headers-all and the kernel, put them in a directory and issue the following on the command-line when standing in the same directory: sudo dpkg -i linux*.deb
    Ubuntu Gnome 13.10 Asus P5Q-DeLuxe C2Q Q9450@3.2GHz 8GB Nvidia GTX650Ti 1GB Asus Xonar Essence ST Crucial M4 64GB(system) 3TB storage Corsair VX450 Xigmatek Asgard

  10. #20
    Join Date
    May 2006
    Beans
    17

    Re: Can't install nvidia-319

    Thanks, I finally got 319 installed. I had to break the system (interupt apt-get remove after it removed nvidia-310 or 304), and install 319 manually by downloading the package.

    During the process, the following held me back, so I removed them:

    libcublas5.0
    libcudart5.0
    libcufft5.0
    libcuinj64-5.0
    libcupti5.0
    libcupti-dev
    libcurand5.0
    libcusparse5.0
    libnpp5.0
    libnvtoolsext5.0
    libthrust-dev
    libvdpau-dev
    nvidia-cuda-dev
    nvidia-cuda-toolkit
    nvidia-opencl-dev
    nvidia-profiler
    nvidia-visual-profiler
    opencl-headers

    Good to go with nvidia-319 and nvidia-319-dev and kernel 3.10

    Quote Originally Posted by xeizo View Post
    There's no PPA for 3.10, but it can be downloaded manually here: http://kernel.ubuntu.com/~kernel-ppa...daily/current/ It will install against the latest Nvidia-blob which IS in the normal repos, install it so: Download headers, headers-all and the kernel, put them in a directory and issue the following on the command-line when standing in the same directory: sudo dpkg -i linux*.deb

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •