Results 1 to 10 of 10

Thread: .wmv file not playing

  1. #1
    Join Date
    Apr 2013
    Beans
    9

    .wmv file not playing

    Hello all,
    I am a newbie into the world of linux and I have a 64-bit Asus K55V laptop and I had installed the Ubuntu 12.04 LTS 64-bit version using the WUBI installer.Now, I am trying to play a .wmv file and I went through a gazillion threads on how to rectify the problem.

    When I first tried, it gave me an error "Python (v2.7) requires to install plugins to play media files of the following type: video/x-asf-unknown decoder". Please pardon me if I am wrong anywhere. After a lot of research, I downloaded the unrestricted-extras, done with the update command in terminal and even downloaded w64codecs. ( since my machine is 64 bit). Now, it gives me the same error, but it plays the audio. I even added the mediubuntu repo into the sources.list or something like that, but no luck

    Also, I downloaded Kplayer, VLC, Mplayer and tried the different combinations. All the players play audio perfectly, but no VIDEO.

    Please HELP !!!! I have some real urgency to view these videos and they are all .wmv format.

    cheers in advance
    chemical

  2. #2
    Join Date
    Jan 2013
    Location
    East Yorkshire
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: .wmv file not playing !!


  3. #3
    Join Date
    Apr 2013
    Beans
    9

    Re: .wmv file not playing !!

    Quote Originally Posted by speartip View Post

    Tried it as well. In the software center, I am not able to find totem media player when I type TOTEM in the search bar.

  4. #4
    Join Date
    Dec 2012
    Location
    USA
    Beans
    185
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: .wmv file not playing !!

    See if you have the FFmpeg plugin installed.

  5. #5
    Join Date
    Jan 2013
    Location
    East Yorkshire
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: .wmv file not playing !!

    You're obviously missing something from your install.
    I have 12.04 64 bit installed & every player I found could play a .wmv. VLC, Totem & Kaffeine.
    check you have the canonical partner repos enabled, in synaptic, (if you don't have synaptic install it) then try reinstalling ubuntu-restricted-extras.
    Other than that I don't know what to suggest. I can't see it being a wubi problem, although IMO, dual booting is far better than a wubi install.

  6. #6
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    9,041
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: .wmv file not playing !!

    There is a class of WMV files that will not play in 64-bit Linux because the codec file needed for them is only available in a 32-bit build. See this thread for details and some workarounds.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  7. #7
    Join Date
    Dec 2006
    Beans
    7,091

    Re: .wmv file not playing !!

    Quote Originally Posted by chemical1608 View Post
    I have some real urgency to view these videos and they are all .wmv format. l
    Can you post one of these troublesome files online?
    You think that's air you're breathing now?

  8. #8
    Join Date
    Jun 2007
    Beans
    13,462

    Re: .wmv file not playing

    If it is mms2 then on 64bit install there still is no Ubuntu/Debian solution.
    But as andrew.46 noted on linked thread a relatively current mplayer that uses FFmpeg will have no issue in 64 bit installs
    (repo mplayer packages use Libav which does not have mss2 decoding support

  9. #9
    Join Date
    Apr 2013
    Beans
    9

    Re: .wmv file not playing !!

    Hey Speartip,

    "check you have the canonical partner repos enabled". Where and how exactly do I do this?

    Cheers
    chemical1608

  10. #10
    Join Date
    Jan 2013
    Location
    East Yorkshire
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: .wmv file not playing !!

    Quote Originally Posted by chemical1608 View Post
    Hey Speartip,

    "check you have the canonical partner repos enabled". Where and how exactly do I do this?

    Cheers
    chemical1608
    Go into synaptic, settings, repositories, other software, & make sure canonical partners & independants are ticked.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •