Results 1 to 4 of 4

Thread: Geany Execute problem

  1. #1
    Join Date
    Apr 2013
    Beans
    2

    Unhappy Geany Execute problem

    Hello there, first of all I want to apologize for my bad explanation, and if there is another topic like this, I just didn't find it. Ok here is my problem I try to run a C program under Geany, it compiles and builds fine, but when it comes to the execution, it just gives me a blank page, with no response. I am not sure what can be causing this...
    I hope this Screenshot helps finding the problem
    jeany execute problem.jpg

  2. #2
    Join Date
    Jun 2011
    Location
    United Kingdom
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: Geany Execute problem

    If you look into the directory you saved your source code/project into, is there an executable file in there? If so, run that file from the terminal, and see if you get anything then. (You may have a bug in your program)

    If you get something in your terminal you probably want to fix the geany settings. I believe there's a build menu.

  3. #3
    Join Date
    Apr 2013
    Beans
    2

    Re: Geany Execute problem

    Thank you, just found it about 10 mins ago, yea I can run it in the terminal, but it's kinda annoying, having to run it every time from there, I should look for some problem in the settings. Thank you mate!

  4. #4
    Join Date
    Apr 2012
    Beans
    5,597

    Re: Geany Execute problem

    Yes if you go to the Build --> Set Build Commands menu item you should see an 'Execute' action at the bottom - mine says "./%e" (which is the default value, afaik) which says 'run the executable in the current directory' (your 'Build' action should set the output file as -o "%e")

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •