Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Ubuntu install USB doesn't boot in UEFI mode on ASUS K55N laptop

  1. #1
    Join Date
    Nov 2009
    Beans
    4

    Ubuntu install USB doesn't boot in UEFI mode on ASUS K55N laptop

    Hello,

    I am trying to install Ubuntu 12.10 64-bit, on my ASUS K55N laptop that came with Windows 8 pre-installed. I wish to dual-boot Windows 8 and Ubuntu 12.10, but every time I try to boot the install medium (a USB drive), it freezes right after printing something along the lines of "binary trusted" if Secure Boot is enabled, or "Secure boot not enabled" when secure boot is disabled. I've tried two other distributions (Fedora 18 and Arch Linux), but it always freezes at the same place (right after some confirmation of the Secure Boot state). The only way that I've been able to boot anything other than Windows 8 in UEFI mode is if I boot it in BIOS-compatibility mode (with Launch CSM enabled).

    I've spent a long time googling for a solution to this problem, but I've only come up with people saying how this laptop refuses to boot anything other than Windows 8 in UEFI mode (for example, http://mjg59.dreamwidth.org/22028.html?replyto=892940 or https://lists.ubuntu.com/archives/fo...er/125271.html). Personally, I've tried installing Arch Linux in BIOS-compatibility mode, and then installing an UEFI bootloader, but the boot would get stuck right after printing "Loading initial ramdisk ...," which would be about the same place in the boot sequence as with the Ubuntu install USB (that is, right after the GRUB boot screen).

    The reason why I prefixed this thread with "[all variants]" is because I don't think this issue is limited to any one linux distro/flavour of Ubuntu.

    If anyone has anything to say about this, or any solutions, that would be great.

    Laptop specs:
    ASUS K55N
    CPU: AMD A8-4500M
    Graphics: Radeon 7460G (APU)
    RAM: 8GB DDR3-1600
    HDD: 750GB

    Thanks.

  2. #2
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu install USB doesn't boot in UEFI mode on ASUS K55N laptop

    Boot-Repair will convert an Ubuntu install in gpt partition drive to UEFI install by uninstalling grub-pc and installing grub-efi. For a few systems that seems to be the only way to install. Some suggest only having Linux in BIOS mode but that is a real hassle as you have to go into UEFI/BIOS and change boot mode to match install.

    How Boot-Repair fixes a Ubuntu with grub-pc with efi Windows
    http://ubuntuforums.org/showpost.php...&postcount=516

    Boot-Repair - Updated Jan 1, 2013 to not rename first time, but rename if first time Windows does not boot. Post 706 and 711
    http://ubuntuforums.org/showthread.p...769482&page=71


    ASUS K55A Windows 8 & Ubuntu Some Asus need this boot parameter pci=nomsi
    http://ubuntuforums.org/showthread.php?t=2088499
    Asus K55n will not boot in UEFI mode. Boot Parameters? Feb 2013
    http://ubuntuforums.org/showthread.php?t=2111720
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  3. #3
    Join Date
    Nov 2009
    Beans
    4

    Re: Ubuntu install USB doesn't boot in UEFI mode on ASUS K55N laptop

    I've tried installing Ubuntu in BIOS-mode, and then replacing grub-pc with grub-efi with boot-repair. I am able to boot Windows, but the ubuntu boot still freezes before loading the kernel and ramdisk.

  4. #4
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu install USB doesn't boot in UEFI mode on ASUS K55N laptop

    What video?
    Are you booting Windows directly from UEFI, or from a grub menu?

    If you get grub menu have you tried nomodeset or other boot parameters or both?
    Graphics Resolution- Upgrade /Blank Screen after reboot mega thread - MAFoElffen
    http://ubuntuforums.org/showthread.php?t=1743535
    How to set NOMODESET and other kernel boot options in grub2 - both liveCD & first boot, but different
    http://ubuntuforums.org/showthread.php?t=1613132
    https://help.ubuntu.com/community/BootOptions
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  5. #5
    Join Date
    Nov 2009
    Beans
    4

    Re: Ubuntu install USB doesn't boot in UEFI mode on ASUS K55N laptop

    Booting Windows from the grub menu works. The video is the built-in radeon 7640G of the a8-4500m. I've tried nomodeset and pci=nomsi, but it doesn't work either.

  6. #6
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu install USB doesn't boot in UEFI mode on ASUS K55N laptop

    I do not know AMD as I have nVidia.
    I thought there were some issues with the very new 7000 series. And I am not sure the links I posted above had good solutions.
    Did live version boot ok?

    https://wiki.ubuntu.com/X/Troublesho...riverDetection
    Ubuntu Precise Installation Guide - AMD/ATI
    http://wiki.cchtml.com/index.php/Ubu...#Video_Tearing
    Add Hardware Graphics - ATI: After installing ATI Driver: From QIII
    http://ubuntuforums.org/showthread.php?t=2050320
    sudo apt-get install fglrx
    #sudo aticonfig --initial -f
    sudo aticonfig --adapter=all --initial
    After reboot to get Catalyst Control Center
    sudo apt-get install fglrx-amdcccle

    https://help.ubuntu.com/community/RadeonDriver
    https://wiki.ubuntu.com/X/Troublesho...thRadeonDriver
    http://ubuntuforums.org/showthread.php?t=1558406


    http://www.phoronix.com/scan.php?pag...amdstock&num=1
    On the proprietary driver side, the AMD Catalyst 12.11 Beta Linux graphics driver was used. For this initial testing, three discrete graphics cards from the AMD Radeon HD 5000/6000 series were used, since pre-HD5000 graphics cards are now on the Catalyst Legacy driver and the latest-generation Radeon HD 7000 series hardware still doesn't fully work with the open-source Gallium3D "RadeonSI" driver.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  7. #7
    Join Date
    May 2013
    Location
    Kerala, India
    Beans
    31
    Distro
    Ubuntu Studio 13.10 Saucy Salamander

    Re: Ubuntu install USB doesn't boot in UEFI mode on ASUS K55N laptop

    Thanks for your reply oldfred. But I'm sorry to inform you that even that didn't work. Or probably I didn't know how to set it right... This is the code that I got when I pressed the 'e' key from the GRUB2 bootloader menu.
    Code:
     setparams 'Install Ubuntu'
     set gfxpayload=keep
     linux /casper/vmlinuz.efi file=/cdrom/pressed/ubuntu.seed boot=casper only-ubiquity quiet splash --
     initrd /casper/initrd.lz
    and I replaced that with...
    Code:
     setparams 'Install Ubuntu'
     set gfxpayload=keep
     linux /casper/vmlinuz.efi file=/cdrom/pressed/ubuntu.seed boot=casper only-ubiquity nomodeset
     initrd /casper/initrd.lz
    Is that how it is supposed to be done?? Nothing happened when I did this... I tried other combinations as deleting the
    Code:
     set gfxpayload=keep
    line, etc but none worked.
    Please help me. I'm desperately in need of installing Ubuntu. I Love Ubuntu and wanna use it permanently. But I don't wanna let go of my OEM Windows 8 either.

  8. #8
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu install USB doesn't boot in UEFI mode on ASUS K55N laptop

    Your nomodeset looks correct.

    I think this is only grub, but you can change the gfx mode. But use your size.
    replace "set gfxmode=auto" by "set gfxmode=1366x768"
    If you do not know sizes supported.
    At grub menu change to command line


    From a grub command line to see available settings pressing <c> & escape to get back to meu
    vbeinfo

    But some systems need other boot parameters in addition to nomodeset.

    https://help.ubuntu.com/community/BootOptions
    http://www.mjmwired.net/kernel/Docum...parameters.txt
    noapic nolapic noapci noirqpoll nosmp irqpoll

    And some older settings, not sure they work with UEFI. Sometimes forcing generic gets it to boot.

    Some other settings:
    http://ubuntu-tutorials.com/2010/05/...up-workaround/


    • Older Intel video card: i915.modeset=1 or i915.modeset=0 newer: i915.i915_enable_rc6=1
    • nVidia: nomodeset
    • Generic: xforcevesa or nouveau.modeset=0
    • Radeon: radeon.modeset=0
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  9. #9
    Join Date
    Jan 2013
    Beans
    9

    Re: Ubuntu install USB doesn't boot in UEFI mode on ASUS K55N laptop

    I am having the same problem with the same laptop asus k55n,

    I used boot-repair in legacy mode because the blank screen problem would happen trying to install ubuntu in UEFI mode, even with quiet splash disabled, the screen was not verbose and was blank.

    After boot-repair : automatic, booting windows from grub works fine, but nomodeset does not have any effect on getting a blank screen when trying to boot ubuntu.

    If I boot older version of ubuntu from grub, it shows loading Linux Generic... , and then freezes after Loading initial ramdisk.

    I tried ls -l in grub <c> menu and it appears that the command list options are pointing to the correct boot partition (hd0, gpt4) , can't figure this out.

  10. #10
    Join Date
    May 2013
    Location
    Kerala, India
    Beans
    31
    Distro
    Ubuntu Studio 13.10 Saucy Salamander

    Re: Ubuntu install USB doesn't boot in UEFI mode on ASUS K55N laptop

    In vain again. I tried putting in all the commands from the GRUB2 edit mode into the Command Line Interface, but in vain. There was some activity when I pressed <enter> after loading the kernel. But then again it went dead later.
    This is the code I typed in
    Code:
    grub> setparams 'Install Ubuntu'
    grub> set gfxpayload=keep
    grub> set gfxmode=1366x768
    grub> linux /casper/vmlinuz.efi file=/cdrom/pressed/ubuntu.seed boot=casper only-ubiquity nomodeset
    grub> initrd /casper/initrd.lz
    grub> boot
    After I pressed the <Enter> key, the LED indicator on my USB PenDrive became idle and the grub refused to give me a shell (grub>). That's where I stopped.
    Last edited by divine shine; May 11th, 2013 at 06:36 PM.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •