Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: FYI: RTL8111/8168 works under 13.04 (problems with 12.10)

  1. #11
    Join Date
    Feb 2007
    Location
    Albuquerque, NM US
    Beans
    314
    Distro
    Ubuntu Development Release

    Re: FYI: RTL8111/8168 works under 13.04 (problems with 12.10)

    13.04 gives me this:
    sudo lshw -C network
    *-network DISABLED
    description: Ethernet interface
    product: RTL8111/8168 PCI Express Gigabit Ethernet controller
    vendor: Realtek Semiconductor Co., Ltd.

    12.04 this:
    lshw -C network
    WARNING: you should run this program as super-user.
    *-network
    description: Ethernet interface
    product: RTL8111/8168B PCI Express Gigabit Ethernet controller
    vendor: Realtek Semiconductor Co., Ltd.

    8168 vs. 8168B...any significance here?
    cheap hardware....LOTS of it

  2. #12
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: FYI: RTL8111/8168 works under 13.04 (problems with 12.10)

    The output shows that the driver isn't loaded. I don't have that chipset, so I'm not sure what driver you need.

  3. #13
    Join Date
    Feb 2007
    Location
    Albuquerque, NM US
    Beans
    314
    Distro
    Ubuntu Development Release

    Re: FYI: RTL8111/8168 works under 13.04 (problems with 12.10)

    Weird (to me anyway)...works fine with 12.04 and not with 13.04....cannot remember if I tried 12.10 on this machine. I did get the same 13.04 result with 3.8 and 3.9...

    Maybe it will sort out as time goes by but then again maybe not.
    cheap hardware....LOTS of it

  4. #14
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: FYI: RTL8111/8168 works under 13.04 (problems with 12.10)

    If you still have a working 12.04 installation, you can check it to see what driver the network card uses.

  5. #15
    Join Date
    Apr 2013
    Beans
    120
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: FYI: RTL8111/8168 works under 13.04 (problems with 12.10)

    Quote Originally Posted by rtalcott View Post
    Weird (to me anyway)...works fine with 12.04 and not with 13.04....cannot remember if I tried 12.10 on this machine. I did get the same 13.04 result with 3.8 and 3.9...

    Maybe it will sort out as time goes by but then again maybe not.
    I confirm that RTL811/8168 works perfectly with 13.04, it was instantly recognized when I installed.

  6. #16
    Join Date
    Feb 2007
    Location
    Albuquerque, NM US
    Beans
    314
    Distro
    Ubuntu Development Release

    Re: FYI: RTL8111/8168 works under 13.04 (problems with 12.10)

    From my 12.04 output...complete output on the previous page:

    capabilities: bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A ip=192.168.1.116 latency=0 multicast=yes port=MII speed=100Mbit/s
    resources: irq:40 ioport:8c00(size=256) memory:fd8ff000-fd8fffff memory:fd7f0000-fd7fffff memory:fd700000-fd71ffff
    cheap hardware....LOTS of it

  7. #17
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: FYI: RTL8111/8168 works under 13.04 (problems with 12.10)

    Quote Originally Posted by rtalcott View Post
    From my 12.04 output...complete output on the previous page:

    capabilities: bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A ip=192.168.1.116 latency=0 multicast=yes port=MII speed=100Mbit/s
    resources: irq:40 ioport:8c00(size=256) memory:fd8ff000-fd8fffff memory:fd7f0000-fd7fffff memory:fd700000-fd71ffff
    That's the driver I thought you needed, you can try loading that driver using the following command:

    Code:
    sudo modprobe r8169
    with a bit of luck, networking should start working right away, if not use the following command:

    Code:
    sudo service networking restart
    If that doesn't work, just reboot.

  8. #18
    Join Date
    Feb 2007
    Location
    Albuquerque, NM US
    Beans
    314
    Distro
    Ubuntu Development Release

    Re: FYI: RTL8111/8168 works under 13.04 (problems with 12.10)

    No cigar...if I modprobe and then restart networking it locks up....if I modprobe and then reboot it's no change (no wired Ethernet). I'd be willing to say I had a hardware problem if it was not for the fact that it runs 12.04 fine...maybe I should download another daily and reinstall and hope....
    cheap hardware....LOTS of it

  9. #19
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: FYI: RTL8111/8168 works under 13.04 (problems with 12.10)

    Have you checked to see if the module (driver) exists in /lib/modules/3.8.0-19-generic/kernel/drivers/net/ethernet/realtek. You should see the following in that directory:

    Code:
    ls -l
    total 224
    -rw-r--r-- 1 root root  43208 Apr 17 11:48 8139cp.ko
    -rw-r--r-- 1 root root  52632 Apr 17 11:48 8139too.ko
    -rw-r--r-- 1 root root  22228 Apr 17 11:42 atp.ko
    -rw-r--r-- 1 root root 103356 Apr 17 11:42 r8169.ko

  10. #20
    Join Date
    Feb 2007
    Location
    Albuquerque, NM US
    Beans
    314
    Distro
    Ubuntu Development Release

    Re: FYI: RTL8111/8168 works under 13.04 (problems with 12.10)

    rtalcott@evga:/lib/modules/3.8.0-19-generic/kernel/drivers/net/ethernet/realtek$ ls -l
    total 224
    -rw-r--r-- 1 root root 43208 Apr 17 12:48 8139cp.ko
    -rw-r--r-- 1 root root 52632 Apr 17 12:48 8139too.ko
    -rw-r--r-- 1 root root 22228 Apr 17 12:42 atp.ko
    -rw-r--r-- 1 root root 103356 Apr 17 12:42 r8169.ko

    uname -a
    Linux evga 3.9.0-030900rc7-generic #201304171402 SMP Wed Apr 17 18:04:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

    edit: I went through all the steps with the 3.8 kernel...same result.
    Last edited by rtalcott; April 21st, 2013 at 10:44 PM.
    cheap hardware....LOTS of it

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •