Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Lenovo W520 won't boot any distro from HD. UEFI is turned off and legacy mode is on.

  1. #1
    Join Date
    Apr 2013
    Beans
    11

    Lenovo W520 won't boot any distro from HD. UEFI is turned off and legacy mode is on.

    I've tried Ubuntu, Mint, etc. No luck with any of them. The live CD works fine. I've tried this with 2 different hard drives, no luck. UEFI is turned off and legacy mode is on. I've tried turning nVidia Optimus off too. All I get is a blinking cursor. Can anyone help me? I was under the impression that the W520 is very Linux friendly, so far this has been pretty discouraging. Any help would be appreciated.

    Thanks,
    -lolthisismyname
    Last edited by lolThisIsMyName; April 19th, 2013 at 02:09 AM.

  2. #2
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,660
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Lenovo W520 won't boot any distro from HD. UEFI is turned off and legacy mode is

    Hi lolThisIsMyName.

    What version of Ubuntu are you trying to install? For 12.04.4 it is not necessary to disable UEFI BTW.

    What is the size of you HD? If it is bigger than 2TB you may need to create GPT partition table with a special grub partition to boot form it.

    Regards.

  3. #3
    Join Date
    Apr 2013
    Beans
    11

    Re: Lenovo W520 won't boot any distro from HD. UEFI is turned off and legacy mode is

    Hi papibe, thanks for responding! I'm using 12.10 I believe. The HD is a 128 GB Samsung 830 SSD right now, before it was a 512 mb western digital mechanical drive.

    Not sure if this is relevant, but on drives where Windows is installed, it boots just fine.
    Last edited by lolThisIsMyName; April 19th, 2013 at 05:32 PM.

  4. #4
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,617
    Distro
    Ubuntu Development Release

    Re: Lenovo W520 won't boot any distro from HD. UEFI is turned off and legacy mode is

    Hi

    Is this a bare metal install or are you trying to install in a VM ?

    Are you using intel or nvidia graphics ?

    Is this a 32 or 64 bit install ?

    EDIT:

    Try disabling VT-d in the BIOS and enable discrete graphics.

    Kind regards
    Last edited by matt_symes; April 19th, 2013 at 05:43 PM.
    Join us on irc at #ubuntuforums. For web chat see here

    If you believe everything you read, you better not read. ~ Japanese Proverb

    Do not read newspapers on an empty stomach ~ Russian Proverb ~ BrunoLotse

  5. #5
    Join Date
    Apr 2013
    Beans
    11

    Re: Lenovo W520 won't boot any distro from HD. UEFI is turned off and legacy mode is

    Hi Matt,

    It's a full install, no VMs.

    I've got it set to discrete and it's 64 bit.

    Thanks for your response!

  6. #6
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,617
    Distro
    Ubuntu Development Release

    Re: Lenovo W520 won't boot any distro from HD. UEFI is turned off and legacy mode is

    Hi

    Disable VT-d in the BIOS and try to install again.

    People have comlained about the 64bit version, your laptop model, graphics and VT-d.

    Take a look:

    http://forums.lenovo.com/t5/Linux-Di...ia/td-p/577789

    Kind regards
    Join us on irc at #ubuntuforums. For web chat see here

    If you believe everything you read, you better not read. ~ Japanese Proverb

    Do not read newspapers on an empty stomach ~ Russian Proverb ~ BrunoLotse

  7. #7
    Join Date
    Apr 2013
    Beans
    11

    Re: Lenovo W520 won't boot any distro from HD. UEFI is turned off and legacy mode is

    Thanks, but how do I disable VT-d? I can't find it in the boot menu.

  8. #8
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Lenovo W520 won't boot any distro from HD. UEFI is turned off and legacy mode is

    Is Windows installed in UEFI mode?
    IF so you need to install Ubuntu in UEFI mode with secure boot off, but UEFI on or BIOS/Legacy off.

    You will need to use the 64 bit version of 12.10 or 12.04.2 and from the UEFI menu boot the flash drive in UEFI mode. That way it will install in UEFI mode.
    Systems need quick boot or fast boot turned off in UEFI settings. Vital for some systems. Best to backup efi partition and Windows partition first.
    Use Windows Disk Tools to shrink Windows main partition, but not to create any new partitions, if installing on same drive.
    https://help.ubuntu.com/community/UEFI
    https://wiki.archlinux.org/index.php/UEFI
    As of 12.04.2, it is possible to install on UEFI systems with Secure Boot enabled (using signed versions of Shim, GRUB, and the Linux kernel). This is only currently set up for Ubuntu (desktop, alternate, and server) and Edubuntu images due to pressures of time; we expect to enable it across the entire Ubuntu family for 12.04.3. Details:
    https://wiki.ubuntu.com/PrecisePango.../UbuntuDesktop
    Installing Grub for UEFI secure boot is only possible if you have booted your system using EFI.


    Lenovo Community Bios Access
    http://forums.lenovo.com/t5/IdeaPad-.../812737/page/2
    Lenovo Active Protection System™ – for hard drive
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  9. #9
    Join Date
    Apr 2013
    Beans
    11

    Re: Lenovo W520 won't boot any distro from HD. UEFI is turned off and legacy mode is

    >Is Windows installed in UEFI mode?

    No, Windows is not installed at all. I'll give what you said a try if I can figure it out.

  10. #10
    Join Date
    Apr 2013
    Beans
    11

    Re: Lenovo W520 won't boot any distro from HD. UEFI is turned off and legacy mode is

    I'm having a hard time understanding what, exactly, I'm supposed to do.

    Why won't just booting in legacy mode work?

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •