Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: can't connect to wifi on ubuntu 12.10

  1. #1
    Join Date
    Apr 2013
    Beans
    9

    can't connect to wifi on ubuntu 12.10

    Ive recently installed ubuntu on my pc. the problem is, i can't connect to my home wifi on ubuntu. i'm running ubuntu 12.10 now and i absolutely dont know how to fix this. my laptop use a broadcomm adapter. somebody please help me...
    Last edited by akuripin; April 18th, 2013 at 08:00 PM.

  2. #2
    Join Date
    Aug 2011
    Location
    52° N 6° E
    Beans
    2,617
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: can't connect to wifi on ubuntu 12.10

    You may need a proprietary driver for that wifi hardware. Get a wired connection, go to additional drivers and they can be downloaded and installed automatically.

  3. #3
    Join Date
    Apr 2013
    Beans
    9

    Re: can't connect to wifi on ubuntu 12.10

    Quote Originally Posted by Impavidus View Post
    You may need a proprietary driver for that wifi hardware. Get a wired connection, go to additional drivers and they can be downloaded and installed automatically.
    thanx. but where can i find the additional driver? is it in the terminal or in the application part?

  4. #4
    Join Date
    Apr 2013
    Beans
    2

    Re: can't connect to wifi on ubuntu 12.10

    find it here: System>Administration>Additional Drivers

  5. #5
    Join Date
    Mar 2011
    Location
    19th Hole
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: can't connect to wifi on ubuntu 12.10

    Hi and welcome to the forums and to Ubuntu.

    I swear that trouble comes in bunches. You are the fourth WIFI issue this week, which hopefully means that the solution is fresh in our minds

    Broadcoms are known to be finicky. Please open up a terminal and do:
    Code:
    wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script
    This will download a script, run it, and produce a file on your current directory (usually desktop) that generates a report stripped of personally identifiable info (like your MAC address). Please attach this report to your reply using the paperclip icon in the reply toolbar. It will tell us what broadcom chip you have as well as a wealth of other info that we can use to track down drivers, settings and configurations.
    Newb: How far must I jump to clear the ledge halfway down?
    Guru: It's bad to jump off cliffs. Let's look at better options.
    Newb: Stop harping about "best practices" and just let me jump.


  6. #6
    Join Date
    Apr 2013
    Beans
    9

    Re: can't connect to wifi on ubuntu 12.10

    Quote Originally Posted by vishal goyal View Post
    find it here: System>Administration>Additional Drivers
    okay..i cant find system>administration>additional driver.. is it system setting? i also cant find that in system setting..

  7. #7
    Join Date
    Apr 2013
    Beans
    9

    Re: can't connect to wifi on ubuntu 12.10

    Quote Originally Posted by DuckHook View Post
    Hi and welcome to the forums and to Ubuntu.

    I swear that trouble comes in bunches. You are the fourth WIFI issue this week, which hopefully means that the solution is fresh in our minds

    Broadcoms are known to be finicky. Please open up a terminal and do:
    Code:
    wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script
    This will download a script, run it, and produce a file on your current directory (usually desktop) that generates a report stripped of personally identifiable info (like your MAC address). Please attach this report to your reply using the paperclip icon in the reply toolbar. It will tell us what broadcom chip you have as well as a wealth of other info that we can use to track down drivers, settings and configurations.
    is this the report?
    Attached Files Attached Files

  8. #8
    Join Date
    Mar 2011
    Location
    19th Hole
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: can't connect to wifi on ubuntu 12.10

    Yes, this is the right report. It shows that you are already using the correct driver, so no need to install another.

    Please describe in detail how you tried to connect to your home router:

    1. What security protocol is your router? Try setting it to WPA2-Personal or WPA2-AES
    2. Did you try connecting through Network Manager?
    3. Did you doublecheck to make sure your encryption key is accurate?
    Newb: How far must I jump to clear the ledge halfway down?
    Guru: It's bad to jump off cliffs. Let's look at better options.
    Newb: Stop harping about "best practices" and just let me jump.


  9. #9
    Join Date
    Apr 2013
    Beans
    9

    Re: can't connect to wifi on ubuntu 12.10

    Quote Originally Posted by DuckHook View Post
    Yes, this is the right report. It shows that you are already using the correct driver, so no need to install another.

    Please describe in detail how you tried to connect to your home router:

    1. What security protocol is your router? Try setting it to WPA2-Personal or WPA2-AES
    2. Did you try connecting through Network Manager?
    3. Did you doublecheck to make sure your encryption key is accurate?
    WEP protocol. where can i find the network manager? yes i double checked the encryption key..

  10. #10
    Join Date
    Mar 2011
    Location
    19th Hole
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: can't connect to wifi on ubuntu 12.10

    Network Manager is available on the top right of your global menu bar. It is the little icon with the up and down arrows. If you click on the icon, it will open a drop-down box. Make sure "Enable Wireless" is checked, then: Edit Connections...> Wireless

    If your SSID already appears then: Select it > Edit > Make sure SSID is correct (case matters in Linux), Mode : Infrastructure > IP4 Settings > Method: Automatic (DHCP) > Wireless Security > Select WPA & WPA2 Personal > [Type in encryption key/passphrase] (remember: case matters) > Save

    If not, then: > Add > [Type in your SSID], Mode: Infrastructure > IP4 Settings > Method: Automatic (DHCP) > Wireless Security > Select WPA & WPA2 Personal > [Type in encryption key/passphrase] > Save

    If wireless does not come on, reboot your computer.

    For above to work, you must have already set your router to WPA2 Personal AES, proper encryption key, saved, then rebooted your router.

    <edit>

    WEP protocol is the worst protocol in creation and can be broken literally in a few minutes. It lulls you into a false illusion of security while offering none at all. Use WPA2 personal with a good encryption phrase of at least 30 characters, mix of letters and numbers.

    </edit>
    Last edited by DuckHook; April 18th, 2013 at 06:48 PM. Reason: Warning on WEP encryption
    Newb: How far must I jump to clear the ledge halfway down?
    Guru: It's bad to jump off cliffs. Let's look at better options.
    Newb: Stop harping about "best practices" and just let me jump.


Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •