Hi all,
I've been trying to add a new repository using add-apt-repository but getting the following error.
PS- i am behind a proxy

root@sanketh:~# add-apt-repository ppa:webupd8team/sublime-text-2
You are about to add the following PPA to your system:
Sublime Text 2 packages - the .deb will automatically download the latest build from http://www.sublimetext.com/dev or beta from http://www.sublimetext.com/2 (Adobe Flash Player installer - style).


More info and feedback:
http://www.webupd8.org/2011/03/subli...buntu-ppa.html
http://www.webupd8.org/2012/03/subli...velopment.html
More info: https://launchpad.net/~webupd8team/+...sublime-text-2
Press [ENTER] to continue or ctrl-c to cancel adding it


gpg: keyring `/tmp/tmpcqhauy/secring.gpg' created
gpg: keyring `/tmp/tmpcqhauy/pubring.gpg' created
gpg: requesting key EEA14886 from hkp server keyserver.ubuntu.com
gpgkeys: key 7B2C3B0889BF5709A105D03AC2518248EEA14886 not found on keyserver
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

Help is appreciated