Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Overheating

  1. #1
    Join Date
    Apr 2013
    Beans
    10

    Overheating

    Hi. I have Ubuntu 12.04 installed on my laptop and it heats up a lot, the fan is way too noisy.
    I have installed 'psensor' and this is what it shows -



    My graphics card is ATI Mobility Radeon HD 4250. Also I opened 'Additional drivers' and selected this -



    How can I lower the temperatures? Please help.
    Last edited by pranavbaitule; April 13th, 2013 at 08:07 PM.

  2. #2
    Join Date
    Jan 2007
    Beans
    3,202

    Re: Heat!!!

    Your links aren't working correctly. From the HTML source I looked at the second one, which shows the fglrx driver installed but not in use. Being an Nvidia user I can't be certain, but pending better advice from the ATI crowd, I would advise doing this:

    1. In system > additional drivers, change back to the open source radeon driver, and reboot.

    2.
    Code:
    sudo apt-get update && sudo apt-get install linux-headers-$(uname -r) build-essential
    3. In systemsettings > additional drivers, set it back to your fglrx driver, and reboot.

    Now, is it working correctly when you look in systemsettings > additional drivers? It should show the fglrx driver in use.
    Intel Core i7-950 / Asus P6X58D-E / Nvidia GTX480 / siduction 64-bit on OCZ Revodrive SSD / KDE4.10.2/ Kubuntu 13.04

  3. #3
    Join Date
    Apr 2013
    Beans
    10

    Re: Heat!!!

    Quote Originally Posted by dabl View Post
    Your links aren't working correctly. From the HTML source I looked at the second one, which shows the fglrx driver installed but not in use. Being an Nvidia user I can't be certain, but pending better advice from the ATI crowd, I would advise doing this:

    1. In system > additional drivers, change back to the open source radeon driver, and reboot.

    2.
    Code:
    sudo apt-get update && sudo apt-get install linux-headers-$(uname -r) build-essential
    3. In systemsettings > additional drivers, set it back to your fglrx driver, and reboot.

    Now, is it working correctly when you look in systemsettings > additional drivers? It should show the fglrx driver in use.
    Nope. It still shows that 'the driver is activated but not in use'.

  4. #4
    Join Date
    May 2007
    Beans
    12,372

    Re: Overheating

    The forums are chock full of folks installing the post-release drivers -- and then having serious display problems. I would choose the beta version from the list, over the post-release version.
    Ubuntu 14.04, Mint 17; MS Win 8.1.
    Will not respond to PM requests for support -- use the forums.

  5. #5
    Join Date
    Apr 2013
    Beans
    10

    Re: Overheating

    Quote Originally Posted by Mark Phelps View Post
    The forums are chock full of folks installing the post-release drivers -- and then having serious display problems. I would choose the beta version from the list, over the post-release version.
    Ok. I chose the beta drivers now and still I get the message 'This driver is activated but currently not in use' and the temperature is also above 90° C.

  6. #6
    Join Date
    Apr 2013
    Location
    Guildford, UK
    Beans
    104
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: Overheating

    This worked for me for the ATI Mobility Radeon 5470. Try it without installing kubuntu first but if when you've rebooted you get no desktop then the driver is incompatible with GNOME and you'll need to try something with KDE (like Kubuntu) or something else that doesn't use GNOME:

    1. Install Kubuntu.
    2. Remove any existing fglrx drivers and their settings:
    Code:
    sudo apt-get remove --purge fglrx*
    3. Install the required driver:
    Code:
    sudo apt-get install fglrx fglrx-amdcccle
    4. Configure the driver
    Code:
    sudo aticonfig --initial
    5. Reboot
    6. To get full hardware acceleration:
    Code:
    sudo apt-get install xvba-va-driver libva-glx1 libva-egl1 vainfo

    Hope that does it!

    Feathers

  7. #7
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    5,409
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Overheating

    If it's getting that hot when it's not under load then I suspect inadequate cooling. The judicious application of a can of compressed air would seem to be in order.
    None but ourselves can free our minds

  8. #8
    Join Date
    Apr 2013
    Beans
    10

    Re: Overheating

    Quote Originally Posted by Feathers McGraw View Post
    This worked for me for the ATI Mobility Radeon 5470. Try it without installing kubuntu first but if when you've rebooted you get no desktop then the driver is incompatible with GNOME and you'll need to try something with KDE (like Kubuntu) or something else that doesn't use GNOME:

    1. Install Kubuntu.
    2. Remove any existing fglrx drivers and their settings:
    Code:
    sudo apt-get remove --purge fglrx*
    3. Install the required driver:
    Code:
    sudo apt-get install fglrx fglrx-amdcccle
    4. Configure the driver
    Code:
    sudo aticonfig --initial
    5. Reboot
    6. To get full hardware acceleration:
    Code:
    sudo apt-get install xvba-va-driver libva-glx1 libva-egl1 vainfo

    Hope that does it!

    Feathers
    Ok. I did what you said and somehow the temperature is down to 75° C.

    But fglrx isn't installed! I get this in the terminal when I type 'fglrxinfo' -



    Also, when I go into System Settings>Details>Graphics, it shows the driver is VESA: RS880M. Will I have to manually install the legacy drivers?

  9. #9
    Join Date
    Apr 2013
    Beans
    10

    Re: Overheating

    Quote Originally Posted by CatKiller View Post
    If it's getting that hot when it's not under load then I suspect inadequate cooling. The judicious application of a can of compressed air would seem to be in order.

    Yes. The dust accumulation is definitely there but when I run windows, the temperature is between 60° C - 75° C which is high but it doesn't touch 90° C unless I play games.

  10. #10
    Join Date
    Apr 2013
    Location
    Guildford, UK
    Beans
    104
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: Overheating

    Interesting...I'm stumped.

    Have you considered trying Lubuntu or Xubuntu? They are supposed to be good with older hardware, and it's possible that if you ask less of your graphics card it'll cool off a bit.

    Feathers

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •