Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: nVidia update disabled desired resolution

  1. #11
    Join Date
    Apr 2008
    Beans
    10,421

    Re: nVidia update disabled desired resolution

    OK, the method described in posts #7 and #8 does work in Precise, Quantal, and Raring. Just a quick recap;

    First open the NVIDIA settings GUI and select Save to X config file as shown here:

    Screenshot from 2013-04-13 07:44:10.png

    DO NOT select "merge with existing file" when asked!

    When that is complete just Quit the NVIDIA settings GUI and open /etc/X11/xorg.conf as root with your desired text editor, eg;

    Code:
    sudo gedit /etc/X11/xorg.conf
    Then add the following line to the Device section:

    Code:
        Option         "ModeValidation" "AllowNonEdidModes"
    Here's my edited Raring xorg.conf with the added line highlighted in red:

    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 304.88  (buildd@komainu)  Wed Apr 10 16:15:17 UTC 2013
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "HannStar Display Corp Hanns.G Hi221"
        HorizSync       24.0 - 94.0
        VertRefresh     56.0 - 76.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 7025 / nForce 630a"
        Option         "ModeValidation" "AllowNonEdidModes"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "nvidiaXineramaInfoOrder" "CRT-0"
        Option         "metamodes" "nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    Then be sure to save the change and just quit gedit or your preferred text editor.

    Next just reboot, restarting X only seems not to be adequate!

    After the reboot just open the Display settings GUI, eg: in Ubuntu or Ubuntu GNOME - System Settings -> Displays, and hopefully you'll find that the desired resolution is now included in the list:

    Screenshot from 2013-04-13 08:51:23.jpg

    Hope that may help someone else

  2. #12
    Join Date
    Apr 2008
    Beans
    10,421

    Re: nVidia update disabled desired resolution

    Dumb question. how do I mark this Solved?

  3. #13
    Join Date
    Apr 2008
    Beans
    10,421

    Re: nVidia update disabled desired resolution


  4. #14
    Join Date
    Sep 2013
    Beans
    1

    Re: nVidia update disabled desired resolution

    Thank you SO MUCH! I've been trying to find a forum to help me all day.

    I've been looking in xrandr doing --addmode --newmode, etc., and that never worked. Doing this worked like a charm.

    ~Matt.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •