Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: Two wireless card, how do I disable one of them?

  1. #1
    Join Date
    Feb 2008
    Location
    Massachusetts
    Beans
    51
    Distro
    Ubuntu 12.04 Precise Pangolin

    Two wireless card, how do I disable one of them?

    I have a Sony Vaio with an intel Pro/wireless 2200BG (calexico2) card that is broken. In windows I disabled this card and installed a USB wireless device (Realtek 802.11n WLAN adapter) which makes wireless connection possible. I cannot get a wireless connection in LUBUNTU because the computer keeps on trying to connect through the original (broken) hardware. How can I disable that original hardware. I tried blacklisting the driver for the Intel hardware in /etc/modprobe.d but unfortunately that seems to interfere with any wireless connection.

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,110
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Two wireless card, how do I disable one of them?

    I tried blacklisting the driver for the Intel hardware in /etc/modprobe.d
    Please show us.

    That's actually the best way to disable the built-in, if done correctly.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Jan 2008
    Location
    Brooklyn, NY
    Beans
    167
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Two wireless card, how do I disable one of them?

    Can you remove the offending card? Then the system can't find it.

  4. #4
    Join Date
    Feb 2008
    Location
    Massachusetts
    Beans
    51
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Two wireless card, how do I disable one of them?

    The computer I am using is a vaio laptop with a known bad internal hardware intel pro/Wireless 2200 BG, and a USB 802.11n edimax EW-7811Un from Realtek. It is a dual boot system and when running windows I turn off the physical switch for wireless and the computer uses the edimax EW-7811Un USB wireless. In Lubuntu, when I turn off the switch the Networking GUI show no options for wireless connections (which Makes sense). When I have the switch turned to the "on" position the Networking GUI shows my router available to both wireless sources (the intel card and the edimax EW-7811Un). The network manager then repeatedly tries to connect to the correct network, and occasionally show a connection only to fail when used. When I blacklisted the Intel driver, the network manager no longer showed both cards, but continued to fail at obtaining a connection. Now I am thinking that the edimax EW-7811Un USB device is not working properly in Linux. Oh, a wired connection to the computer works fine and I am running 12.04 Lubuntu.

    Realtek Kernel Module rtl8192cu
    Intel Kernel Module IPW2200


    Thank you for any help.
    Last edited by Herber; April 9th, 2013 at 04:32 PM.

  5. #5
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,110
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Two wireless card, how do I disable one of them?

    Please show us the file where you did this:
    I tried blacklisting the driver for the Intel hardware in /etc/modprobe.d
    I suspect there is a slight error we can easily correct but I have to see the exact wording first.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  6. #6
    Join Date
    Feb 2008
    Location
    Massachusetts
    Beans
    51
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Two wireless card, how do I disable one of them?

    I have not previously posted output in the forums but this is a copy of my modprobe.b

    b@b-VGN-S360:/etc/modprobe.d$ cat blacklist.conf
    # This file lists those modules which we don't want to be loaded by
    # alias expansion, usually so some other driver will be loaded for the
    # device instead.

    # evbug is a debug tool that should be loaded explicitly
    blacklist evbug

    # these drivers are very simple, the HID drivers are usually preferred
    blacklist usbmouse
    blacklist usbkbd

    # replaced by e100
    blacklist eepro100

    # replaced by tulip
    blacklist de4x5

    # causes no end of confusion by creating unexpected network interfaces
    blacklist eth1394

    # snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
    # hardware on its own (Ubuntu bug #2011, #6810)
    blacklist snd_intel8x0m

    # Conflicts with dvb driver (which is better for handling this device)
    blacklist snd_aw2

    # causes failure to suspend on HP compaq nc6000 (Ubuntu: #10306)
    blacklist i2c_i801

    # replaced by p54pci
    blacklist prism54

    # replaced by b43 and ssb.
    blacklist bcm43xx

    # most apps now use garmin usb driver directly (Ubuntu: #114565)
    blacklist garmin_gps

    # replaced by asus-laptop (Ubuntu: #184721)
    blacklist asus_acpi

    # low-quality, just noise when being used for sound playback, causes
    # hangs at desktop session start (Ubuntu: #246969)
    blacklist snd_pcsp

    # ugly and loud noise, getting on everyone's nerves; this should be done by a
    # nice pulseaudio bing (Ubuntu: #77010)
    blacklist pcspkr

    # EDAC driver for amd76x clashes with the agp driver preventing the aperture
    # from being initialised (Ubuntu: #297750). Blacklist so that the driver
    # continues to build and is installable for the few cases where its
    # really needed.
    blacklist amd76x_edac

    #stopping driver to intel wireless
    blacklist ipw2200


    It is obviously the last entry.

  7. #7
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,110
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Two wireless card, how do I disable one of them?

    Looks perfect to me. Let's double-check a few other things:
    Code:
    lspci -nn | grep 0280
    cat /etc/modules
    lsmod | grep ipw
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  8. #8
    Join Date
    Feb 2008
    Location
    Massachusetts
    Beans
    51
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Two wireless card, how do I disable one of them?

    b@b-VGN-S360:~$ lspci -nn | grep 0280
    02:0b.0 Network controller [0280]: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection [8086:4220] (rev 05)
    b@b-VGN-S360:~$ cat /etc/modules
    # /etc/modules: kernel modules to load at boot time.
    #
    # This file contains the names of kernel modules that should be loaded
    # at boot time, one per line. Lines beginning with "#" are ignored.

    lp
    b@b-VGN-S360:~$ lsmod | grep ipw
    b@b-VGN-S360:~$ lsmod | grep ipw
    b@b-VGN-S360:~$

    The Realtek USB device just seems to search for the nework over and over, although with the blacklist, the intel card disappears.

  9. #9
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,110
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Two wireless card, how do I disable one of them?

    although with the blacklist, the intel card disappears.
    Well, then the question is solved, correct? Are you ready to troubleshoot the USB? Please try a driver parameter:
    Code:
    sudo modprobe -r rtl8192cu
    sudo modprobe rtl8192cu swenc=1
    Is the behavior improved, no change or worse?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #10
    Join Date
    Feb 2008
    Location
    Massachusetts
    Beans
    51
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Two wireless card, how do I disable one of them?

    The computer is unchanged after the above sudo modprobe commands. I became suspicious earlier that the problem was the USB device and not the presence of the intel card.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •