Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 41

Thread: Server works on Lan but not over internet.

  1. #11
    Join Date
    Apr 2013
    Beans
    28

    Re: Server works on Lan but not over internet.

    hi doug, did you refresh? because I can't get to them anywhere.....

  2. #12
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    1,781
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Server works on Lan but not over internet.

    Yes, I refreshed twice.

    However, now they (all 3) are not working for me. Odd. Oh... Correction two are just really really slow now, and one is not working.


    http://www.biddock.com/ works, but now slow.
    http://www.socialpitchman.com/ works, but now slow.
    http://www.bazoodle.com/ seems to have stopped working. (And it was the only site that was more than those little default pages you had the other day.)
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

  3. #13
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Server works on Lan but not over internet.

    Quote Originally Posted by Doug S View Post
    Yes, I refreshed twice.

    However, now they (all 3) are not working for me. Odd. Oh... Correction two are just really really slow now, and one is not working.


    http://www.biddock.com/ works, but now slow.
    http://www.socialpitchman.com/ works, but now slow.
    http://www.bazoodle.com/ seems to have stopped working. (And it was the only site that was more than those little default pages you had the other day.)
    I tried all three and they just throw a "The server at domainname is taking too long to respond." error.

    It's like the IP is right, but something isn't working.

    EDIT: Did canyouseeme tell you port 80 or 8080 was open to the internet? Is this hosted on a residential connection?

    Have you tried scanning that IP from outside your local network with something like nmap to see if the ports you think are open are actually open?
    Last edited by CharlesA; April 9th, 2013 at 03:47 AM.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  4. #14
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    1,781
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Server works on Lan but not over internet.

    Hi,

    O.K. sorry, I was wrong before, now I never get any packet returned from 76.29.34.164.80: however I do get: " ICMP host 192.168.1.102 unreachable, length 60" just like was the problem the other day.

    I am using a windows computer and for whatever reason, it behaves like the simple web pages worked after 20 seconds. O.K. so that is annoying.

    O.K. so earlier, yes everything was working fine. I went back to my tcpdump logs and looked at the raw traffic. I can see the TCP session open and the "GET" requests and the web page data being sent and such.
    Everything was definately O.K. for me roughly 50 minutes ago. I wonder if I got blacklisted somehow. ?? ( I mean I can see blacklisting Charles, but not me. ha, ha)
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

  5. #15
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Server works on Lan but not over internet.

    Quote Originally Posted by Doug S View Post
    ( I mean I can see blacklisting Charles, but not me. ha, ha)
    I blame using IE to double check to make sure it wasn't Firefox's fault.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  6. #16
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HELP Server works on Lan but not over internet.

    Quote Originally Posted by danshea View Post
    I can access my site on my lan by using the domain name, so I assume that port 80 is not blocked.
    I guess that depends if you are accessing it from the internal IP when inside the network or if you are accessing it with the external IP and your router supports WAN redirection.

    Since both myself and Doug S cannot access any of your sites, it is safe to say there is some sort of problem with port 80 being blocked (or port forwarding went wacky) because we can ping the IP address just fine.

    Have you verified the IP of the server hosting the websites and verified port forwarding is setup correctly?
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  7. #17
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    1,781
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Server works on Lan but not over internet.

    I am reasonably sure that port 80 is not blocked (upstream from the local server at 192.168.1.102 at least), and reasonably sure that at least the 76.29.34.164 to 192.168.1.102 half of port forwarding is working.
    I base this on the ICMP reply:
    Code:
    2013-04-09 06:51:45.075818 IP 76.29.34.164 > XXX.XXX.XXX.XXX: ICMP host 192.168.1.102 unreachable, length 60
    that I get when trying to send a TCP session open "SYN" packet to 76.29.34.164.80:

    As with the previous thread on this same thing (they should be one thread really), look at your firewall or iptables or whatever and your web server logs and such.
    Perhaps have a look at the packet level with tcpdump, or wireshark if you prefer.
    Code:
    sudo tcpdump -n -nn -tttt -i eth1 port 80
    (change eth1 to whatever your interface is) Do you see the packets arriving at your 192.168.1.102 server? Do you see a reply leaving?
    Last edited by Doug S; April 9th, 2013 at 07:28 PM. Reason: mistake in tcpdump example. Used "host" instead or "port"
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

  8. #18
    Join Date
    Apr 2013
    Beans
    28

    Re: Server works on Lan but not over internet.

    Hi, well since I couldn't figure it out. I decided to reinstall everything, but this time I install ubuntu with openssh and theninstalled nginx with php5-fpm and mysql. right now I am trying to get the domain www.socialpitchman.com up, I have nginx working over my lan, but I get a 502 error on php. I created a phpinfo file and get the error when I try to go to it. weird. Can you dig socialpitchman.com and see what happens?? Thanks,
    Dan

  9. #19
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Server works on Lan but not over internet.

    Are you sure you have Nginx configured correctly to work with PHP?

    I have mine set up like this:

    Code:
    server {
            listen 80;
            server_name charlesa.net;
            access_log /var/log/nginx/charlesa.net_access.log;
            root /var/www/charlesa.net;
            index index.html index.htm index.php;
    
            location ~ \.php$ {
                    fastcgi_split_path_info ^(.+\.php)(/.+)$;
                    # NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini
                    # With php5-fpm:
                    fastcgi_pass unix:/var/run/php5-fpm.sock;
                    fastcgi_index index.php;
                    include fastcgi_params;
            }
    }
    Which version of php did you install? The above config file works fine with PHP5.4 and Nginx 1.2.8-1 (tested on my Debian box, but it should work on Ubuntu).

    Check the /etc/log/php5-fpm.log and see if it has any errors.
    Last edited by CharlesA; April 10th, 2013 at 04:24 AM.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  10. #20
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    1,781
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Server works on Lan but not over internet.

    Same for me, no packets returned except:
    Code:
    2013-04-09 20:29:52.329629 IP 76.29.34.164 > XXX.XXX.XXX.XXX: ICMP host 192.168.1.102 unreachable, length 60
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

Page 2 of 5 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •