Results 1 to 6 of 6

Thread: Can't locate ./lib/*.a

  1. #1
    Join Date
    Dec 2008
    Location
    Scotland
    Beans
    417
    Distro
    Ubuntu 12.04 Precise Pangolin

    Can't locate ./lib/*.a

    I'm trying to install ARToolkit and can't seem to get past this one section in the instructions. I'm supposed to use the following command.
    sudo cp ./lib/*.a /usr/local/lib/

    However I keep getting cannot find file, which is understandable.

    Has anyone any idea how I should proceed?

    I'm following instructions from the following web site. http://tech.enekochan.com/2012/05/01...-ubuntu-10-10/

    Thanks
    Smile . . there's always tomorrow.

  2. #2
    Join Date
    Jan 2011
    Beans
    193

    Re: Can't locate ./lib/*.a

    Did you see them yourself, in the directory where you are...
    The files should exist if compilation went okay.

    When you execute a sudo your current dir may have changed.( Not true, just tested )

    just as a suggestion, I am not familiar with ARTool.

    Update : sudo does not change the current directory
    Last edited by kuifje09; April 9th, 2013 at 12:15 AM.

  3. #3
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    7,366
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Can't locate ./lib/*.a

    kapi; Hi !

    In addition to kuifje09's post; in the command "sudo cp ./lib/*.a"--- the ",/" in "./lib/" says in effect - in this directory -; is your present working directory "that" directory that contains the file to be copied ?

    just try'n to help
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  4. #4
    Join Date
    Dec 2008
    Location
    Scotland
    Beans
    417
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't locate ./lib/*.a

    Quote Originally Posted by Bashing-om View Post
    kapi; Hi !

    In addition to kuifje09's post; in the command "sudo cp ./lib/*.a"--- the ",/" in "./lib/" says in effect - in this directory -; is your present working directory "that" directory that contains the file to be copied ?

    just try'n to help
    Hi, thanks for the replies. I understand the file structure and navigation it's just that when I checked the lib folder in the current directory there didn't appear to be any files with .a as an extension.

    Maybe I'll just start again eh.

    Thanks again
    Smile . . there's always tomorrow.

  5. #5
    Join Date
    Apr 2012
    Beans
    5,523

    Re: Can't locate ./lib/*.a

    If a source distribution involves a local lib directory, that usually means that part of the build process is to create its own .a and/or .so library files - so what was the result of the ./configure and make commands? did they complete successfully or were there errors? if errors occurred then maybe the .a file(s) that you are trying to copy didn't get created

  6. #6
    Join Date
    Dec 2008
    Location
    Scotland
    Beans
    417
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't locate ./lib/*.a

    Quote Originally Posted by steeldriver View Post
    If a source distribution involves a local lib directory, that usually means that part of the build process is to create its own .a and/or .so library files - so what was the result of the ./configure and make commands? did they complete successfully or were there errors? if errors occurred then maybe the .a file(s) that you are trying to copy didn't get created
    Thanks, you may be right. I'll need to check later as I'm not at my laptop.

    Thanks
    Smile . . there's always tomorrow.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •