Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Cannot compile Gnofract4d 3.1.3 from source code

  1. #11
    Join Date
    Apr 2013
    Beans
    7

    Re: Cannot compile Gnofract4d 3.1.3 from source code

    It worked!!!!!! You are a genius!

  2. #12
    Join Date
    Feb 2014
    Beans
    1

    Re: Cannot compile Gnofract4d 3.1.3 from source code

    Hello.

    Apologies in advance as I am totally new to Ubuntu.

    In stepping through the Code, I get the error "E: Unable to locate package python-dev-all" on the sudo apt-get statement.

    Would you please describe how to satisfy this dependency?

    Thank you very much,
    Eli

  3. #13
    Join Date
    Feb 2013
    Beans
    Hidden!

    Re: Cannot compile Gnofract4d 3.1.3 from source code

    The package is now called python-all-dev.

  4. #14
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    6,536
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Cannot compile Gnofract4d 3.1.3 from source code

    @schragge, nice to see you back

  5. #15
    Join Date
    Mar 2014
    Beans
    1

    Re: Cannot compile Gnofract4d 3.1.3 from source code

    Quote Originally Posted by schragge View Post
    UpdateWell, the debian packaging of gnofract4d is an awful hack...
    But there's another problem...

    Code:
    Gnofract4D/test/gnofract4d-3.14.1$ dpkg-buildpackage -us -uc -b
    dpkg-buildpackage: source package gnofract4d
    dpkg-buildpackage: source version 3.14.1-1
    dpkg-buildpackage: source changed by Rachel Mant <dx-mon@users.sourceforge.net>
    dpkg-buildpackage: host architecture amd64
     dpkg-source --before-build gnofract4d-3.14.1
    dpkg-checkbuilddeps: Unmet build dependencies: libjpeg62-dev
    dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
    dpkg-buildpackage: warning: (Use -d flag to override.)
    Attempting to install libjpeg62 requires uninstalling libjpeg8, so...

    Shouldn't this work OK with libjpeg8...???

  6. #16
    Join Date
    Feb 2013
    Beans
    Hidden!

    Re: Cannot compile Gnofract4d 3.1.3 from source code

    Yes, sure. I've just rebuilt the package with libjpeg8-dev and it seems to work. I'm uploading a new version to box.com. Instead of downloading it once again, you can just edit debian/control:
    Code:
    gnofract4d-3.14.1$ sed -i s/jpeg62/jpeg8/ debian/control
    @vasa1
    Nice to see you, too. Unfortunately, I'm mostly away from the forums these days.
    Last edited by schragge; December 16th, 2014 at 04:12 PM.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •