Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 51

Thread: Atheros AR9462 keeps disconnecting.

  1. #11
    Join Date
    Aug 2009
    Beans
    41
    Distro
    Ubuntu

    Re: Atheros AR9462 keeps disconnecting.

    Quote Originally Posted by Wild Man View Post
    Hi, we are going to compile a new driver from compat, I am going to do it on my computer first to make sure it compiles so it will take some time to do that and write the dirctions.
    Thanks
    OK thank's a lot. Before I reformatted the PC I compiled and installed a compat driver but maybe I did it wrong. Bluetooth started working when I did it.

  2. #12
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,056
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Atheros AR9462 keeps disconnecting.

    Which driver did you compile? did you have options ath9k nohwcrypt=1 applied with the compiled driver?
    If the driver installed it should have worked if it was going too.
    Link please and the directions you used.
    Thanks

  3. #13
    Join Date
    Aug 2009
    Beans
    41
    Distro
    Ubuntu

    Re: Atheros AR9462 keeps disconnecting.

    Quote Originally Posted by Wild Man View Post
    Which driver did you compile? did you have options ath9k nohwcrypt=1 applied with the compiled driver?
    If the driver installed it should have worked if it was going too.
    Link please and the directions you used.
    Thanks
    I lost the link when formatting and can't find it but I think it wasn't a specific driver. If I'm not mistaken it said to compile all drivers and then I removed the ones that were beeing used and rebooted. According to the guide the network manager would assume the correct driver but it didn't work. And I think I had the nohwcrypt applied but I'm not sure... I tried so many things it's hard to keep track.

  4. #14
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,056
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Atheros AR9462 keeps disconnecting.

    Okay, I am going to work on it then.
    Thanks

  5. #15
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,056
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Atheros AR9462 keeps disconnecting.

    It is going to take a little longer then expected I have to download 12.10 and install it in virtualbox before I can compile the driver but I have a fast internet connection so the process will not take to long.
    Thanks

  6. #16
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,056
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Atheros AR9462 keeps disconnecting.

    This driver compiled on the kernel you are using with no errors or warning.

    Install linux-headers-generic for your kernel version and build-essentials then:

    Please download compat-wireless-3.6.8-1 from the link below.
    http://linuxwireless.org/en/users/Do...table_releases
    Then drag the file to your desktop right click on it and select extract here:
    Code:
    cd Desktop/compat-wireless-3.6.8-1
    sudo su
    ./scripts/driver-select ath9k
    make
    make install
    exit
    After build and installation unload modules and drivers:
    Code:
    sudo make unload
    sudo modprobe ath9k
    When there is an upgrade to the kernel you will need to recompile this driver:
    Code:
    cd Desktop/compat-wireless-3.6.8-1
    sudo su
    ./scripts/driver-select restore
    ./scripts/driver-select ath9k
    make clean
    make
    make install
    exit
    Copy and paste all commands for accuracy.
    Thanks
    Last edited by Wild Man; April 8th, 2013 at 11:04 PM.

  7. #17
    Join Date
    Aug 2009
    Beans
    41
    Distro
    Ubuntu

    Re: Atheros AR9462 keeps disconnecting.

    OK just finished now I will test and hopefully it's solved. You sound confident.

  8. #18
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,056
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Atheros AR9462 keeps disconnecting.

    You will probably still need this options ath9k nohwcrypt=1.
    I just compiled and installed it I do not have that device so I could not test it.
    Thanks

  9. #19
    Join Date
    Aug 2009
    Beans
    41
    Distro
    Ubuntu

    Re: Atheros AR9462 keeps disconnecting.

    OK so it didn't drop not even once so it seems to be solved. I did lose internet access this morning but it stayed connected and then it came back. Probably a misunderstanding between router and pc. If it's not too much to ask you think you could help me get bluetooth working too?

  10. #20
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,056
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Atheros AR9462 keeps disconnecting.

    Hi, I am glad to hear that it is working!!!

    Did you have to add the parameter to the driver to make it work properly?

    For the bluetooth issue please start a new thread because we are only suppose to have one issue per thread.
    Thanks

Page 2 of 6 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •