Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: white window overlaying desktop

Hybrid View

  1. #1
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    white window overlaying desktop

    I finally bit the bullet, and installed the three gnome ppas, after having nothing but problems on previous installs. This time everything seems to be working OK, except that I have a white window overlaying the desktop. During boot up, after logging in I can see the desktop background I chose before setting up the ppas, but just before the top panel shows, I can see the window open, and completely cover the desktop.

    Has anyone else run into this, and if so what did you do to solve the problem?

  2. #2
    Join Date
    Jun 2007
    Beans
    13,422

    Re: white window overlaying desktop

    You need to disable fm handling the Desktop, what you're seeing is an empty Desktop folder as the background
    Code:
    gsettings set org.gnome.desktop.background show-desktop-icons false

  3. #3
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: white window overlaying desktop

    Quote Originally Posted by mc4man View Post
    You need to disable fm handling the Desktop, what you're seeing is an empty Desktop folder as the background
    Code:
    gsettings set org.gnome.desktop.background show-desktop-icons false
    Should be reported as a bug, as its not easy to find the solution, and has nothing related to "show-desktop-icons"

  4. #4
    Join Date
    Jun 2007
    Beans
    13,422

    Re: white window overlaying desktop

    Quote Originally Posted by dino99 View Post
    Should be reported as a bug, as its not easy to find the solution, and has nothing related to "show-desktop-icons"
    Don't think it's a bug, it seems many are installing Ubuntu then dist-upgrading to the gnome3 ppa(s).
    In that case ubuntu-settings is installed & show-desktop-icons true is set as default.
    I'd suspect that if one used the gnome image that this wouldn't be an issue.

    Can be seen if one removes ubuntu-settings or edits /usr/share/glib-2.0/schemas/10_ubuntu-settings.gschema.override changing key to false, then compiling glib-2.0 schemas. If a new user account is then created it will get a desktop background, which one depends on whether removing ubuntu-settings or editing the .override

  5. #5
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: white window overlaying desktop

    This is really weird, I don't have ubuntu-settings installed, I have desktop-show-icons set to false, and creating a new user, has the same problem.

    This is a gnome install using the Ubuntu Gnome iso, with just normal updates, and then the ppas added

  6. #6
    Join Date
    Jun 2007
    Beans
    13,422

    Re: white window overlaying desktop

    Quote Originally Posted by cariboo907 View Post
    This is really weird, I don't have ubuntu-settings installed, I have desktop-show-icons set to false, and creating a new user, has the same problem.

    This is a gnome install using the Ubuntu Gnome iso, with just normal updates, and then the ppas added
    will have to give that a try later (if you don't figure out why.

    To ck. if you're seeing the Desktop folder is simple, open nautilus > Desktop & add something to the folder. Then log out/in, if what you added is now in your Bg then that's what you are getting.

    Can you change to a normal Bg?

    edit: did you do a dist-upgrade after adding ppa(s)?

  7. #7
    Join Date
    Nov 2008
    Location
    England, near London
    Beans
    36
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: white window overlaying desktop

    Thanks - this sorted my desktop out.

  8. #8
    Join Date
    Mar 2006
    Beans
    4,373
    Distro
    Ubuntu Development Release

    Re: white window overlaying desktop

    I too have been having the white background in gnome shell from the gnome 3 ppa . used gnome-tweak-tool to turn off have file manager handle desktop there and got the normal background back . when I invoked from term I got this ,
    Code:
    INFO    : GSettings missing key org.gnome.nautilus.desktop (key computer-icon-visible)
    . maybe some missing settings are causing the problem .
    if it ain't broke you haven't tweaked it enough

  9. #9
    Join Date
    Jan 2006
    Location
    Denmark
    Beans
    571
    Distro
    Ubuntu Development Release

    Re: white window overlaying desktop

    @ cariboo907
    What does
    Code:
    nautilus --version
    gnome-shell --version
    gdm --version
    give you ?
    Just to check if you have conflicting packages like I did.
    Mine are:
    Code:
    GNOME nautilus 3.8.0
    GNOME Shell 3.8.0.1
    GDM 3.8.0

  10. #10
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: white window overlaying desktop

    Quote Originally Posted by Stinger View Post
    @ cariboo907
    What does
    Code:
    nautilus --version
    gnome-shell --version
    gdm --version
    give you ?
    Just to check if you have conflicting packages like I did.
    Mine are:
    Code:
    GNOME nautilus 3.8.0
    GNOME Shell 3.8.0.1
    GDM 3.8.0
    My versions are

    • GNOME nautilus 3.8.0
    • GNOME Shell 3.8.0.1
    • GDM 3.8.0


    I tried ronacc's suggestion to use tweak tool to unset the file manager managing he desktop, then setting it. When I let nautilus manage the desktop, I see the files I placed in the desktop folder on the desktop. I tried different backgrounds, and the only one that seems to work is /usr/share/backgrounds/gnome/blinds.jpg, if I select anything else, I get the white background. If I use something from my pictures directory, that also works, so I'm going to assume that most of the background files are somehow corrupted. I'll reinstall gnome-backgrounds, and see what happens.

    Update: I cleaned out the archived packages, and reinstalled gnome-backgrounds, and blinds.jpg, is still the only included background that works. I guess I'll use it or something from my pictures directory, until I do a fresh install at the end of the month. Thanks everyone for all the help.
    Last edited by cariboo907; April 5th, 2013 at 09:18 PM.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •