Results 1 to 4 of 4

Thread: Reset desktop choice

  1. #1
    Join Date
    Jun 2005
    Location
    England
    Beans
    2,698

    Reset desktop choice

    So I have done a fresh install of 13.04 beta, is there a way to reset my users default desktop choice as my user seems to try to login to a desktop (Cinnamon) that doesn't exist.

    This is as a result of using my previous /home that I had partitioned.

  2. #2
    Join Date
    Apr 2009
    Location
    UK Lake District
    Beans
    3,053
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Reset desktop choice

    I'd probably go in with one of my parallel installs and delete all the hidden files and folder (except the ones I need and know are OK to leave)
    If you don't have another Linux install in the system, you can do it with Parted Magic
    Ubuntu Member Always something different. Promoting Ubuntu and System 76 at TUXPC

  3. #3
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Reset desktop choice

    I believe you need to edit /var/lib/AccountsService/users/$USER

    eg mine is /var/lib/AccountsService/users/glen

    List your installed sessions
    Code:
    ls /usr/share/xsessions
    and edit /var/lib/AccountsService/users/$USER
    to your chosen session.
    Code:
    gksudo gedit /var/lib/AccountsService/users/$USER

    eg my file
    Code:
    glen@Raring:~$ cat /var/lib/AccountsService/users/glen
    [User]
    Language=en_AU
    XSession=ubuntu
    XKeyboardLayouts=
    Background=/home/glen/Pictures/coffee.jpeg

  4. #4
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Reset desktop choice

    Quote Originally Posted by ELD View Post
    So I have done a fresh install of 13.04 beta, is there a way to reset my users default desktop choice as my user seems to try to login to a desktop (Cinnamon) that doesn't exist.

    This is as a result of using my previous /home that I had partitioned.
    If I got Your question right:

    1. get out of {lightdm,gdm} to tty1 (AltCtrlF1)
    2.1 (if You use LightDM) disable autologin in /etc/lightdm/lightdm.conf
    2.2 (if You use GDM) disable autologin in /etc/gdm/custom.conf
    3. restart GDM
    Code:
    sudo service {lightdm,gdm} restart
    4. choose another WM and You're OK...
    Last edited by zika; April 5th, 2013 at 08:43 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •