Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 41

Thread: 12.04 - Wireless Connectivity

  1. #31
    Join Date
    Jul 2009
    Beans
    1

    Re: 12.04 - Wireless Connectivity

    Tired of this Atheros problem I bought a Sweex LW311 Wireless 300N PC Card (Ralink chipset).

  2. #32
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,925
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: 12.04 - Wireless Connectivity

    Please confirm you rebooted into the new kernel:
    Code:
    uname -r
    Please show me the result of this exact sequence:
    Code:
    sudo modprobe ath9k
    dmesg | grep ath
    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #33
    Join Date
    Mar 2013
    Beans
    27

    Re: 12.04 - Wireless Connectivity

    FATAL: Error inserting ath9k (/lib/modules/3.8.0-030800rc7-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko): Invalid argument


    [ 1.733519] MODSIGN: Loaded cert 'Magrathea: Glacier signing key: ad6a7cd4a8ee89be312cbd1972d8de063ba3ac4b'
    [ 4.412759] usb 8-1: Product: Razer DeathAdder
    [ 12.017932] input: Razer Razer DeathAdder as /devices/pci0000:00/0000:00:09.0/0000:02:00.0/usb8/8-1/8-1:1.0/input/input2
    [ 12.018036] hid-generic 0003:1532:0016.0001: input,hidraw1: USB HID v1.11 Mouse [Razer Razer DeathAdder] on usb-0000:02:00.0-1/input0
    [ 12.172225] ath9k: `y' invalid for parameter `nohwcrypt'
    [ 12.705328] type=1400 audit(1365249499.491:11): apparmor="STATUS" operation="profile_load" name="/usr/lib/telepathy/mission-control-5" pid=970 comm="apparmor_parser"
    [ 33.843681] type=1400 audit(1365249520.699:27): apparmor="DENIED" operation="open" parent=1 profile="/usr/lib/telepathy/mission-control-5" name="/usr/share/gvfs/remote-volume-monitors/" pid=2167 comm="mission-control" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
    [ 51.578596] ath9k: `y' invalid for parameter `nohwcrypt'

  4. #34
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,925
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: 12.04 - Wireless Connectivity

    ath9k: `y' invalid for parameter `nohwcrypt'
    Indeed it is! According to modinfo, it should be an integer; i.e. 0 or 1. That's exactly what the Wild Man asked for:
    echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf
    Let's experiment just a bit:
    Code:
    sudo rm /etc/modprobe.d/ath9k.conf
    That should get rid of the file with the typo. Now do:
    Code:
    echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf
    Check the file:
    Code:
    cat /etc/modprobe.d/ath9k.conf
    It should report: options ath9k nohwcrypt=1.

    Reboot and tell us if your wireless is working better.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #35
    Join Date
    Mar 2013
    Beans
    27

    Re: 12.04 - Wireless Connectivity

    oops that makes sense, haha I was thinking that was the issue but didn't know exactly what to do to change it. Anyway, my networks appear again and it attempts to connect but we are back to the same issue of it attempting to connect and then stopping and asking for the password and trying to connect again.

  6. #36
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,925
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: 12.04 - Wireless Connectivity

    Let's have a look at:
    Code:
    cat /etc/modprobe.d/ath9k.conf
    dmesg | grep -e ath -e wlan
    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #37
    Join Date
    Mar 2013
    Beans
    27

    Re: 12.04 - Wireless Connectivity

    [ 1.727634] MODSIGN: Loaded cert 'Magrathea: Glacier signing key: ad6a7cd4a8ee89be312cbd1972d8de063ba3ac4b'
    [ 4.405365] usb 8-1: Product: Razer DeathAdder
    [ 11.812135] input: Razer Razer DeathAdder as /devices/pci0000:00/0000:00:09.0/0000:02:00.0/usb8/8-1/8-1:1.0/input/input2
    [ 11.812263] hid-generic 0003:1532:0016.0001: input,hidraw0: USB HID v1.11 Mouse [Razer Razer DeathAdder] on usb-0000:02:00.0-1/input0
    [ 12.014712] ath9k 0000:07:00.0: enabling device (0000 -> 0002)
    [ 12.023969] ath: EEPROM regdomain: 0x6a
    [ 12.023970] ath: EEPROM indicates we should expect a direct regpair map
    [ 12.023972] ath: Country alpha2 being used: 00
    [ 12.023973] ath: Regpair used: 0x6a
    [ 12.077734] ieee80211 phy0: Selected rate control algorithm 'ath9k_rate_control'
    [ 12.505144] type=1400 audit(1365350501.300:8): apparmor="STATUS" operation="profile_load" name="/usr/lib/telepathy/mission-control-5" pid=956 comm="apparmor_parser"
    [ 12.817436] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 17.505155] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 17.560614] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 17.616778] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 17.672241] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 17.728435] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 17.783891] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 17.840050] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 17.895519] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 17.951668] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 18.007160] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 18.078587] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 21.292338] wlan0: authenticate with 4c:17:eb:dc:9e:7b
    [ 21.299449] wlan0: direct probe to 4c:17:eb:dc:9e:7b (try 1/3)
    [ 21.499263] wlan0: direct probe to 4c:17:eb:dc:9e:7b (try 2/3)
    [ 21.702509] wlan0: direct probe to 4c:17:eb:dc:9e:7b (try 3/3)
    [ 21.905846] wlan0: authentication with 4c:17:eb:dc:9e:7b timed out
    [ 21.913716] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 26.977498] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 27.041208] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 27.105063] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 27.168474] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 27.232511] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 27.296462] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 27.360126] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 27.424036] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 27.487836] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 27.551287] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 27.615444] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 37.590324] type=1400 audit(1365350526.464:24): apparmor="DENIED" operation="open" parent=1 profile="/usr/lib/telepathy/mission-control-5" name="/usr/share/gvfs/remote-volume-monitors/" pid=1971 comm="mission-control" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

  8. #38
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,925
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: 12.04 - Wireless Connectivity

    [ 27.424036] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 27.487836] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 27.551287] ath: phy0: Failed to stop TX DMA, queues=0x001!
    [ 27.615444] ath: phy0: Failed to stop TX DMA, queues=0x001!
    A Google search suggests this is a well-known bug, although I did read a report that suggested, at least in one case, a hardware defect. Please check here: http://comments.gmane.org/gmane.linu....general/99873

    They suggest the compat-wireless package, however, before you do that, I'd suggest you download and burn the 12.10 live CD and see if the errors go away and, better yet, your wireless works. If you are a bit adventuresome, then I'd just go forward to the 13.04 daily build: http://cdimage.ubuntu.com/daily-live/current/ I have run it myself trouble free, although I'm not sure I have tried every function and feature there is.

    The advantage of the live CD is that you can try it before you install it. If you do decide to install, back up and back up!
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  9. #39
    Join Date
    Mar 2013
    Beans
    27

    Re: 12.04 - Wireless Connectivity

    Thanks for the help :/ I know it's not hardware because I can use it on my Windows installation. I'd LOVE to use 12.10 or 13.04 but they aren't letting me live boot... get stuck on loading screen/go to black screen after load screen. Also, my installation is not affected by windows as I have it on a separate hard drive altogether.

  10. #40
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,640
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 - Wireless Connectivity

    Hi, please post the output of:
    Code:
    cat /etc/lsb-release; uname -a
    modinfo ath9k
    iwconfig
    rfkill list all
    lsmod | egrep 'ath|firm'
    Thanks

Page 4 of 5 FirstFirst ... 2345 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •