Results 1 to 3 of 3

Thread: gnome-control-center black background

  1. #1
    Join Date
    Oct 2012
    Beans
    22

    gnome-control-center black background

    The second problem is weird displaying of background in settings. My gnome-control-center and all it's "subdesktops" display black background. But only if I run them from GUI Activities->Applications. When I run them from terminal, or when I add "Terminal=true", it works fine.


    Is it bug or is there any known solution? I haven't find anything.

    Thanks for help
    Last edited by Kotrfa; April 4th, 2013 at 09:41 AM.

  2. #2
    Join Date
    Aug 2009
    Beans
    881
    Distro
    Ubuntu Development Release

    Re: Super key doesn't work and black screen in settings

    You should ask whoever developed the theme you're using to update their theme for GNOME 3.8.

  3. #3
    Join Date
    Oct 2012
    Beans
    22

    Re: Super key doesn't work and black screen in settings

    That's not the point - I'm using official Adwaita or High contrast theme by default. There isn't option for users theme in 3.8 yet. And changing the theme doesn't change anything. This problem is just in the settings manager.

    EDIT: I've found "workaround" - the gnome-control-center displays ok, when I run it by command from terminal. It looks on the permission problem, but I don't know, what to change. Here is my /usr/share/applications/gnome-control-center.desktop (I deleted keywords for other languages for smaller output just for this thread). When I change "Terminal=false" at "Terminal=true" it works (but the terminal is lunched when I run it). Even when I manually execute it from Nautilus, it displays ok. It occurs only when I run it from applications. By the way it do much more .desktop files, for ex. gnome-notifications-accounts-panel.desktop etc.

    Code:
    vim /usr/share/applications/gnome-control-center.desktop
    
    [Desktop Entry]
    Name=Settings
    Icon=preferences-system
    Exec=gnome-control-center --overview
    Terminal=true
    Type=Application
    StartupNotify=true
    Categories=GNOME;GTK;System;
    OnlyShowIn=GNOME;Unity;
    X-GNOME-Bugzilla-Bugzilla=GNOME
    X-GNOME-Bugzilla-Product=gnome-control-center
    X-GNOME-Bugzilla-Component=shell
    X-GNOME-Bugzilla-Version=3.8.0
    Keywords=Preferences;Settings;
    Keywords[cs]=předvolby;nastavení;
    X-Ubuntu-Gettext-Domain=gnome-control-center-1.0

    I will start other thread for super key.
    Last edited by Kotrfa; April 4th, 2013 at 09:52 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •