Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Option 66 for DHCP server

  1. #1
    Join Date
    Apr 2013
    Beans
    7

    Option 66 for DHCP server

    We are trying to connect to a PBX phone system and the vendor stated that we need to add option 66 to our DHCP server. The line to add is: option 66 ascii siproxy@66.209.232.198:5062 . How can I do that in Ubuntu 12.04?

    Thanks

  2. #2
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,860
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Option 66 for DHCP server

    Your ubuntu is running the dhcp server, right? Is it the built in isc-dhcp-server or how ever it was called?

    You can google about setting the option 66 for the dhcp server package you are using. If I'm not mistaken the 66 is a PXE boot server. Are you sure that line is correct for option 66? I guess the vendor knows what they are talking about.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 14.04 LTS 64bit & Windows 7 Ultimate 64bit

  3. #3
    Join Date
    Nov 2006
    Location
    Craggy Island.
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Option 66 for DHCP server

    Hello

    Option 66 (tftp server address) is usually used in conjunction with option 67 (filename)
    You would add the option to your subnet declaration to allow it to use those parameters

    Here are the options
    http://www.ipamworldwide.com/dhcp-op...4-options.html

    In your declaration you should have something like

    Code:
    option tftp-server-name "ipaddressofserver";
    You can test it by using a wireshark trace and filter DHCP messages,
    in the options you should see the name or IP being handed back to the client.
    You can tell a man who boozes by the company he chooses, as the pig got up and slowly walked away.

  4. #4
    Join Date
    Nov 2006
    Location
    Belgium
    Beans
    3,023
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Option 66 for DHCP server

    Quote Originally Posted by darkod View Post
    If I'm not mistaken the 66 is a PXE boot server. Are you sure that line is correct for option 66? I guess the vendor knows what they are talking about.
    obviously the OP's question is about a config targetted at IP phones. So the correct value of that option will depend on the phones and the phone system the need to connect to, and this indeed can vary by vendor.

  5. #5
    Join Date
    Apr 2013
    Beans
    7

    Re: Option 66 for DHCP server

    I have tried adding the line: option tftp-server-name 66.209.232.198:5062;

    after saving and restarting the dhcp server it says it cannot start. If I remove the line again and restart it will start. Am I missing something?

    Thanks for all the help so far.

  6. #6
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,860
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Option 66 for DHCP server

    Stupid question: Are you touching the correct dhcp server?

    In most offices IP phones (voice) runs on separate VLAN which is like another separate physical LAN. You need this option in the dhcp serving the phones, in case you do have them separated from the data LAN.

    Looks like you are entering the option correctly, but double check the syntax again if the dhcp is not starting after you add the option.

    PS. Also double check with the vendor if you need the text "sip proxy" or similar in front or not. I fail to see what they are trying to do, I guess to connect the phones directly to their system/PBX without you having PBX on-site. Because that IP they gave you is public one.
    Last edited by darkod; April 2nd, 2013 at 08:38 PM.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 14.04 LTS 64bit & Windows 7 Ultimate 64bit

  7. #7
    Join Date
    Nov 2006
    Location
    Belgium
    Beans
    3,023
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Option 66 for DHCP server

    Quote Originally Posted by ejcoon View Post
    I have tried adding the line: option tftp-server-name 66.209.232.198:5062;

    after saving and restarting the dhcp server it says it cannot start. If I remove the line again and restart it will start. Am I missing something?
    Sound like the dhcp server won't start because it trips over the confi file - so that would suggest a syntax error in the line in question. (your syslog or daemon log will probably have details about it)

    Or troubleshoot by trial and error :
    option 66 is a text typed option, maybe quoting it fixes things ?

  8. #8
    Join Date
    Nov 2006
    Location
    Belgium
    Beans
    3,023
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Option 66 for DHCP server

    Quote Originally Posted by darkod View Post
    PS. Also double check with the vendor if you need the text "sip proxy" or similar in front or not. I fail to see what they are trying to do, I guess to connect the phones directly to their system/PBX without you having PBX on-site. Because that IP they gave you is public one.
    dhcp option 66 is just text, not necessarily a server name or ip address. But it does look like they're trying to just pass info to the phones and supposedly the phones will know what to do with it. - a vendor-specific dhcp option might have been a better way of implementing this. Apparently, other phone systems do something similar, eg look here : http://www.3cx.com/sip-phones/dhcp-option-66/

  9. #9
    Join Date
    Apr 2013
    Beans
    7

    Re: Option 66 for DHCP server

    I will try the option with varying syntax. Should it matter where in the config file it is inserted (ie in the {} for the scope)? We are connecting across a dark fiber (layer 2 path) that connects to a VLAN with Layer 3 but the vendor failed to mention needing a DHCP server in place to complete the install.

    Thanks again.

  10. #10
    Join Date
    Nov 2006
    Location
    Craggy Island.
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Option 66 for DHCP server

    Hello


    Im not sure why the :5062 is in there.
    tftp runs on port 69 UDP

    Port 5060 is the SIP signalling port which sounds close to your 5062, but IM not sure why the port number is defined there.
    Im pretty sure adding :5062 is stopping DHCP from starting
    You can tell a man who boozes by the company he chooses, as the pig got up and slowly walked away.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •