Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Cairo dock 3.2 wrong position on raring desktop

Hybrid View

  1. #1
    Join Date
    Mar 2013
    Beans
    8

    Cairo dock 3.2 wrong position on raring desktop

    I had tried until three times, may be more to fix this trouble of Cairo Dock v3.2 position on my Raring Desktop. I don't know why, Cairo Dock always show wrong position, as you can see on my pict attached here. I must be at the center on the edge of bottom. I can fix it, by configuring via System -> Composition. Then, give thick on the Composition, click Apply, and remove thick on the Composition, then Apply. But can you explain why Cairo Dock show wrong position on my Raring desktop? Note, I run Cairo Dock with OpenGL.

    Last edited by leo4kusuma; April 10th, 2013 at 11:13 PM.

  2. #2
    Join Date
    Feb 2010
    Location
    WI USA
    Beans
    9,787
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Cairo dock 3.2 wrong position on raring desktop

    It could have something to do with the fact that 13.04 is still beta. Although 13.04 has reached beta freeze there are still many updates forth coming. I have had 60 + the last 2 days. You may have to wait for someone who is running Cairo Dock on 13.04.
    Infinite diversity in infinite combination.

    Ubuntu Documentation Search: Popular Pages
    Ubuntu: Security Basics
    Ubuntu: Manual

  3. #3
    Join Date
    May 2007
    Location
    The New Forest
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Cairo dock 3.2 wrong position on raring desktop

    Thread moved to Ubuntu +1 (Raring Ringtail).
    Forum Social IRC Channel
    Xubuntu IRC Support
    Xubuntu Support

    Please do not PM me about Registration issues without having been asked to. I will tell you to post here

  4. #4
    Join Date
    Apr 2007
    Location
    Denmark
    Beans
    2,858
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Cairo dock 3.2 wrong position on raring desktop

    Quote Originally Posted by leo4kusuma View Post
    I had tried until three times, may be more to fix this trouble of Cairo Dock v3.2 position on my Raring Desktop. I don't know why, Cairo Dock always show wrong position, as you can see on my pict attached here. I must be at the center on the edge of bottom. I can fix it, by configuring via System -> Composition. Then, give thick on the Composition, click Apply, and remove thick on the Composition, then Apply. But can you explain why Cairo Dock show wrong position on my Raring desktop? Note, I run Cairo Dock with OpenGL.
    In Compiz Settings Manager try to uncheck Unity Plugin,
    and log out

  5. #5
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,831
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Cairo dock 3.2 wrong position on raring desktop

    Quote Originally Posted by Ringi View Post
    In Compiz Settings Manager try to uncheck Unity Plugin,
    and log out
    If You uncheck Unity and do not have any other WM how will You be able to get it back...?
    I know, it could be done throgh CLI but, I'm not sure everybody know how...
    Be carefull with Your advices...
    Let's say that I might be wrong, but I would like that ergo that way I would learn something new...
    Last edited by zika; April 2nd, 2013 at 08:34 PM.

  6. #6
    Join Date
    Jun 2007
    Beans
    12,905

    Re: Cairo dock 3.2 wrong position on raring desktop

    Quote Originally Posted by zika View Post
    If You uncheck Unity and do not have any other WM how will You be able to get it back...?
    I know, it could be done throgh CLI but, I'm not sure everybody know how...
    Be carefull with Your advices...
    Let's say that I might be wrong, but I would like that ergo that way I would learn something new...
    Being that's it's mainly a plugin for the Wm (compiz), you can disable unity without too much going away. To re-enable just simply open ccsm & enable.

    (running a ubuntu session without unity may need a few adjustments because of all the gschemas/overrides, ect., but wouldn't be to hard to work out.

  7. #7
    Join Date
    Jul 2007
    Beans
    1,085

    Re: Cairo dock 3.2 wrong position on raring desktop

    Instead of disabling Unity from ccsm, prefer to log into a Cairo-dock session.
    This way, you can have a light session with cairo-dock, without messing up with the Unity session.

    PS: you may have to enable the application switcher (alt+tab) in ccsm.
    Refresh your desktop with GLX-Dock !
    Installation of the latest stable version for Ubuntu in 1 copy-paste :
    http://www.glx-dock.org/ww_page.php?...sitory&lang=en

  8. #8
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,831
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Cairo dock 3.2 wrong position on raring desktop

    Quote Originally Posted by mc4man View Post
    Being that's it's mainly a plugin for the Wm (compiz), you can disable unity without too much going away. To re-enable just simply open ccsm & enable.

    (running a ubuntu session without unity may need a few adjustments because of all the gschemas/overrides, ect., but wouldn't be to hard to work out.
    I'll have to play (again, after quite a time) with Unity... I, usually, start it via startx/xinit so I'll have to find a way to start compiz without Unity...
    Code:
    exec /usr/bin/ck-launch-session /usr/bin/gnome-session --session=ubuntu
    might do the trick, I'll try...
    Update₁: Yeap, that works, and that doesn't have Unity started... Thank You for making me try this... Downside: custom keyboard shortcuts still do not work, but that is because I have all GS PPAs turned on... Upside: I get clean black screen and no bars, panels, notnihg... Nice...
    As I've wrote, I like that I've learned something new, again...
    http://www.youtube.com/watch?v=3PszMaZ5Ipk
    Last edited by zika; April 3rd, 2013 at 11:25 AM.

  9. #9
    Join Date
    Aug 2009
    Beans
    3,078
    Distro
    Ubuntu Development Release

    Re: Cairo dock 3.2 wrong position on raring desktop

    Never had a problem with Cairo Dock 3.2 in Gnome fallback or Unity.
    Don't know what to tell you.

    Check Java Version | Install Java via WEB UPD8 PPA
    Creating a Custom Maintenance Free GRUB2 Screen Community Wiki
    Ubuntu 12.04 | 14.04 | 14.10 | Mint 13 | Mint 17 | Windows 7 | All 64 bit

  10. #10
    Join Date
    Jan 2013
    Beans
    525

    Re: Cairo dock 3.2 wrong position on raring desktop

    DO NOT UNCHECK THE UNITY PLUGIN, YOU WILL LOOSE THE WHOLE DESKTOP!

    Instead, disable multiple desktops. In Unity, multiple desktops are treated as congruent so Cairo-Dock is being stretch between screen 1 and 2. with Multiple Desktops disabled, there will be one desktop and Cairo will be centered.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •