Results 1 to 4 of 4

Thread: Java plugins stopped working in browser

Threaded View

  1. #1
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Java plugins stopped working in browser

    OK... sort of at a loss. Java "was" working great, until today? as far as I know, it's working, but not on FireFox nor Chrome. Both say they "Cannot load Java(TM) Plugin 1.7.15."

    I have OpenJavaJDK's 6 and 7 (default). Oracle JDK and JRE version 7... NetBeans and Eclispe JEE. I've been converting and revamping some server Management Utiltiies for my servers, which some are Java app's and Java Web app's.

    So locally everything seems to be fine. Browser are now boinked for "some" reason.
    Code:
    mafoelffen@maferr-ubuntu-1:~$ java -version
    java version "1.7.0_17"
    Java(TM) SE Runtime Environment (build 1.7.0_17-b02)
    Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)
    Code:
    mafoelffen@maferr-ubuntu-1:~$ dpkg -l | grep -i openjdk
    ii  icedtea-7-jre-jamvm:amd64              7u15-2.3.7-0ubuntu1~12.10.1               amd64        Alternative JVM for OpenJDK, using JamVM
    ii  icedtea-7-plugin:amd64                    1.3-1ubuntu1.1                                   amd64        web browser plugin based on OpenJDK and IcedTea to execute Java applets
    rc  openjdk-6-jre-headless:amd64          6b27-1.12.3-0ubuntu1~12.10                amd64        OpenJDK Java runtime, using Hotspot JIT (headless)
    ii  openjdk-7-jdk:amd64                       7u15-2.3.7-0ubuntu1~12.10.1               amd64        OpenJDK Development Kit (JDK)
    ii  openjdk-7-jre:amd64                       7u15-2.3.7-0ubuntu1~12.10.1               amd64        OpenJDK Java runtime, using Hotspot JIT
    ii  openjdk-7-jre-headless:amd64          7u15-2.3.7-0ubuntu1~12.10.1               amd64        OpenJDK Java runtime, using Hotspot JIT (headless)
    ii  openjdk-7-jre-lib                             7u15-2.3.7-0ubuntu1~12.10.1               all          OpenJDK Java runtime (architecture independent libraries)
    And
    Code:
    mafoelffen@maferr-ubuntu-1:~$ echo "JAVA_HOME: $JAVA_HOME" && ls -l $JAVA_HOME/jre/lib/amd64/libnpjp2.so && ls -l ~/.mozilla/plugins/
    JAVA_HOME: /usr/lib/jvm/jdk1.7.0
    -rwxr-xr-x 1 mafoelffen mafoelffen 203560 Feb 15 13:19 /usr/lib/jvm/jdk1.7.0/jre/lib/amd64/libnpjp2.so
    total 0
    lrwxrwxrwx 1 mafoelffen mafoelffen 46 Feb 23 13:05 libnpjp2.so -> /usr/lib/jvm/jdk1.7.0/jre/lib/i386/libnpjp2.so


    But I did upgrade Eclipse 2 days ago from the repo version 3.8 (removed through Software Center) to Juno, v 4.2 becuase the Anroid SDK wasn't working right with the older Eclipse version.
    Code:
    Start-Date: 2013-03-28  09:20:09
    Commandline: aptdaemon role='role-remove-packages' sender=':1.76'
    Remove: libtomcat7-java:amd64 (7.0.30-0ubuntu1.1), libdb5.1-java-gcj:amd64 (5.1.29-5ubuntu2), libcommons-pool-java:amd64 (1.5.6-1build1), libdb-je-java:amd64 (3.3.98-1), junit4:amd64 (4.10-3), libgeronimo-jta-1.1-spec-java:amd64 (1.1.1-2ubuntu2), libecj-java:amd64 (3.5.1-4), eclipse-jdt:amd64 (3.8.0~rc4-1ubuntu1), libdb5.1-java-jni:amd64 (5.1.29-5ubuntu2), eclipse-platform-data:amd64 (3.8.0~rc4-1ubuntu1), libxerces2-java:amd64 (2.11.0-6), libswt-gtk-3-jni:amd64 (3.8.0~rc4-1), libxz-java:amd64 (1.1-1), eclipse-pde:amd64 (3.8.0~rc4-1ubuntu1), libjtidy-java:amd64 (7+svn20110807-4), libicu4j-java:amd64 (4.2.1.1-1), eclipse-rcp:amd64 (3.8.0~rc4-1ubuntu1), libaspectj-java:amd64 (1.6.12+dfsg-3), libswt-cairo-gtk-3-jni:amd64 (3.8.0~rc4-1), libcommons-beanutils-java:amd64 (1.8.3-3), libjetty8-java:amd64 (8.1.3-4), libosgi-compendium-java:amd64 (4.3.0-1), junit:amd64 (3.8.2-8build1), libdb-java:amd64 (5.1.6), libgeronimo-jpa-2.0-spec-java:amd64 (1.1-2), libkxml2-java:amd64 (2.3.0+ds1-2), libcommons-cli-java:amd64 (1.2-3ubuntu1), libfelix-gogo-runtime-java:amd64 (0.10.0-1), libcommons-logging-java:amd64 (1.1.1-9ubuntu1), libcommons-compress-java:amd64 (1.4.1-2ubuntu1), libfelix-gogo-shell-java:amd64 (0.10.0-1), libswt-gtk-3-java:amd64 (3.8.0~rc4-1), libdb5.1-java:amd64 (5.1.29-5ubuntu2), libicu4j-4.4-java:amd64 (4.4.2.2-1), libswt-gnome-gtk-3-jni:amd64 (3.8.0~rc4-1), libosgi-foundation-ee-java:amd64 (4.2.0-1), ant:amd64 (1.8.2-4build2), libservlet3.0-java:amd64 (7.0.30-0ubuntu1.1), default-jdk:amd64 (1.7-43ubuntu3), aspectj:amd64 (1.6.12+dfsg-3), libjsch-java:amd64 (0.1.48-0ubuntu1), libeasymock-java:amd64 (2.4+ds1-7), jarwrapper:amd64 (0.43ubuntu2), libxml-commons-resolver1.1-java:amd64 (1.2-7build1), ant-optional:amd64 (1.8.2-4build2), libapache-pom-java:amd64 (10-2build1), libxml-commons-external-java:amd64 (1.4.01-2build1), libcommons-dbcp-java:amd64 (1.4-3ubuntu1), libosgi-core-java:amd64 (4.3.0-3), sat4j:amd64 (2.3.1-1ubuntu1), eclipse:amd64 (3.8.0~rc4-1ubuntu1), libservlet2.5-java:amd64 (6.0.35-5), libcommons-httpclient-java:amd64 (3.1-10build1), libasm3-java:amd64 (3.3.2-1build1), libregexp-java:amd64 (1.5-3build1), libfelix-gogo-command-java:amd64 (0.12.0-2), fastjar:amd64 (0.98-4), libcommons-codec-java:amd64 (1.6-1), libcommons-lang-java:amd64 (2.6-3ubuntu2), libhamcrest-java:amd64 (1.2-2build1), liblucene2-java:amd64 (2.9.4+ds1-4), libfelix-osgi-obr-java:amd64 (1.0.2-3fakesync1), libgeronimo-osgi-support-java:amd64 (1.0-2), libequinox-osgi-java:amd64 (3.8.0~rc4-1ubuntu1), libcommons-parent-java:amd64 (22-2build1), libcommons-collections3-java:amd64 (3.2.1-5build1), eclipse-platform:amd64 (3.8.0~rc4-1ubuntu1), libfelix-bundlerepository-java:amd64 (1.6.6-1), libcommons-digester-java:amd64 (1.8.1-3), libjline-java:amd64 (1.0-2), libswt-webkit-gtk-3-jni:amd64 (3.8.0~rc4-1), libswt-glx-gtk-3-jni:amd64 (3.8.0~rc4-1)
    End-Date: 2013-03-28  09:21:10
    Anyone with ideas on getting the Browser plugins working again?
    Last edited by MAFoElffen; April 1st, 2013 at 09:31 PM.
    Multi-Boot= Various flavours of Windows, Linux and Unix... Ubuntu user # 33563, Linux user # 533637
    Sticky: [all variants] Graphics Resolution- Upgrade /Blank Screen after reboot
    Boot Info Script courtesy of community member meierfra

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •