Results 1 to 6 of 6

Thread: Please help! nVidia Geforce 460gtx driver.

  1. #1
    Join Date
    Mar 2013
    Beans
    6

    Please help! nVidia Geforce 460gtx driver.

    I installed today Ubuntu 12.10 (64 bit !!) and Mate 1.4.2 Desktop.
    My regular resolution is 1680x1050 but it allowed me only 1024x768.
    OK, so i read a little and installed the nvidia drivers using the apt-get install nvidia-current and also nvidia-current-update.
    But it did no good. now i have 800x600 resolution. I tried to remove it and re-install but it didn't help. I also tried to install the driver manually (downloading the .run file) but it failed becuase of some missing kernel (after i finally found that i need to stop lightdm in order to install it). Well, i m really frustrated.
    Please help.
    thanks.

  2. #2
    Join Date
    Mar 2013
    Beans
    6

    Re: Please help! nVidia Geforce 460gtx driver.

    No one ?
    I'm really stuck

  3. #3
    Join Date
    Mar 2013
    Beans
    6

    Re: Please help! nVidia Geforce 460gtx driver.

    YESSSS !!!
    If anyone have the same issue, this solved my problem :
    http://podzemski.com/2012/10/20/ubun...vidia-drivers/

  4. #4
    Join Date
    Feb 2008
    Beans
    41

    Re: Please help! nVidia Geforce 460gtx driver.

    Have you tried running the restricted drivers utility. It pulls the drivers from nvidia and sets them up for you, Use the latest experimental if you wanna use steam
    Windows users converted: 21
    --AMD Athlon(tm) II X4 640 Processor × 4 (3.0ghz) | 8gig 1333mhz memory | nvidia geforce gtx 430(fermi)| 750G SATAII

  5. #5
    Join Date
    Jul 2011
    Beans
    5

    Re: Please help! nVidia Geforce 460gtx driver.

    Hi there,

    I am having the same issue with my 470 GTX. However After chaning a frew things I can now set it in nvidia-settings, but it keeps going back after a reboot.

    This is my xorg.conf file

    Code:
    root@lxhome:/var/log# cat /etc/X11/xorg.conf
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 304.51  (buildd@batsu)  Fri Oct 12 12:53:54 UTC 2012
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "DELL 2707WFP"
        HorizSync       30.0 - 81.0
        VertRefresh     56.0 - 76.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GTX 470"
    #   Option "IgnoreEDID" "1"
    #   Option "NoDDC"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "nvidiaXineramaInfoOrder" "DFP-0"
    #   Option         "nvidiaXineramaInfoOrder" "DVI-0"
    #   Option         "metamodes" "1920x1200 +0+0; nvidia-auto-select +0+0"
        Option         "metamodes" "DFP-0: 1920x1200 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    root@lxhome:/var/log#
    I can see it in the log file selecting 1024x768:

    [ 5.438] (II) NVIDIA(GPU-0): Display (DELL 2707WFP (DFP-0)) does not support NVIDIA 3D
    [ 5.438] (II) NVIDIA(GPU-0): Vision stereo.
    [ 5.438] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
    [ 5.438] (**) NVIDIA(0): device DELL 2707WFP (DFP-0) (Using EDID frequencies has
    [ 5.438] (**) NVIDIA(0): been enabled on all display devices.)
    [ 5.632] (II) NVIDIA(0): Setting mode "NULL"
    [ 5.641] (II) NVIDIA(0): Setting mode "DVI-I-2: 1024x768 @1024x768 +0+0"
    [ 5.807] (II) NVIDIA(GPU-0): Display (DELL 2707WFP (DFP-0)) does not support NVIDIA 3D
    [ 5.807] (II) NVIDIA(GPU-0): Vision stereo.
    [ 5.807] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
    [ 5.807] (**) NVIDIA(0): device DELL 2707WFP (DFP-0) (Using EDID frequencies has
    [ 5.807] (**) NVIDIA(0): been enabled on all display devices.)



    Then when I change it:

    [ 7.189] (**) NVIDIA(0): device DELL 2707WFP (DFP-0) (Using EDID frequencies has
    [ 7.189] (**) NVIDIA(0): been enabled on all display devices.)
    [ 18.582] (WW) NVIDIA(0): Specified panning domain height of 720 is smaller than
    [ 18.582] (WW) NVIDIA(0): viewport height 1200; adjusting
    [ 18.650] (II) NVIDIA(0): Setting mode "DVI-I-2:1920x1200"
    [ 22.189] (WW) NVIDIA(0): Specified panning domain width of 1280 is smaller than
    [ 22.189] (WW) NVIDIA(0): viewport width 1920; adjusting



    I have not yet found the setting to keep it at 1920x1200 at boot.

  6. #6
    Join Date
    Jul 2011
    Beans
    5

    Re: Please help! nVidia Geforce 460gtx driver.

    I have been trying some different settings and I have a configuration that works.
    Code:
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "False" #  <==== stops compiz when set to True
    
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
    
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "DELL 2707WFP"
        HorizSync       30.0 - 81.0
        VertRefresh     56.0 - 76.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GTX 470"
    EndSection
    
    Section "Screen"
    
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "metamodes"      "DFP-0: 1920x1200_60 +0+0; nvidia-auto-select +0+0"
        Option         "Stereo"         "0"
        Option         "nvidiaXineramaInfoOrder" "DFP-0"
        Option         "NoDDC"            "True"
        Option         "ModeValidation" "AllowNonEdidModes"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    It might be a good starting point.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •