Results 1 to 9 of 9

Thread: VLC does not respect "disable screensaver" setting

  1. #1
    Join Date
    Oct 2004
    Beans
    Hidden!

    VLC does not respect "disable screensaver" setting

    When playing DVDs or videos through VLC, the screensaver kicks in even though "disable screensaver" is ticked in tools->prefs->advanced->video. I have no idea why.

    I have another machine with very similar hardware & software packages installed (nvidia accelerated driver 185 on both) and the setting works correctly on the other machine.

    Where would I start digging to figure this out?

    edit:

    Oops, I just thought of this; it might actually be a big deal. (/facepalm)

    the biggest difference between the two machines is the one that works correctly is 32-bit and was first installed with the Karmic RC release, then upgraded to "official". The one that does not work is 64-bit, installed from the "official" release.
    Last edited by negativ; November 22nd, 2009 at 02:48 PM.

  2. #2
    Join Date
    Aug 2006
    Location
    Bountiful, Utah
    Beans
    236
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: VLC does not respect "disable screensaver" setting

    I am having this same issue on my machine and it is a fresh install 32 bit. I don't think it is the bit's that is the issue.
    UNDERTAKINGYOU--
    ------------------------

  3. #3
    Join Date
    Jun 2005
    Location
    Grenoble (France)
    Beans
    19
    Distro
    Ubuntu

    Re: VLC does not respect "disable screensaver" setting


  4. #4
    Join Date
    Feb 2009
    Beans
    20

    Re: VLC does not respect "disable screensaver" setting

    So, there is still nothing for this issue? Any workaround or anything?

  5. #5
    Join Date
    Sep 2009
    Beans
    2,330

    Re: VLC does not respect "disable screensaver" setting

    totem turns the screen saver off in/on 910
    you may find settings in it

  6. #6
    Join Date
    Oct 2007
    Location
    Oregon, USA
    Beans
    1,534

    Re: VLC does not respect "disable screensaver" setting

    There's an app called "caffeine" whose purpose is to disable/prevent screen-savers, sleep, etc.

    http://www.omgubuntu.co.uk/2009/08/c...ersuspend.html

  7. #7
    Join Date
    Feb 2009
    Beans
    20

    Re: VLC does not respect "disable screensaver" setting

    Quote Originally Posted by Chronon View Post
    There's an app called "caffeine" whose purpose is to disable/prevent screen-savers, sleep, etc.

    http://www.omgubuntu.co.uk/2009/08/c...ersuspend.html
    Thanks that looks like a cool little program. I tried installing using the PPA, but I got an error when it was requesting the key:

    gpg: keyserver timed out
    gpg: keyserver receive failed: keyserver error

  8. #8
    Join Date
    Mar 2013
    Beans
    1

    Talking Re: VLC does not respect "disable screensaver" setting

    SOLVED!!!

    For easy understanding, the below instructions are shown in this video:

    http://www.youtube.com/watch?v=hmyPbhwjBn0

    Since this problem is related to the operating system of any computer, this solution works for any other video player which has the same problem on screensavers.


    How to disable VLC player's Screensaver for good!


    While playing or after played a video on VLC, the Windows screensaver will come on (activate).


    The settings option within the VLC won't work to disable it. See the path:

    VLC -Tools - Preferences Go to left bottom column at Show settings and activate All button. Navigate down to Video section. Mark the option "Disable screensaver" All that won't disable the screensaver because VLC is related to your Windows settings for screensaver.

    Therefore, go to Desktop, right-click, and go to Screensaver options. In Windows Vista is: right-click on Desktop - Personalize - Screen Saver.

    Look at "Wait" value. If it says 10 minutes, VLC will activate the screensaver after 10 minutes of idle, EVEN THOUGH your windows screensaver is deactivated. If it say 1 minute, VLC will do it after 1 minute, and so on.

    To fix all this problem, is to cheat: change the value to a very high one, like 480 minutes.

    Change the value activating the screen saver and deactivating it just like i did before.

    From now on, VLC won't bother you at all.

  9. #9
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: VLC does not respect "disable screensaver" setting

    Very old thread. Closed.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •