Results 1 to 10 of 10

Thread: How to disable Twinview

  1. #1
    Join Date
    Mar 2012
    Beans
    246

    How to disable Twinview

    Hi.

    I need Your help. Could You help me?

    I have problem with TwinView with nVidia drivers on Ubuntu 12.04. I user 310.19 but this problem occurs on all nvidia drivers - exept nouveau.

    It is related to recognizing more than one screen, and that is not right - i have only one.

    It looks like on attached picture. When i boot to ubuntu destkop nvidia sees two screens and my picture is stretched to both of them. Some screen goes for "fake crt" (i don't have crt), and rest goes for my LCD flat screen (HP).

    Is there a way to completly disable TwinView, prevent it from working, from detecting more than one screen when, in fact, i have only one?

    I think that option in Xorg.conf "TwinView" "off" doesen't help:

    Code:
    firekage@deusex:~$ cat /etc/X11/xorg.conf
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 310.19  (buildmeister@swio-display-x86-rhel47-11)  Thu Nov  8 00:25:56 PST 2012
    
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 310.19  (buildmeister@swio-display-x86-rhel47-11)  Thu Nov  8 00:26:06 PST 2012
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
        FontPath        "unix/:7100"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "HP w2228h"
        HorizSync       24.0 - 83.0
        VertRefresh     48.0 - 76.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GTX 260"
    EndSection
    
    Section "Screen"
    
    # Removed Option "metamodes" "nvidia-auto-select +0+0; nvidia-auto-select +0+0; nvidia-auto-select +0+0"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option "TwinView" "off"
        Option "TwinView "false"
        Option         "Stereo" "0"
        Option         "nvidiaXineramaInfoOrder" "DFP-0"
        Option         "metamodes" "1680x1050 +0+0; nvidia-auto-select +0+0; nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    firekage@deusex:~$
    Maybe it is related to "metamodes" and the rest after it?


    When i boot up, and when nvidia detects more than one screen, i have ti "fight" in order to disable it but after reboot the same thing happens. If im lucky, than i'm able to run terminal, and in it run nvidia-settings (but it often runs in "crt fake screen" and i can't set up it because it is on far left "fake screen").


    I attached second picture, it shows how it looks when "second screen" is detected - i have only one!
    Attached Images Attached Images
    Last edited by firekage; December 26th, 2012 at 06:26 PM.

  2. #2
    Join Date
    Mar 2012
    Beans
    246

    Re: How to disable Twinview

    Help? Anyone?

  3. #3
    Join Date
    Mar 2012
    Beans
    246

    Re: How to disable Twinview

    Up...

  4. #4
    Join Date
    Mar 2012
    Beans
    246

    Re: How to disable Twinview

    Up.

  5. #5
    Join Date
    May 2008
    Location
    India
    Beans
    7
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: How to disable Twinview

    What happens when you choose "Detect Displays" in Nvidia X Server Settings?

    Nvidia X Server Settings > X Server Display Configuration -> Detect Displays

    If it shows you just one display, you could configure it as per your requirements and then before exiting the program, use the "Save to X Configuration File" option to overwrite your xorg.conf with the current settings.

    That should ensure proper behaviour across reboots.

  6. #6
    Join Date
    Jun 2010
    Location
    Phoenix, AZ
    Beans
    147
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to disable Twinview

    I had a similar problem, except I actually had two monitors hooked up to my Nvidia GeForce 8400 GS. The second monitor was being used as a tv. I couldn't get the screen to show everything. You could see the missing part when rotating the Compiz Cube I had enabled. I had Conky and Cairo Dock running, but I couldn't access them. My Nvidia X-server Settings tool would always default to the secondary monitor with Twinview.

    What worked for me was unplugging the secondary monitor from my video card and rebooting. I know this probably won't help you, but the problem is so similar I thought it might help someone.
    ASRock 970 Extreme4, 8GB RAM
    AMD FX
    ™- 4100 Quad-Core
    nVidia GeForce 8400 GS

    2 500GB SATA HDs

  7. #7
    Join Date
    Mar 2012
    Beans
    246

    Re: How to disable Twinview

    Quote Originally Posted by crk View Post
    What happens when you choose "Detect Displays" in Nvidia X Server Settings?

    Nvidia X Server Settings > X Server Display Configuration -> Detect Displays

    If it shows you just one display, you could configure it as per your requirements and then before exiting the program, use the "Save to X Configuration File" option to overwrite your xorg.conf with the current settings.

    That should ensure proper behaviour across reboots.
    That's the problem...when i click on 'detect displays" here is what happens - attached screen. Don't know why. I have only one screen. I was luckily enough because on this picture i caught exacly how the screen looks like when the problem occurs. One small screen, one big screen with just one flat screen! Strange...
    Attached Images Attached Images

  8. #8
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    4,438
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: How to disable Twinview

    in my moms /etc/X11/xorg.conf the second monitor is off by default i did this by usign nvidia settings, this is the code it used to do it
    Code:
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-1: NULL"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    i have her system using the xorg edgers ppa
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  9. #9
    Join Date
    Mar 2012
    Beans
    246

    Re: How to disable Twinview

    Quote Originally Posted by pqwoerituytrueiwoq View Post
    in my moms /etc/X11/xorg.conf the second monitor is off by default i did this by usign nvidia settings, this is the code it used to do it
    Code:
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-1: NULL"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    i have her system using the xorg edgers ppa

    Thank You. I will try this.

  10. #10
    Join Date
    Mar 2012
    Beans
    246

    Re: How to disable Twinview


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •